Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

l666deicide666l

Members
  • Posts

    4
  • Joined

  • Last visited

Posts posted by l666deicide666l

  1. 7 minutes ago, DaemonUmbra said:

    I think you'll have to do bin/java, the whole thing


    Ok thats really good to know in general.

    /usr/lib/jvm/java-8-openjdk-amd64/bin/java -server -Xms${MIN_RAM} -Xmx${MAX_RAM} ${JAVA_PARAMETERS} -jar ${FORGE_JAR} nogui

    where "/usr/lib/jvm/java-8-openjdk-amd64/bin/java" is the direct path to java 8.

    This works. ?

     

    Now i just need to create some $java8 system variable and im satisfied ?

  2. Im currently having an issue with
    forge 1.12.2 - 14.23.5.2838
    (I also tried 2768)

    on my linux machine.

    Stacktrace while starting

    Spoiler

    Starting forge server...
    A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException
            at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
            at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
            at java.base/java.lang.reflect.Method.invoke(Method.java:566)
            at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:70)
            at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:34)
    Caused by: java.lang.ClassCastException: class jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to class java.net.URLClassLoader (jdk.internal.loader.ClassLoaders$AppClassLoader and java.net.URLClassLoader are in module java.base of loader 'bootstrap')
            at net.minecraft.launchwrapper.Launch.<init>(Launch.java:34)
            at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
            ... 6 more

     

     

    jvm parameters
    -XX:+UseG1GC -Dsun.rmi.dgc.server.gcInterval=2147483646 -XX:+UnlockExperimentalVMOptions -XX:G1NewSizePercent=20 -XX:G1ReservePercent=20 -XX:MaxGCPauseMillis=50 -XX:G1HeapRegionSize=32M -Dfml.readTimeout=180

    java version (11)

    Spoiler

    java version "11.0.2" 2019-01-15 LTS
    Java(TM) SE Runtime Environment 18.9 (build 11.0.2+9-LTS)
    Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11.0.2+9-LTS, mixed mode)


    My first guess is that this has something to do with my java version. This error might occur with java 9 and above.

    If im right:
    Does someone know a way to start this forge version with java 11
    or
    Install java 8 parallel to java 11 and use the old version through launch options?

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.