Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

TekxWolf

Members
  • Posts

    2
  • Joined

  • Last visited

Posts posted by TekxWolf

  1. Hey I'm relatively new to Minecraft Modding using forge, I'm somewhat rehearsed with the Sponge API and I am a experienced Bukkit/Spigot Plugineer.

    But up until now I've never actaully tried to run Minecraft from within the Eclipse IDE.

    I tried following a few Tutorials from YouTube on how to do this but none work.

     

    Strange part is though, when i use

    ./gradlew runClient

    Everything runs fine aside from a weird spash.properties error or something.

    But when I run in Eclipse using:

    net.minecraft.launchwrapper.Launch

    for my main class and

    --userProperties, {}, --assetsDir, /home/darkwolf/.gradle/caches/minecraft/assets, --assetIndex, 1.8, --accessToken, {REDACTED}, --version, 1.8, --tweakClass, net.minecraftforge.fml.common.launcher.FMLTweaker, --tweakClass, net.minecraftforge.gradle.tweakers.CoremodTweaker

    for the arguments I get the following error in my Eclipse 'Console'

    [04:37:53] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraft.launchwrapper.VanillaTweaker
    [04:37:53] [main/INFO] [LaunchWrapper]: Using primary tweak class name net.minecraft.launchwrapper.VanillaTweaker
    [04:37:53] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraft.launchwrapper.VanillaTweaker
    [04:37:53] [main/ERROR] [LaunchWrapper]: Unable to launch
    java.lang.NoSuchMethodException: net.minecraft.client.Minecraft.main([Ljava.lang.String;)
    at java.lang.Class.getMethod(Class.java:1786) ~[?:1.8.0_51]
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:132) [launchwrapper-1.12.jar:?]
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]
    

     

    So any help to understand how to resolve this would be greatly appreciated, In the meantime I guess I will just have to stick to using runClient from the command line

     

    SideNote: I'm running on Ubuntu 14.04 if it matters

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.