Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.16.x] How to register custom signs using Deferred Registries?


Quaint34
 Share

Recommended Posts

I am currently trying to make custom signs using deferred registries but its not working. The issue I am having is the sign classes do not support registry objects. Does anyone know how I can work around this?

Sign Item:    
public static final RegistryObject<Item> MAGICA_SIGN = itemHolder.register("magica_sign", () ->
            new SignItem(new Item.Properties().group(ItemGroup.DECORATIONS), blockInit.MAGICA_SIGN, blockInit.WALL_MAGICA_SIGN));
}

Sign Blocks:
      public static final RegistryObject<Block> MAGICA_SIGN = blockHolder.register("magica_sign", () ->
            new StandingSignBlock(AbstractBlock.Properties.create(Material.WOOD).doesNotBlockMovement().hardnessAndResistance(1.0F).sound(SoundType.WOOD), ModWoodType.MAGICA));

    public static final RegistryObject<Block> WALL_MAGICA_SIGN = blockHolder.register("magica_sign", () ->
            new WallSignBlock((AbstractBlock.Properties.create(Material.WOOD).doesNotBlockMovement().hardnessAndResistance(1.0F).sound(SoundType.WOOD).lootFrom(Blocks.OAK_SIGN)), ModWoodType.MAGICA));

 

Link to comment
Share on other sites

2 minutes ago, DietmarKracht said:

RegistryObject.get() is what you need here

Now I am getting an error about the .get method not being able to use static methods. Is this something I should care about? If so what can I do to fix it.

Link to comment
Share on other sites

1 hour ago, Quaint34 said:

Now I am getting an error about the .get method not being able to use static methods. Is this something I should care about? If so what can I do to fix it.

post the updated code

Link to comment
Share on other sites

8 hours ago, Quaint34 said:

Now I am getting an error about the .get method not being able to use static methods. Is this something I should care about? If so what can I do to fix it.

he meant RegistryObject#get, but if you don't know what that message means you shold take some time to learn java first.

your Sign BlockItem takes references to an Item, not to an RegistryObject, RegistryObjects work like Suppliers, you create them statically, you need to call .get() on the instance to get the object that it supplies. note that RegistryObjects only get populated after the registration events, therefore you can't call them before that (such as in statically initialization)

registering custom signs is not a simple task, I had to go through it a while ago, I can point you towards the topic I made on this thread on some of the errors I was getting: https://forums.minecraftforge.net/topic/96417-solved-116-custom-sign-wont-render/

 

Link to comment
Share on other sites

  • 1 month later...
On 4/25/2021 at 3:40 AM, kiou.23 said:

he meant RegistryObject#get, but if you don't know what that message means you shold take some time to learn java first.

your Sign BlockItem takes references to an Item, not to an RegistryObject, RegistryObjects work like Suppliers, you create them statically, you need to call .get() on the instance to get the object that it supplies. note that RegistryObjects only get populated after the registration events, therefore you can't call them before that (such as in statically initialization)

registering custom signs is not a simple task, I had to go through it a while ago, I can point you towards the topic I made on this thread on some of the errors I was getting: https://forums.minecraftforge.net/topic/96417-solved-116-custom-sign-wont-render/

 

I have my signs working but the textures do not show in game. I have them properly applied in the jsons but they are invisible and crash the game when placed. I have tried looking at your github but it is a broken link. Could you please guide me through on how to fix this?

Link to comment
Share on other sites

Posted (edited)
1 hour ago, Quaint34 said:

I have my signs working but the textures do not show in game. I have them properly applied in the jsons but they are invisible and crash the game when placed. I have tried looking at your github but it is a broken link. Could you please guide me through on how to fix this?

Updated Code

 

SignTileEntity Registration:

public class tileEntityTypeInit <T extends TileEntity> extends net.minecraftforge.registries.ForgeRegistryEntry<TileEntityType<?>>{

    public static final DeferredRegister<TileEntityType<?>> ENTITY_TYPE_DEFERRED_REGISTER = DeferredRegister.create(
            ForgeRegistries.TILE_ENTITIES, SwaysVanilla.modID
    );

    public static final TileEntityType<SignTileEntity> SIGN_TILE_ENTITY_TYPE = ENTITY_TYPE_DEFERRED_REGISTER.register(
            "sign", TileEntityType.Builder.create(SignTileEntity::new, blockInit.MAGICA_SIGN, blockInit.WALL_MAGICA_SIGN));
}

How do I apply the RegistryObjects in the field above? I have tried the .get() method but it doesn't work for some reason.

 

FakeBakery:

class FakeBakery extends ModelBakery {

    private FakeBakery (IResourceManager resourceManager, BlockColors blockColors, IProfiler profiler, int maxMiniMapLvl)
    {
        super(resourceManager, blockColors, profiler, maxMiniMapLvl);
    }

    static Set<RenderMaterial> Texturesget() {
        return ModelBakery.LOCATIONS_BUILTIN_TEXTURES;
    }
}

How do I apply the Fake Model Bakery to my signs?

 

Block Registration:

public static final RegistryObject<Block> MAGICA_SIGN = blockHolder.register("magica_sign", () ->
            new StandingSignBlock(AbstractBlock.Properties.create(Material.WOOD).doesNotBlockMovement().hardnessAndResistance(1.0F).sound(SoundType.WOOD), ModWoodType.MAGICA));

    public static final RegistryObject<Block> WALL_MAGICA_SIGN = blockHolder.register("magica_wall_sign", () ->
            new WallSignBlock((AbstractBlock.Properties.create(Material.WOOD).doesNotBlockMovement().hardnessAndResistance(1.0F).sound(SoundType.WOOD).lootFrom(Blocks.OAK_SIGN)), ModWoodType.MAGICA));

Item Registration:

    public static final RegistryObject<Item> MAGICA_SIGN_ITEM = itemHolder.register("magica_sign", () ->
            new SignItem(new Item.Properties().group(ItemGroup.DECORATIONS), blockInit.MAGICA_SIGN.get(), blockInit.WALL_MAGICA_SIGN.get()));

 

Edited by Quaint34
Link to comment
Share on other sites

1 hour ago, Quaint34 said:

public class tileEntityTypeInit <T extends TileEntity> extends net.minecraftforge.registries.ForgeRegistryEntry<TileEntityType<?>>{

    public static final DeferredRegister<TileEntityType<?>> ENTITY_TYPE_DEFERRED_REGISTER = DeferredRegister.create(
            ForgeRegistries.TILE_ENTITIES, SwaysVanilla.modID
    );

    public static final TileEntityType<SignTileEntity> SIGN_TILE_ENTITY_TYPE = ENTITY_TYPE_DEFERRED_REGISTER.register(
            "sign", TileEntityType.Builder.create(SignTileEntity::new, blockInit.MAGICA_SIGN, blockInit.WALL_MAGICA_SIGN));
}

How do I apply the RegistryObjects in the field above? I have tried the .get() method but it doesn't work for some reason.

you should call .get() on the registry objects. any time you're dealing with registry objects, and you need the actual thing "inside" the registry object, you use .get() (that's because a registry object is just a fancy supplier)

the problem is that when registering to a deferred register, you need to pass a supplier which returns the actual object. but in the code you're just passing the object (in your "sign" tile entity registration)

also, the DeferredRegister::register(string, supplier) returns a RegistryObject, not a TileEntityType

also, don't name your tile entity type deferred register a "entity type deferred register", entity types are another thing entirely (for entities, and not tile entities)

 

also also, please properly type your Registry Objects, if it's a SignItem, don't type it to RegistryObject<Item>, but use the more specific RegistryObject<SignItem>, same goes for your blocks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.