Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

1.16.5 mod server :"main WARN Advanced terminal features are not available in this environment"


Recommended Posts

C:\Users\xyc\Desktop\F16s>java -Xmx20480M -Xms20480M -jar server0.jar nogui
2021-04-28 16:45:20,198 main WARN Advanced terminal features are not available in this environment
[16:45:20] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.1.0, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge, nogui]
[16:45:20] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 16.0.1 by Oracle Corporation
Exception in thread "main" java.lang.IllegalAccessError: class cpw.mods.modlauncher.SecureJarHandler (in unnamed module @0x4c6e276e) cannot access class sun.security.util.ManifestEntryVerifier (in module java.base) because module java.base does not export sun.security.util to unnamed module @0x4c6e276e
        at cpw.mods.modlauncher.SecureJarHandler.lambda$static$1(SecureJarHandler.java:41)
        at cpw.mods.modlauncher.api.LamdbaExceptionUtils.uncheck(LamdbaExceptionUtils.java:95)
        at cpw.mods.modlauncher.SecureJarHandler.<clinit>(SecureJarHandler.java:41)
        at cpw.mods.modlauncher.Launcher.lambda$new$6(Launcher.java:55)
        at java.base/java.util.concurrent.ConcurrentHashMap.computeIfAbsent(ConcurrentHashMap.java:1708)
        at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:52)
        at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:47)
        at cpw.mods.modlauncher.Environment.computePropertyIfAbsent(Environment.java:62)
        at cpw.mods.modlauncher.Launcher.<init>(Launcher.java:55)
        at cpw.mods.modlauncher.Launcher.main(Launcher.java:66)
        at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:63)
        at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:60)
        at net.minecraftforge.server.ServerMain.main(ServerMain.java:57)

 

Get this message when try to install forge server.

Link to comment
Share on other sites

16 minutes ago, scro_oge said:

get this now when try to reinstall forge

wtf.PNG

fix by uninstall all jdk and jre, then reinstall.

but I still get this when try to launch the server

2021-04-28 17:12:49,890 main WARN Advanced terminal features are not available in this environment
[17:12:49] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.1.0, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge, nogui]
[17:12:49] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 16.0.1 by Oracle Corporation
Exception in thread "main" java.lang.IllegalAccessError: class cpw.mods.modlauncher.SecureJarHandler (in unnamed module @0x4c6e276e) cannot access class sun.security.util.ManifestEntryVerifier (in module java.base) because module java.base does not export sun.security.util to unnamed module @0x4c6e276e
        at cpw.mods.modlauncher.SecureJarHandler.lambda$static$1(SecureJarHandler.java:41)
        at cpw.mods.modlauncher.api.LamdbaExceptionUtils.uncheck(LamdbaExceptionUtils.java:95)
        at cpw.mods.modlauncher.SecureJarHandler.<clinit>(SecureJarHandler.java:41)
        at cpw.mods.modlauncher.Launcher.lambda$new$6(Launcher.java:55)
        at java.base/java.util.concurrent.ConcurrentHashMap.computeIfAbsent(ConcurrentHashMap.java:1708)
        at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:52)
        at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:47)
        at cpw.mods.modlauncher.Environment.computePropertyIfAbsent(Environment.java:62)
        at cpw.mods.modlauncher.Launcher.<init>(Launcher.java:55)
        at cpw.mods.modlauncher.Launcher.main(Launcher.java:66)
        at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:63)
        at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:60)
        at net.minecraftforge.server.ServerMain.main(ServerMain.java:57)

Link to comment
Share on other sites

I do not believe your issue has to do with the warning about advanced terminal features, rather I think it may be due to using Java 16.

Try it using Java 8, which is the version MC uses, although I think I saw something somewhere saying forge works with up to Java 15.

Link to comment
Share on other sites

31 minutes ago, scro_oge said:

C:\Users\xyc\Desktop\F16s>java -Xmx20480M -Xms20480M -jar server0.jar nogui

Also, make sure you are running the forge jar, hard to tell since your commandline says "server0.jar". I would advise against renaming the forge jar to some arbitrary name.

Link to comment
Share on other sites

1 minute ago, Ugdhar said:

I do not believe your issue has to do with the warning about advanced terminal features, rather I think it may be due to using Java 16.

Try it using Java 8, which is the version MC uses, although I think I saw something somewhere saying forge works with up to Java 15.

JDK 15? cause I installed jre 8 but then I cant even open jar files

Link to comment
Share on other sites

3 minutes ago, scro_oge said:

JDK 15? cause I installed jre 8 but then I cant even open jar files

If you're just running java programs, you only need the JRE. If you can't open jar files after installing Java 8, it's probably messed up file associations. Can't tell for sure without seeing a log or error message.

Link to comment
Share on other sites

12 minutes ago, Ugdhar said:

If you're just running java programs, you only need the JRE. If you can't open jar files after installing Java 8, it's probably messed up file associations. Can't tell for sure without seeing a log or error message.

holy shit , install jdk 15 actually worked, thx bro

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.