Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Unable to load a world minecraft 1.16.5 datapack issues


Recommended Posts

when I try to load a new world on a modpack I am making I got this error "Errors in currently selected datapacks prevented the world from loading. You can either try to load it with only the vanilla data pack ("safe mode"), or go back to the title screen and fix it manually." and I tried clicking safe mode it has the same result. The mods I am using are

Abnormals core, akashic Tome, Alexsmobs, Aquaculture 2, Architectury, ars nouveau, AutoRegLib, Better animals plus, better end forge, bookshelf, botania, bountiful baubles forge, buzzier bees, oh the biomes you'll go, carry on, cave biomes, caves and cliffs backport, mr cragsfish furniture mod, chisels and bits, citadel, clumps, comforts forge, cosmetic armor reworked, culinary construct, curios, cylic, deeper in the caves remake, doggy talents, dungeon crawl, dungeons plus, enchantment descriptions, feed the beast gui library, geckolib, goblin traders, gravestone, Hwyla, ice and fire, inventory pets, iron chest, jei, just enough resources, maccaw bridges, maccaw doors, maccaw fences, maccaw trapdoors, maccaw windows, maccaw roofs, maccaw furniture, mouse tweaks, mowziesmobs, natures compass, nether portal fix, overloaded armor bar, pams harvestcraft foodcore, pams harvestcraft foodextended, patchouli, repurposed structures, scaling health, serene seasons, silent lib, Spice of life carrot edition, spartan shields, spartan weaponry, structure gel, survive, toughnessbar, tumbleweed, twilight forest, u team core, union lib, upgrade aquatic, useful backpacks, waila harvestability, xaeros minimap, xp tome

Edited by EeveeIsAFox
Link to post
Share on other sites
  • EeveeIsAFox changed the title to Unable to load a world minecraft 1.16.5 datapack issues

this is happening with me too and i only have optifine, fullbright toggle, and world edit, ive used all these before with no problems and just now its starting to be weird :/

Link to post
Share on other sites

@EeveeIsAFox Post the debug.log.

 

3 hours ago, Soltye said:

this is happening with me too and i only have optifine, fullbright toggle, and world edit, ive used all these before with no problems and just now its starting to be weird :/

Make your own thread and post your debug.log there.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • It happens with Language Support for Java. Because of this error, my code will not be able to resolve the reference. Please help me. Error Messages: ---------------------------------- [Warn  - 9:37:53] 2021/08/01 9:37:53 While loading class "org.eclipse.buildship.core.internal.util.gradle.PublishedGradleVersions$LookupStrategy", thread "Thread[Worker-1: Loading available Gradle versions,5,main]" timed out waiting (30035ms) for thread "Thread[pool-2-thread-1,5,main]" to finish starting bundle "org.eclipse.buildship.core_3.1.5.v20210112-1646-s [14]". To avoid deadlock, thread "Thread[Worker-1: Loading available Gradle versions,5,main]" is proceeding but "org.eclipse.buildship.core.internal.util.gradle.PublishedGradleVersions$LookupStrategy" may not be fully initialized. Unable to acquire the state change lock for the module: osgi.identity; type="osgi.bundle"; version:Version="3.1.5.v20210112-1646-s"; osgi.identity="org.eclipse.buildship.core"; singleton:="true" [id=14] STARTED [STARTED] org.osgi.framework.BundleException: Unable to acquire the state change lock for the module: osgi.identity; type="osgi.bundle"; version:Version="3.1.5.v20210112-1646-s"; osgi.identity="org.eclipse.buildship.core"; singleton:="true" [id=14] STARTED [STARTED]     at org.eclipse.osgi.container.Module.lockStateChange(Module.java:350)     at org.eclipse.osgi.container.Module.start(Module.java:419)     at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:511)     at org.eclipse.osgi.internal.hooks.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:117)     at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findLocalClass(ClasspathManager.java:572)     at org.eclipse.osgi.internal.loader.ModuleClassLoader.findLocalClass(ModuleClassLoader.java:345)     at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:401)     at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:480)     at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:170)     at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:519)     at org.eclipse.buildship.core.internal.util.gradle.PublishedGradleVersionsWrapper$LoadVersionsJob.run(PublishedGradleVersionsWrapper.java:60)     at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63) Caused by: java.util.concurrent.TimeoutException: Timeout after waiting 30 seconds to acquire the lock.     at org.eclipse.osgi.container.Module.lockStateChange(Module.java:347)     ... 11 more Caused by: org.eclipse.osgi.framework.util.ThreadInfoReport: Thread dump ... ----------------------------------
    • Can someone please tell me why this is happening and help me find a solution. thanks. Edit: Nevermind I figured it out.
    • I am trying to store data through my ItemStack capability storage, but I stumbled upon a roadblock. My ItemStack Capability Storage: public class WandItemStorage implements Capability.IStorage<IWandCap> { @Nullable @Override public INBT writeNBT(Capability<IWandCap> capability, IWandCap instance, Direction side) { CompoundNBT tag = new CompoundNBT(); tag.put("spells", instance.getSpells()); return tag; } @Override public void readNBT(Capability<IWandCap> capability, IWandCap instance, Direction side, INBT nbt) { } } My ItemStack Capability: public class WandCap implements IWandCap { private List<Spell> spells; public WandCap () { spells = new ArrayList<>(); } @Override public List<Spell> getSpells() { return this.spells; } @Override public void addSpells(Spell... spells) { this.spells.addAll(Arrays.asList(spells)); } @Override public void addSpell(Spell spell) { this.spells.add(spell); } @Override public void removeSpells(Spell... spells) { this.spells.removeAll(Arrays.asList(spells)); } @Override public void removeSpell(Spell spell) { this.spells.remove(spell); } @Override public boolean containsSpell(Spell spell) { return this.spells.contains(spell); } } I'm currently trying to put a List of Spells (my custom object) to the Write and Read NBT methods of my ItemStack cap storage, but CompoundNBT doesn't have a method for putting a custom object into a tag. All it has is the put() method from what I'm seeing, however the put() method requires an INBT for the second parameter, which I do not have. Would I need to convert my List of Spells to an INBT, and how would I go about doing that?
    • When I click on forge jar file for my server it doesn't do anything what do I do. Please help asap
    • The Slots Move the stacks correctly when I shift click but when I manually move the stack it duplicates and creates ghost items please tell me what I did wrong???? my git repo: https://github.com/User-PARROT/MC-FORGE-1.16-Capability-Testing
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.