Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Trying to check if chunk is fully loaded (1.16.5)


Recommended Posts

I know I said I didn't want to make a new thread, but it's still not working, so here we are.

I have an EntityJoinWorldEvent function. I'm trying to set it so that it has a check to make sure it's not while the chunk is loading. So far, everything I've tried has resulted in the game saying the chunk is loaded during the initial entering-the-game loading phase and then never getting past the 100% indicator.

This is what I currently have:

@SubscribeEvent
public static void beeSpawn(EntityJoinWorldEvent event) {
	if (event.getEntity() instanceof BeeEntity) {
		LOGGER.debug("It's a bee!");
		BeeEntity bee = (BeeEntity)event.getEntity();
		World world = event.getWorld();
		if (!world.isClientSide()) {
			LOGGER.debug("It's the server!");
			if (bee.hasHive()) {
				BlockPos hive_pos = bee.getHivePos();
				if (world.getChunkSource().getChunkNow(hive_pos.getX() >> 4, hive_pos.getY() >> 4) != null) {
					LOGGER.debug("Hive is loaded");
					Block hive_block =  world.getBlockState(hive_pos).getBlock();
					LOGGER.debug(hive_block.toString());
					if (hive_block instanceof BeehiveBlock) {
						BeehiveTileEntity hiveEntity = (BeehiveTileEntity)world.getBlockEntity(hive_pos);
						if (world.getBiome(hive_pos).getTemperature(hive_pos) < 0.95F) {
							LOGGER.debug("Bee attempted leaving the hive, but it's too cold.");
							hiveEntity.addOccupant(bee, false);
							event.setCanceled(true);
						}
					}
					
				} else {
					LOGGER.debug("Hive isn't loaded yet, ignoring");
				}
			} else {
				LOGGER.debug("Hiveless bee, ignoring");
			}
		}
	}
}

 

And this is what I get to console:

[20:10:42] [Server thread/INFO] [minecraft/MinecraftServer]: Preparing start region for dimension minecraft:overworld
[20:10:44] [Render thread/INFO] [minecraft/LoggingChunkStatusListener]: Preparing spawn area: 0%
[20:10:44] [Render thread/INFO] [minecraft/LoggingChunkStatusListener]: Preparing spawn area: 0%
[20:10:44] [Render thread/INFO] [minecraft/LoggingChunkStatusListener]: Preparing spawn area: 0%
[20:10:44] [Render thread/INFO] [minecraft/LoggingChunkStatusListener]: Preparing spawn area: 0%
[20:10:44] [Server thread/DEBUG] [co.cl.be.ev.ModEvents/]: It's a bee!
[20:10:44] [Server thread/DEBUG] [co.cl.be.ev.ModEvents/]: It's the server!
[20:10:44] [Server thread/DEBUG] [co.cl.be.ev.ModEvents/]: Hive isn't loaded yet, ignoring
[20:10:44] [Server thread/DEBUG] [co.cl.be.ev.ModEvents/]: It's a bee!
[20:10:44] [Server thread/DEBUG] [co.cl.be.ev.ModEvents/]: It's the server!
[20:10:44] [Server thread/DEBUG] [co.cl.be.ev.ModEvents/]: Hiveless bee, ignoring
[20:10:44] [Server thread/DEBUG] [co.cl.be.ev.ModEvents/]: It's a bee!
[20:10:44] [Server thread/DEBUG] [co.cl.be.ev.ModEvents/]: It's the server!
[20:10:44] [Server thread/DEBUG] [co.cl.be.ev.ModEvents/]: Hive is loaded
[20:10:47] [Render thread/INFO] [minecraft/LoggingChunkStatusListener]: Preparing spawn area: 83%
[20:10:47] [Render thread/INFO] [minecraft/LoggingChunkStatusListener]: Preparing spawn area: 83%
[20:10:47] [Render thread/INFO] [minecraft/LoggingChunkStatusListener]: Preparing spawn area: 83%
[20:10:47] [Render thread/INFO] [minecraft/LoggingChunkStatusListener]: Preparing spawn area: 83%
[20:10:47] [Render thread/INFO] [minecraft/LoggingChunkStatusListener]: Preparing spawn area: 83%
[20:10:47] [Render thread/INFO] [minecraft/LoggingChunkStatusListener]: Preparing spawn area: 95%
[20:10:48] [Render thread/INFO] [minecraft/LoggingChunkStatusListener]: Preparing spawn area: 95%
[20:10:48] [Render thread/INFO] [minecraft/LoggingChunkStatusListener]: Preparing spawn area: 96%

Aaaand then it just sits with the loading screen saying 100% forever. It's obviously getting stuck on "Block hive_block =  world.getBlockState(hive_pos).getBlock();" which I'm guessing is because it's trying to access block info while the chunk is loading and causing a deadlock, which means that this is still the wrong way to check if a chunk is fully loaded.

How do I fix this?

Link to comment
Share on other sites

Yes, EntityJoinWorldEvent is called during chunk loading. So if you try to access the chunk (which you do indirectly with getBlockState) then you have a deadlock, because the chunk can't be loaded until your event handler is completed, but your event handler is waiting for the chunk to be loaded.

From what I can tell the reason getChunkNow doesn't work for you here is that the chunk is already half-loaded (see ChunkStatus) and in this case getChunkNow does not bail out and return null, instead if waits for it to be fully loaded.

See ForgeInternalHandler for how Forge deals with this problem by delaying things by 1 tick.

Link to comment
Share on other sites

8 hours ago, diesieben07 said:

Yes, EntityJoinWorldEvent is called during chunk loading. So if you try to access the chunk (which you do indirectly with getBlockState) then you have a deadlock, because the chunk can't be loaded until your event handler is completed, but your event handler is waiting for the chunk to be loaded.

From what I can tell the reason getChunkNow doesn't work for you here is that the chunk is already half-loaded (see ChunkStatus) and in this case getChunkNow does not bail out and return null, instead if waits for it to be fully loaded.

See ForgeInternalHandler for how Forge deals with this problem by delaying things by 1 tick.

I'll take a look, but does this mean there isn't anything that'll tell me if it's only half loaded? I was really aiming for not executing the code block during chunk loading as much as possible, but as far as I can tell, this is the event to use for bees exiting their hives so I have to account for chunk loading as well.

Link to comment
Share on other sites

1 hour ago, diesieben07 said:

I don't think so. Look at ForgeInternalHandler.

Ah, mild bummer. Yeah, I took a look at it, but I'm not at my dev machine right now so it'll be a few hours before I can try anything out.

In the meantime, though, I noticed the delayed executor uses addFreshEntity, which is the same method for bees leaving hives and has me questioning my entire event. I had assumed addFreshEntity triggers the onEntityJoinWorld event, but that makes ForgeInternalHandler look like it would just continually remove and recreate the entity every tick which is obviously not right. Does the executor not trigger events, or does addFreshEntity not count as an entity join event? If it's the latter, what does addFreshEntity trigger, because that's what I need to be using.

 

(Tangentially, I've been continually impressed by the scope of your knowledge of the code base and active presence on the forum, and I know that support work can feel incredibly thankless and exhausting so I wanted to mention that I really appreciate all the help!)

Link to comment
Share on other sites

8 minutes ago, InspectorCaracal said:

but that makes ForgeInternalHandler look like it would just continually remove and recreate the entity every tick which is obviously not right. Does the executor not trigger events, or does addFreshEntity not count as an entity join event?

It only calls addFreshEntity if it cancels the event, meaning the original entity is not spawned.

Link to comment
Share on other sites

3 minutes ago, diesieben07 said:

It only calls addFreshEntity if it cancels the event, meaning the original entity is not spawned.

Right, sorry, I wasn't clear.

What it looks like this does is, if the item has a custom entity, it cancels the spawn event and reschedules a new spawn event for the new entity. But I'd think that would then, on execution, trigger this event again, match the custom entity condition, cancel the spawn, reschedule, etc.

I know this isn't what it does and I'm probably missing something completely obvious, but I can't figure out how this doesn't just continually cancel and reschedule the entity spawn and I want to make sure I understand how it works before I try using parts of it myself.

Link to comment
Share on other sites

Just now, InspectorCaracal said:

Right, sorry, I wasn't clear.

What it looks like this does is, if the item has a custom entity, it cancels the spawn event and reschedules a new spawn event for the new entity. But I'd think that would then, on execution, trigger this event again, match the custom entity condition, cancel the spawn, reschedule, etc.

I know this isn't what it does and I'm probably missing something completely obvious, but I can't figure out how this doesn't just continually cancel and reschedule the entity spawn and I want to make sure I understand how it works before I try using parts of it myself.

This is the key:

Entity entity = event.getEntity();
if (entity.getClass().equals(ItemEntity.class))

That if statement only triggers for vanilla item entities. Yes, if an item just creates a vanilla ItemEntity as its custom entity this will create an infinite loop. However that would be a bug with the item implementation, it needs to create a subclass.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • What you posted looks like the latest.log, not debug.log. It also does not show any error, but a successful join of a single player world. Please answer this question.
    • [29Nov2021 13:35:13.629] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--username, Alsefri1423, --version, 1.17.1-forge-37.0.126, --gameDir, C:\Users\Gaming\AppData\Roaming\.minecraft, --assetsDir, C:\Users\Gaming\AppData\Roaming\.minecraft\assets, --assetIndex, 1.17, --uuid, a889dee5cd184fe7b91ede11d2acd85f, --accessToken, ????????, --userType, msa, --versionType, release, --launchTarget, forgeclient, --fml.forgeVersion, 37.0.126, --fml.mcVersion, 1.17.1, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20210706.113038] [29Nov2021 13:35:13.633] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 9.0.7+91+master.8569cdf starting: java version 16.0.1 by Microsoft [29Nov2021 13:35:13.746] [main/INFO] [mixin/]: SpongePowered MIXIN Subsystem Version=0.8.4 Source=union:/C:/Users/Gaming/AppData/Roaming/.minecraft/libraries/org/spongepowered/mixin/0.8.4/mixin-0.8.4.jar%2318! Service=ModLauncher Env=CLIENT [29Nov2021 13:35:15.296] [main/INFO] [cpw.mods.modlauncher.LaunchServiceHandler/MODLAUNCHER]: Launching target 'forgeclient' with arguments [--version, 1.17.1-forge-37.0.126, --gameDir, C:\Users\Gaming\AppData\Roaming\.minecraft, --assetsDir, C:\Users\Gaming\AppData\Roaming\.minecraft\assets, --uuid, a889dee5cd184fe7b91ede11d2acd85f, --username, Alsefri1423, --assetIndex, 1.17, --accessToken, ????????, --userType, msa, --versionType, release] [13:35:21] [Render thread/WARN]: Assets URL 'union:/C:/Users/Gaming/AppData/Roaming/.minecraft/libraries/net/minecraft/client/1.17.1-20210706.113038/client-1.17.1-20210706.113038-srg.jar%2353!/assets/.mcassetsroot' uses unexpected schema [13:35:21] [Render thread/WARN]: Assets URL 'union:/C:/Users/Gaming/AppData/Roaming/.minecraft/libraries/net/minecraft/client/1.17.1-20210706.113038/client-1.17.1-20210706.113038-srg.jar%2353!/data/.mcassetsroot' uses unexpected schema [29Nov2021 13:35:21.370] [Render thread/INFO] [com.mojang.authlib.yggdrasil.YggdrasilAuthenticationService/]: Environment: authHost='https://authserver.mojang.com', accountsHost='https://api.mojang.com', sessionHost='https://sessionserver.mojang.com', servicesHost='https://api.minecraftservices.com', name='PROD' [13:35:22] [Render thread/INFO]: Setting user: Alsefri1423 [13:35:22] [Render thread/INFO]: Backend library: LWJGL version 3.2.2 SNAPSHOT [13:35:24] [modloading-worker-2/INFO]: Forge mod loading, version 37.0.126, for MC 1.17.1 with MCP 20210706.113038 [13:35:24] [modloading-worker-2/INFO]: MinecraftForge v37.0.126 Initialized [13:35:24] [Render thread/WARN]: Removed resource pack Fabric Mods from options because it doesn't seem to exist anymore [29Nov2021 13:35:26.011] [Render thread/INFO] [com.mojang.text2speech.NarratorWindows/]: Narrator library for x64 successfully loaded [13:35:26] [Render thread/INFO]: Reloading ResourceManager: Default, Mod Resources [13:35:26] [modloading-worker-2/WARN]: Configuration file C:\Users\Gaming\AppData\Roaming\.minecraft\config\forge-client.toml is not correct. Correcting [13:35:26] [modloading-worker-2/WARN]: Incorrect key client.forceSystemNanoTime was corrected from null to its default, false.  [13:35:26] [modloading-worker-2/WARN]: Incorrect key client.disableStairSlabCulling was corrected from false to its default, null.  [13:35:26] [modloading-worker-2/WARN]: Incorrect key client.zoomInMissingModelTextInGui was corrected from false to its default, null.  [13:35:26] [modloading-worker-2/WARN]: Incorrect key client.forgeLightPipelineEnabled was corrected from true to its default, null.  [13:35:26] [modloading-worker-2/WARN]: Incorrect key client.forgeCloudsEnabled was corrected from true to its default, null.  [29Nov2021 13:35:26.669] [Forge Version Check/INFO] [net.minecraftforge.fml.VersionChecker/]: [forge] Starting version check at https://files.minecraftforge.net/net/minecraftforge/forge/promotions_slim.json [13:35:38] [Render thread/INFO]: OpenAL initialized. [13:35:38] [Render thread/INFO]: Sound engine started [13:35:38] [Render thread/INFO]: Created: 1024x512x4 minecraft:textures/atlas/blocks.png-atlas [13:35:38] [Render thread/INFO]: Created: 256x128x4 minecraft:textures/atlas/signs.png-atlas [13:35:38] [Render thread/INFO]: Created: 512x512x4 minecraft:textures/atlas/banner_patterns.png-atlas [13:35:38] [Render thread/INFO]: Created: 512x512x4 minecraft:textures/atlas/shield_patterns.png-atlas [13:35:38] [Render thread/INFO]: Created: 256x256x4 minecraft:textures/atlas/chest.png-atlas [13:35:38] [Render thread/INFO]: Created: 512x256x4 minecraft:textures/atlas/beds.png-atlas [13:35:38] [Render thread/INFO]: Created: 512x256x4 minecraft:textures/atlas/shulker_boxes.png-atlas [29Nov2021 13:35:38.817] [Forge Version Check/INFO] [net.minecraftforge.fml.VersionChecker/]: [forge] Found status: BETA Current: 37.0.126 Target: 37.0.126 [13:35:40] [Render thread/INFO]: Created: 256x256x0 minecraft:textures/atlas/particles.png-atlas [13:35:40] [Render thread/INFO]: Created: 256x256x0 minecraft:textures/atlas/paintings.png-atlas [13:35:40] [Render thread/INFO]: Created: 128x128x0 minecraft:textures/atlas/mob_effects.png-atlas [13:35:51] [Render thread/WARN]: Ambiguity between arguments [teleport, location] and [teleport, destination] with inputs: [0.1 -0.5 .9, 0 0 0] [13:35:51] [Render thread/WARN]: Ambiguity between arguments [teleport, location] and [teleport, targets] with inputs: [0.1 -0.5 .9, 0 0 0] [13:35:51] [Render thread/WARN]: Ambiguity between arguments [teleport, destination] and [teleport, targets] with inputs: [Player, 0123, @e, dd12be42-52a9-4a91-a8a1-11c01849e498] [13:35:51] [Render thread/WARN]: Ambiguity between arguments [teleport, targets] and [teleport, destination] with inputs: [Player, 0123, dd12be42-52a9-4a91-a8a1-11c01849e498] [13:35:51] [Render thread/WARN]: Ambiguity between arguments [teleport, targets, location] and [teleport, targets, destination] with inputs: [0.1 -0.5 .9, 0 0 0] [13:35:51] [Render thread/INFO]: Reloading ResourceManager: Default, forge-1.17.1-37.0.126-universal.jar [13:35:54] [Render thread/INFO]: Loaded 7 recipes [13:35:55] [Render thread/INFO]: Loaded 1137 advancements [13:35:55] [Render thread/INFO]: Injecting existing registry data into this CLIENT instance [13:35:56] [Render thread/WARN]: Ambiguity between arguments [teleport, location] and [teleport, destination] with inputs: [0.1 -0.5 .9, 0 0 0] [13:35:56] [Render thread/WARN]: Ambiguity between arguments [teleport, location] and [teleport, targets] with inputs: [0.1 -0.5 .9, 0 0 0] [13:35:56] [Render thread/WARN]: Ambiguity between arguments [teleport, destination] and [teleport, targets] with inputs: [Player, 0123, @e, dd12be42-52a9-4a91-a8a1-11c01849e498] [13:35:56] [Render thread/WARN]: Ambiguity between arguments [teleport, targets] and [teleport, destination] with inputs: [Player, 0123, dd12be42-52a9-4a91-a8a1-11c01849e498] [13:35:56] [Render thread/WARN]: Ambiguity between arguments [teleport, targets, location] and [teleport, targets, destination] with inputs: [0.1 -0.5 .9, 0 0 0] [13:35:56] [Render thread/INFO]: Reloading ResourceManager: Default, forge-1.17.1-37.0.126-universal.jar [13:35:58] [Render thread/INFO]: Loaded 7 recipes [13:35:59] [Render thread/INFO]: Loaded 1137 advancements [13:36:00] [Render thread/INFO]: Injecting existing registry data into this CLIENT instance [29Nov2021 13:36:00.780] [Render thread/INFO] [com.mojang.authlib.yggdrasil.YggdrasilAuthenticationService/]: Environment: authHost='https://authserver.mojang.com', accountsHost='https://api.mojang.com', sessionHost='https://sessionserver.mojang.com', servicesHost='https://api.minecraftservices.com', name='PROD' [13:36:00] [Server thread/INFO]: Starting integrated minecraft server version 1.17.1 [13:36:00] [Server thread/INFO]: Generating keypair [13:36:01] [Server thread/INFO]: Preparing start region for dimension minecraft:overworld [13:36:01] [Render thread/INFO]: Preparing spawn area: 0% [13:36:05] [Render thread/INFO]: Preparing spawn area: 0% [13:36:05] [Render thread/INFO]: Preparing spawn area: 0% [13:36:05] [Render thread/INFO]: Preparing spawn area: 0% [13:36:05] [Render thread/INFO]: Preparing spawn area: 0% [13:36:05] [Render thread/INFO]: Preparing spawn area: 0% [13:36:05] [Render thread/INFO]: Preparing spawn area: 0% [13:36:05] [Render thread/INFO]: Preparing spawn area: 0% [13:36:05] [Render thread/INFO]: Preparing spawn area: 0% [13:36:06] [Render thread/INFO]: Preparing spawn area: 56% [13:36:06] [Render thread/INFO]: Preparing spawn area: 76% [13:36:06] [Render thread/INFO]: Preparing spawn area: 88% [13:36:06] [Render thread/INFO]: Time elapsed: 5638 ms [13:36:06] [Server thread/INFO]: Changing view distance to 31, from 10 [13:36:08] [Netty Local Client IO #0/INFO]: Connected to a modded server. [13:36:08] [Server thread/INFO]: Using new advancement loading for net.minecraft.server.PlayerAdvancements@334a2b19 [13:36:08] [Server thread/INFO]: Alsefri1423[local:E:9ebcee60] logged in with entity id 113 at (-1414.803438468965, 64.0, 25.132433578510874) [13:36:08] [Server thread/INFO]: Alsefri1423 joined the game [13:36:09] [Server thread/INFO]: Saving and pausing game... [13:36:09] [Server thread/INFO]: Saving chunks for level 'ServerLevel[New World]'/minecraft:overworld [13:36:09] [Server thread/INFO]: Saving chunks for level 'ServerLevel[New World]'/minecraft:the_nether [13:36:09] [Server thread/INFO]: Saving chunks for level 'ServerLevel[New World]'/minecraft:the_end [13:36:09] [Server thread/WARN]: Can't keep up! Is the server overloaded? Running 2136ms or 42 ticks behind [13:36:10] [Render thread/INFO]: Loaded 174 advancements   My OS is Windows 10
    • Hello, I know I've been quite active here lately and I promise I'll get out of your hair once i can work out this final thing. Essentially I'm looking for a way to get the player's Position on a specific axis and use its value in an if statement. I've experimented with classes vec3 and vec3i as the method getY() seemed promising, but i didn't know how to use it with the player and I had issues with the method being non-static. Any help would be appreciated. 
    • This is why the MDK comes with a properly configured .gitignore file. Did you run genEclipseRuns? I don't use Eclipse, but your Repository works fine in IntelliJ.
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.