Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

1.7.10 forgegradle keeps failing builds


RubyEmerald
 Share

Recommended Posts

i am a 1.12.2 forge mod maker and when i try to build the mod it says build fail or somethin heres my code.

 

 

 

 

 

 

 

 

 

 

Last login: Sat Jul 10 21:13:27 on ttys000

cd desktop

cd codakid

cd ""^[[D/Users/iMac/.nvm/versions/io.js/v3.3.1/lib/node_modules/npm/bin/npm-cli.js:85

      let notifier = require('update-notifier')({pkg})

      ^^^

 

SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode

    at exports.runInThisContext (vm.js:53:16)

    at Module._compile (module.js:413:25)

    at Object.Module._extensions..js (module.js:448:10)

    at Module.load (module.js:355:32)

    at Function.Module._load (module.js:310:12)

    at Function.Module.runMain (module.js:471:10)

    at startup (node.js:117:18)

    at node.js:951:3

nvm is not compatible with the npm config "prefix" option: currently set to ""

Run `npm config delete prefix` or `nvm use --delete-prefix iojs-v3.3.1 --silent` to unset it.

iMacs-iMac:~ iMac$ cd desktop

iMacs-iMac:desktop iMac$ cd codakid

iMacs-iMac:codakid iMac$ cd "COdakid mod creation 1"

iMacs-iMac:COdakid mod creation 1 iMac$ cd "emerald tools and combat"

-bash: cd: emerald tools and combat: No such file or directory

iMacs-iMac:COdakid mod creation 1 iMac$ cd project

-bash: cd: project: No such file or directory

iMacs-iMac:COdakid mod creation 1 iMac$ cd projects

iMacs-iMac:projects iMac$ cd "emerald tools and combat"

iMacs-iMac:emerald tools and combat iMac$ ./gradlew build

To honour the JVM settings for this build a new JVM will be forked. Please consider using the daemon: https://docs.gradle.org/2.14/userguide/gradle_daemon.html.

 

FAILURE: Build failed with an exception.

 

* Where:

Build file '/Users/iMac/Desktop/Codakid/Codakid Mod Creation 1/projects/Emerald Tools And combat/build.gradle' line: 25

 

* What went wrong:

A problem occurred evaluating root project 'Emerald Tools And combat'.

> Could not set unknown property 'runDir' for root project 'Emerald Tools And combat' of type org.gradle.api.Project.

 

* Try:

Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

 

BUILD FAILED

 

Total time: 5.268 secs

iMacs-iMac:emerald tools and combat iMac$ ./gradlew build

 

FAILURE: Build failed with an exception.

 

* Where:

Build file '/Users/iMac/Desktop/Codakid/Codakid Mod Creation 1/projects/Emerald Tools And combat/build.gradle' line: 25

 

* What went wrong:

A problem occurred evaluating root project 'Emerald Tools And combat'.

> Could not set unknown property 'runDir' for root project 'Emerald Tools And combat' of type org.gradle.api.Project.

 

* Try:

Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

 

BUILD FAILED

 

Total time: 4.973 secs

iMacs-iMac:emerald tools and combat iMac$ 

Link to comment
Share on other sites

The problem is here:

version = "1.7.10-10.13.0.1187"
    runDir = "run"
    
    // the mappings can be changed at any time, and must be in the following format.
    // snapshot_YYYYMMDD   snapshot are built nightly.
    // stable_#            stables are built at the discretion of the MCP team.
    // Use non-default mappings at your own risk. they may not always work.
    // simply re-run your setup task after changing the mappings to update your workspace.
    mappings = "snapshot_20171003"
    // makeObfSourceJar = false // an Srg named sources jar is made by default. uncomment this to disable.

This should be:

minecraft {
    version = "1.7.10-10.13.0.1187"
    runDir = "run"
    
    // the mappings can be changed at any time, and must be in the following format.
    // snapshot_YYYYMMDD   snapshot are built nightly.
    // stable_#            stables are built at the discretion of the MCP team.
    // Use non-default mappings at your own risk. they may not always work.
    // simply re-run your setup task after changing the mappings to update your workspace.
    mappings = "snapshot_20171003"
    // makeObfSourceJar = false // an Srg named sources jar is made by default. uncomment this to disable.
}

 

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.