Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Error when runClient is ran Eclipse IDE


Recommended Posts

I have a mod and when I try to run it I get a long error

2021-07-11 11:35:48,916 main WARN Advanced terminal features are not available in this environment
[11:35:49] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmluserdevclient, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge, --fml.forgeVersion, 36.1.0, --version, MOD_DEV, --assetIndex, 1.16, --assetsDir, C:\Users\-----\.gradle\caches\forge_gradle\assets, --username, Dev, --accessToken, ????????, --userProperties, {}]
[11:35:49] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 16.0.1 by Oracle Corporation
[11:35:49] [main/DEBUG] [cp.mo.mo.LaunchServiceHandler/MODLAUNCHER]: Found launch services [minecraft,fmldevdata,fmldevclient,fmldevserver,fmluserdevserver,fmluserdevdata,testharness,fmlclient,fmluserdevclient,fmlserver]
Exception in thread "main" java.lang.IllegalAccessError: class cpw.mods.modlauncher.SecureJarHandler (in unnamed module @0xf6efaab) cannot access class sun.security.util.ManifestEntryVerifier (in module java.base) because module java.base does not export sun.security.util to unnamed module @0xf6efaab
    at cpw.mods.modlauncher.SecureJarHandler.lambda$static$1(SecureJarHandler.java:41)
    at cpw.mods.modlauncher.api.LamdbaExceptionUtils.uncheck(LamdbaExceptionUtils.java:95)
    at cpw.mods.modlauncher.SecureJarHandler.<clinit>(SecureJarHandler.java:41)
    at cpw.mods.modlauncher.Launcher.lambda$new$6(Launcher.java:55)
    at java.base/java.util.concurrent.ConcurrentHashMap.computeIfAbsent(ConcurrentHashMap.java:1708)
    at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:52)
    at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:47)
    at cpw.mods.modlauncher.Environment.computePropertyIfAbsent(Environment.java:62)
    at cpw.mods.modlauncher.Launcher.<init>(Launcher.java:55)
    at cpw.mods.modlauncher.Launcher.main(Launcher.java:66)
    at net.minecraftforge.userdev.LaunchTesting.main(LaunchTesting.java:105)

I don't know wat's happening and I tried without modifying anything and get the same error

I am following a tutorial but 


is it outdated


Link to comment
Share on other sites

It says it is running Java 16. You are probably using the newer Eclipse which comes with 16. You need to change setting to point to one of the other versions of Java.

Go to Preferences and check you have compiler compliance level set to 1.8, then check/fix Installed JREs and Execution Environment settings.

Edited by lupicus
Link to comment
Share on other sites

I had to install an older version of Eclipse from mid-2020 to work with java 8; the current version refused to run when I told it to use 8. If you have a fresh Eclipse install and it's running, it's probably ignoring your jdk 8 path and using the version 16 one instead.

Here is the version of Eclipse I'm using.

Link to comment
Share on other sites

i played around with my settings and i changed the jre to the java 8 and set the compiler compliance level to 1.8 and now the fml early loading mod starts up but a few seconds later it closes it self


i have this error from the console


Exception in thread "main"

Link to comment
Share on other sites

1 minute ago, lupicus said:

I'm using the latest and works fine when you change the settings, but if you don't like to make those changes then load older version.

Hmm, I wonder what I did wrong, then. I changed all the settings to point to Java 8 instead of 16 and then whenever I tried to run it, it told me that it wouldn't work on that version. Well, the older version is a good back-up for cases where changing the settings isn't working for whatever reason, at least. xD

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.