Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

CustomTileEntityRenderer texture problem


Recommended Posts

I'm creating a custom renderer to a tile entity. But my texture does not render. Here's my code:

Spoiler

@OnlyIn(Dist.CLIENT)
public class AltarTileEntityRenderer  extends TileEntityRenderer<AltarTileEntity> {

    public static final RenderMaterial ADORNS_LOCATION = new RenderMaterial(AtlasTexture.LOCATION_BLOCKS , new ResourceLocation("mohard", "textures/entity/altar_adorn.png"));

    private AdornsModel adorns = new AdornsModel();

    public AltarTileEntityRenderer(TileEntityRendererDispatcher p_i226006_1_) {
        super(p_i226006_1_);
    }

    @Override
    public void render(AltarTileEntity p_225616_1_, float p_225616_2_, MatrixStack p_225616_3_, IRenderTypeBuffer p_225616_4_, int p_225616_5_, int p_225616_6_) {
  
        p_225616_3_.pushPose();
        p_225616_3_.translate(0D, 0D, 0D);
        p_225616_3_.scale(1F, 1F, 1F);
        IVertexBuilder vertexBuilder = ADORNS_LOCATION.buffer(p_225616_4_, RenderType::entitySolid);
        adorns.render(p_225616_3_, vertexBuilder, p_225616_5_, p_225616_6_, 1.0F, 1.0F, 1.0F, 1.0F);
        p_225616_3_.popPose();
  
    }
  }

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.