Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

How to update your mod from 1.16.4 to 1.16.5


Recommended Posts

I'm really lost. 

Please, if someone has some instructions, i'm really desperate, I can't find anything that soesn't break ny code :(

 

How to update your mode:

1) download version of forge you want, unzip the package and call it what you want.

2) copy src folder to the new forge package.

3) using cmd, run gradlew eclipse and gradlew genEclipseRuns, then run gradlew -PUPDATE_MAPPINGS_CHANNEL="snapshot" -PUPDATE_MAPPINGS="20210309-1.16.5" updateMappings (but use version of mappings you want)

4) open build.gradlew txt file and edit mappings channel: 'official', version: '1.16.5' to mappings channel: "snapshot", version: "20210309-1.16.5"

5) bingo

 

That's just a remonding for me :)

Edited by urabaros
Link to post
Share on other sites

you'll need to be more specific than that
not a lot has changed from 1.16.4 to 1.16.5, so your code shouldn't be breaking. However, what may be happening is that you were using mcp mappings, but now the project is with mojmaps. You can try to refactor the code to update the mappings, or just switch back to using mcp mappings (given that this is the actual issue, I'm just assuming it is since you didn't provide more info)

  • Like 1
Link to post
Share on other sites

Ok! That's hard. I think you are right, I use mappings that i've found on forge's discord: 

mappingsVersion = 20210309-1.16.5

How should I refractor the code..?

What I did: I've created a new package with forge 1.16.5 files, than I've done /gradlew build and /gradlew genEclipseRuns, then I've edited build.gradle and gradle.properties. My gradle.properties: 

modVersion = "1.5.1"
modMinecraftVersion = 1.16.4
modForgeVersion = 35.1.5
mappingsChannel = snapshot
mappingsVersion = 20210309-1.16.5
modID = tutorialmod
modGroup = tutorialmod
modFileName = AkiraTheDemon

Link to post
Share on other sites
  • urabaros changed the title to How to update your mod from 1.16.4 to 1.16.5

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.