Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Issue with running the 1.17.1 Forge server.

Recommended Posts

I installed the Server using the forge-1.17.1-37.0.13-installer.jar from the Forge files website. The first issue I encountered was attempting to install the server in a folder on my desktop, while the .jar installer file was still in my Downloads folder. 8Lpwj4W.png

The issue was resolved by moving the .jar installer to my desktop (same area as the folder it's extracting files into).

Second issue (the one I can't fix), is that when attempting to run the server, it would state that it "Could not find or load the main class @user_jvm_args.txt" though the file was right there in the same folder as it.



I understand that Forge 1.17.1 is still in Beta, just wondering if this issue is resolvable (and if so, how it might be fixed) or if the server portion isn't an actual functioning piece yet.

Thanks - Salty

Link to comment
Share on other sites

Is your downloads folder a OneDrive/GoogleDrive or something like that? That's my first guess for your issue running the installer directly from your downloads folder. I just downloaded that same version, and ran install for both client and server (from my downloads folder, Win10 Home), and it worked flawlessly.

Which version of Java are you using (java -version from the commandline should show it)?

For MC/Forge 1.17, I used the latest Java 16 from AdoptOpenJDK.

Edited by Ugdhar
Link to comment
Share on other sites

2 hours ago, Ugdhar said:

Is your downloads folder a OneDrive/GoogleDrive or something like that? That's my first guess for your issue running the installer directly from your downloads folder. I just downloaded that same version, and ran install for both client and server (from my downloads folder, Win10 Home), and it worked flawlessly.

Which version of Java are you using (java -version from the commandline should show it)?

For MC/Forge 1.17, I used the latest Java 16 from AdoptOpenJDK.

Nah it is the C:\Users\(User)\Downloads folder, it was in a folder inside a folder etc., maybe a few too many for it to handle.
Wasn't aware that it would require Java 16, I don't remember reading anywhere that it needed it and I know past Forge servers haven't required it.

Regardless, all works now! Not having Java 16 was the issue. Thanks for the help :D

Link to comment
Share on other sites

On 7/29/2021 at 8:58 AM, SaltyLucky said:

Nah it is the C:\Users\(User)\Downloads folder, it was in a folder inside a folder etc., maybe a few too many for it to handle.

No Diesieben is right (Source: I fixed the issue) the issue was paths were being encoded for http (replacing http-illegal characters like spaces with encoded forms, space in this instance is encoded to %20)

As for the other person's issue there is very little info there and regardless I'd prefer you made your own topic with as much info as you can give

This is my Forum Signature, I am currently attempting to transform it into a small guide for fixing easier issues using spoiler blocks to keep things tidy.


As the most common issue I feel I should put this outside the main bulk:

The only official source for Forge is https://files.minecraftforge.net, and the only site I trust for getting mods is CurseForge.

If you use any site other than these, please take a look at the StopModReposts project and install their browser extension, I would also advise running a virus scan.


For players asking for assistance with Forge please expand the spoiler below and read the appropriate section(s) in its/their entirety.


Logs (Most issues require logs to diagnose):


Please post logs using one of the following sites (Thank you Lumber Wizard for the list):

https://gist.github.com/100MB Requires member (Free)

https://pastebin.com/: 512KB as guest, 10MB as Pro ($$$)

https://hastebin.com/: 400KB

Do NOT use sites like Mediafire, Dropbox, OneDrive, Google Drive, or a site that has a countdown before offering downloads.


What to provide:

...for Crashes and Runtime issues:

Minecraft 1.14.4 and newer:

Post debug.log

Older versions:

Please update...


...for Installer Issues:

Post your installer log, found in the same place you ran the installer

This log will be called either installer.log or named the same as the installer but with .log on the end

Note for Windows users:

Windows hides file extensions by default so the installer may appear without the .jar extension then when the .log is added the log will appear with the .jar extension


Where to get it:

Mojang Launcher: When using the Mojang launcher debug.log is found in .minecraft\logs.


Curse/Overwolf: If you are using the Curse Launcher, their configurations break Forge's log settings, fortunately there is an easier workaround than I originally thought, this works even with Curse's installation of the Minecraft launcher as long as it is not launched THROUGH Twitch:

  1. Make sure you have the correct version of Forge installed (some packs are heavily dependent on one specific build of Forge)
  2. Make a launcher profile targeting this version of Forge.
  3. Set the launcher profile's GameDir property to the pack's instance folder (not the instances folder, the folder that has the pack's name on it).
  4. Now launch the pack through that profile and follow the "Mojang Launcher" instructions above.






or alternately, 


Fallback ("No logs are generated"):

If you don't see logs generated in the usual place, provide the launcher_log.txt from .minecraft


Server Not Starting:


If your server does not start or a command window appears and immediately goes away, run the jar manually and provide the output.


Reporting Illegal/Inappropriate Adfocus Ads:


Get a screenshot of the URL bar or copy/paste the whole URL into a thread on the General Discussion board with a description of the Ad.

Lex will need the Ad ID contained in that URL to report it to Adfocus' support team.


Posting your mod as a GitHub Repo:


When you have an issue with your mod the most helpful thing you can do when asking for help is to provide your code to those helping you. The most convenient way to do this is via GitHub or another source control hub.

When setting up a GitHub Repo it might seem easy to just upload everything, however this method has the potential for mistakes that could lead to trouble later on, it is recommended to use a Git client or to get comfortable with the Git command line. The following instructions will use the Git Command Line and as such they assume you already have it installed and that you have created a repository.


  1. Open a command prompt (CMD, Powershell, Terminal, etc).
  2. Navigate to the folder you extracted Forge’s MDK to (the one that had all the licenses in).
  3. Run the following commands:
    1. git init
    2. git remote add origin [Your Repository's URL]
      • In the case of GitHub it should look like: https://GitHub.com/[Your Username]/[Repo Name].git
    3. git fetch
    4. git checkout --track origin/master
    5. git stage *
    6. git commit -m "[Your commit message]"
    7. git push
  4. Navigate to GitHub and you should now see most of the files.
    • note that it is intentional that some are not synced with GitHub and this is done with the (hidden) .gitignore file that Forge’s MDK has provided (hence the strictness on which folder git init is run from)
  5. Now you can share your GitHub link with those who you are asking for help.

[Workaround line, please ignore]


Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • I am working in 1.17.1 and i am trying to read the contents of a chest from a client side mod. I have attempted to read the chest using  ((RandomizableContainerBlockEntity)Minecraft.getInstance().level.getBlockEntity(new BlockPos(1,1,1))).getItem(0); this returns null since it is reading from the client side. is there any way to get the inventory within a block without needing any server side code I was thinking of trying to catch the ClientboundContainerSetContentPacket but I have seen that is said not to be the best idea.   the overall project is to try to get the inventories within an area and then by sending packets to the server move the player in order to reequip with items from said chests.   here is my code so far I haven't implemented movement of the player yet i am just trying to move items between inventories.   ForgeEventHandeler.java @Mod.EventBusSubscriber public class ForgeEventHandler { private static ArrayList<BlockPos> homeBase = new ArrayList<BlockPos>(); private static Boolean pressed = false; public static final KeyMapping keyBinding = new KeyMapping("pam SETUP", 79, "PAM"); @SubscribeEvent public static void updatePlayer(TickEvent.PlayerTickEvent event) { if(event.player.canEat(false)){ for(ItemStack inventoryStack : event.player.getInventory().items){ if (inventoryStack.isEdible()) { ForgeEventFactory.onItemUseStart(event.player, inventoryStack, 0); ItemStack result = inventoryStack.getItem().finishUsingItem(inventoryStack, event.player.getCommandSenderWorld(), event.player); ForgeEventFactory.onItemUseFinish(event.player, inventoryStack, 0, result); if (!event.player.canEat(false)) { break; } } } } if (keyBinding.isDown() && !pressed) { pressed = true; openBlock(); if(homeBase.size()==2) { homeBase.clear(); } HitResult block = Minecraft.getInstance().player.pick(20.0D, 0.0F, false); if(block.getType() == BlockHitResult.Type.BLOCK){ BlockPos blockpos = ((BlockHitResult)block).getBlockPos(); homeBase.add(blockpos); Minecraft.getInstance().getConnection().send(new ServerboundChatPacket("position set")); } if(homeBase.size()==2) { int[] start ={(int)homeBase.get(0).get(Direction.Axis.X),(int)homeBase.get(0).get(Direction.Axis.Y),(int)homeBase.get(0).get(Direction.Axis.Z)}; int[] end ={ (int) homeBase.get(1).get(Direction.Axis.X),(int)homeBase.get(1).get(Direction.Axis.Y),(int)homeBase.get(1).get(Direction.Axis.Z)}; int[] diff = {end[0]-start[0],end[1]-start[1],end[2]-start[2]}; for (int i=start[0]; i!=(end[0]+Integer.signum(diff[0])); i+=Integer.signum(diff[0])){ for (int j=start[1]; j!=(end[1]+Integer.signum(diff[1])); j+=Integer.signum(diff[1])){ for (int k=start[2]; k!=(end[2]+Integer.signum(diff[2])); k+=Integer.signum(diff[2])){ System.out.println(i+","+j+","+k); BlockPos posTemp = new BlockPos(i,j,k); BlockEntity blockEntity = Minecraft.getInstance().level.getBlockEntity(posTemp); if (blockEntity != null && blockEntity instanceof RandomizableContainerBlockEntity) { /*add chest to a category of chests that best describes what is in it E.G tools, weapons, food*/ } } } } } } if (!keyBinding.isDown()) { pressed=false; } } @SubscribeEvent public static void setup(FMLClientSetupEvent event) { ClientRegistry.registerKeyBinding(keyBinding); } @SuppressWarnings("resource") private static void openBlock(){ BlockHitResult hit = (BlockHitResult) Minecraft.getInstance().player.pick(20.0D, 0.0F, false); Minecraft.getInstance().getConnection().send(new ServerboundUseItemOnPacket(InteractionHand.MAIN_HAND,hit)); } }   exampemod.java // The value here should match an entry in the META-INF/mods.toml file @Mod("examplemod") public class ExampleMod { // Directly reference a log4j logger. public ExampleMod() { } }  
    • Look at where the field is used. There is a function that lets you set it.
    • So I'm trying to make an addon for Mr. Crayfish's Gun mod, what I'm trying to achieve right now is to add a new gun, but I got this error while adding the max stack size property to the item and I don't know how to get around it: 'maxStackSize' has private access in 'net.minecraft.item.Item.Properties' The line of code is this one: public static final Item.Properties genericProperties = new Item.Properties().maxStackSize(1).group(MoGuns.GROUP); And the whole code is this: package ttv.alanormiga.moguns.core.registry; import ttv.alanormiga.moguns.core.MoGuns; import com.mrcrayfish.guns.item.GunItem; import net.minecraft.item.Item; import net.minecraftforge.fml.RegistryObject; import net.minecraftforge.registries.DeferredRegister; import net.minecraftforge.registries.ForgeRegistries; public class ItemRegistry { public static final DeferredRegister<Item> ITEMS = DeferredRegister.create(ForgeRegistries.ITEMS, MoGuns.ID); public static final Item.Properties genericProperties = new Item.Properties().maxStackSize(1).group(MoGuns.GROUP); public static final RegistryObject<Item> SCAR = ITEMS.register("scar", () -> new GunItem(genericProperties)); } Also here is my github repo: https://github.com/AlanorMiga/MoGuns   Any help is greatly appreciated! Thanks in advance!
    • Reimport the gradle project into your IDE then regenerate run configs.
  • Topics

  • Who's Online (See full list)

  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.