Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.17.1] The mining speed of my block is unaffected by the tool in use.


DireTook
 Share

Recommended Posts

Hello,

Despite setting the harvestTool, harvestLevel and strength of the block, the mining speed of my block doesn't change regardless of the level of pickaxe or if I use of a supposedly unsuitable tool instead. I get the same mining speed with fists as a netherite pick.

image.thumb.png.a6f4c6c527a20cbd348f9dc333bef303.png

The usage of destroy time did increase the mining speed but was still unaffected by tools.

I looked at the register for Diorite as it seems to be a similar block, but can't see any reason that would be affected by tools and my block isn't?

Could anyone please tell me what I'm missing? 

I've attempted to add .setRequiresTool() as it was suggested it works in this thread: 

 

but that no longer seems to be an option in 1.17 with BlockBehaviour.

Link to comment
Share on other sites

Posted (edited)

I've realised .requiresCorrectToolForDrops() is now whats in use instead of .setRequiresTool(). 

So it seems like .harvestLevel() and .harvestTool() aren't functioning as they should?

Edited by DireTook
Link to comment
Share on other sites

Ah right, I'm completely unfamiliar with tags so apologies. Thanks for the reply though.

I've attempted to add as you've said and ended up with two .Jsons under tags.blocks. One for mineable/pickaxe and one for needs_stone_tools both with code similar to: 

Capture.PNG.e3e21403a01e1283e085c58ab9f448a6.PNG 

However this doesn't seem to change anything yet and nothing I've found has been clear about the best way to add to blocks to vanilla block tags although custom tags and recipe stuff is talked about a lot. I figured its properly not best to just add my block to the BlockTagProvider class? Is there something I'm missing or am I just going the completely wrong direction?

Link to comment
Share on other sites

17 minutes ago, DireTook said:

However this doesn't seem to change anything yet and nothing I've found has been clear about the best way to add to blocks to vanilla block tags although custom tags and recipe stuff is talked about a lot. I figured its properly not best to just add my block to the BlockTagProvider class? Is there something I'm missing or am I just going the completely wrong direction?

show the complete path of the tags

Link to comment
Share on other sites

Posted (edited)

Its src/main/resources/data.tutorialmod_uniqueid309.tags.blocks.mineable.pickaxe.json

and src/main/resources/data.tutorialmod_uniqueid309.tags.blocks.needs_stone_tools.json

image.png.6c94764821f2ae5284aa8ff5d130ec51.png

for this I have replaced the "examplemod:example_object" with my names: "tutorialmod_uniqueid309:example_block" 

Edited by DireTook
Link to comment
Share on other sites

32 minutes ago, DireTook said:

Its src/main/resources/data.tutorialmod_uniqueid309.tags.blocks.mineable.pickaxe.json

and src/main/resources/data.tutorialmod_uniqueid309.tags.blocks.needs_stone_tools.json

this are minecraft tags, so you need to put them in data.minecraft.tags folder

  • Thanks 1
Link to comment
Share on other sites

That worked! Thank you very much!

Although the Minecraft folder didn't show in my main directory till I tried to add the tags.block folder to it in the Project and External Dependencies which I found odd. Maybe that's normal eclipse thing I've not experienced yet :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • just want to know if it's possible to show people's session id's when they join your minecraft server  
    • I am currently working on a mod that needs to listen to player connect/disconnect events.  I am currently subscribing to both ServerDisconnectionFromClientEvent and PlayerLoggedOutEvent.  For the most part, when the server is running normally the PlayerLoggedOutEvent is called. I haven't really found much on the ServerDisconnectionFromClientEvent, but my testing would suggest that this event is only raised when the server itself has an issue and forces the clients to disconnect - rather than the clients themselves disconnecting when they think the server is no longer responding. It just seems like sometimes during my testing when I let the debugger just sit there awhile (simulating the server not responding) the PlayerLoggedOutEvent is raised and other times ServerDisconnectionFromClientEvent Here is my understanding of the events: PlayerLoggedOutEvent is raised when a player manually returns to main menu, or when the client believes the server is not responding. ServerDisconnectionFromClientEvent is raised when the server has an issue and is forcing players to disconnect.  I'm not sure if it is always the case that the server is closing after this event, or if it can happen on an otherwise healthy server, like maybe there was some issue sending packets to the client and the server doesn't think the client is there. I'm not sure if my understanding is correct.  I would like to have test cases for both events with several clients connected to the server, as I need to make sure that my code is working properly no matter the order in which people disconnect.  Some players cause effects on disconnecting, and some don't, so it's quite important to know if the logic is working properly in BOTH events. Can anyone enlighten me on when exactly each event is raised, and how to force ServerDisconnectionFromClientEvent to be raised?
    • There isnt a way for me to qccess vampire GUI and settings says nothing, the button the click to get into gui from inventory just isnt there. Is there a way to fix this
    • I've been trying to sort this out for a few days but unfortunately I've had no success. I was wondering if anyone has figured out how to add xp drops to an ore for 1.17.1. Anyone help would be appreciated, thanks!
    • JVM info: Oracle Corporation - 1.8.0_281 - 25.281-b09 java.net.preferIPv4Stack=true Found java version 1.8.0_281 Extracting main jar:   Extracted successfully Considering minecraft server jar java.net.UnknownHostException: launchermeta.mojang.com     at java.net.AbstractPlainSocketImpl.connect(Unknown Source)     at java.net.PlainSocketImpl.connect(Unknown Source)     at java.net.SocksSocketImpl.connect(Unknown Source)     at java.net.Socket.connect(Unknown Source)     at sun.security.ssl.SSLSocketImpl.connect(Unknown Source)     at sun.net.NetworkClient.doConnect(Unknown Source)     at sun.net.www.http.HttpClient.openServer(Unknown Source)     at sun.net.www.http.HttpClient.openServer(Unknown Source)     at sun.net.www.protocol.https.HttpsClient.<init>(Unknown Source)     at sun.net.www.protocol.https.HttpsClient.New(Unknown Source)     at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.getNewHttpClient(Unknown Source)     at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(Unknown Source)     at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source)     at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(Unknown Source)     at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)     at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)     at java.net.HttpURLConnection.getResponseCode(Unknown Source)     at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(Unknown Source)     at net.minecraftforge.installer.DownloadUtils.getConnection(DownloadUtils.java:203)     at net.minecraftforge.installer.DownloadUtils.downloadManifest(DownloadUtils.java:267)     at net.minecraftforge.installer.json.Util.getVanillaVersion(Util.java:62)     at net.minecraftforge.installer.actions.ServerInstall.run(ServerInstall.java:70)     at net.minecraftforge.installer.InstallerPanel.run(InstallerPanel.java:428)     at net.minecraftforge.installer.SimpleInstaller.launchGui(SimpleInstaller.java:170)     at net.minecraftforge.installer.SimpleInstaller.main(SimpleInstaller.java:143) Failed to download version manifest, can not find server jar URL.  
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.