Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

1.16.5 server keeps crashing/not starting

Recommended Posts

HI there anyone reading this

I'm trying to create a minecraft server me and my friends after getting a new pc for it

I downlaoded everything and added the mods, but then when I try to start it then it satrats up but crashes after 1 second of running

Here's the debug log: https://gist.github.com/Tatshino/604a99994e455dc237674ed1bbe940b4

Any help anyone can give will be helpful!

Link to comment
Share on other sites


[15Aug2021 12:14:38.787] [Netty Client IO #6/INFO] [net.minecraftforge.fml.client.ClientHooks/CLIENTHOOKS]: Server has additional mods that may be needed on the client: mcwbridges@1.0.5, repurposed_structures@1.16.5-2.7.8-forge, mowziesmobs@1.5.19, pandoras_creatures@1.16.3-2.0.1, craftingstation@4.1.1, pamhc2crops@version, mcwfences@1.0.0, curiousshulkerboxes@1.16.5-, mcwwindows@1.0.3, patchouli@1.16.4-51, somnia@1.16.4-2.0, bettercaves@1.16.4-1.1.2, pamhc2foodcore@version, fastbench@4.5.1, cookingforblockheads@9.3.1, ctm@MC1.16.1-, placebo@4.4.2, doubleslabs@3.5.2, yungsapi@1.16.4-Forge-6, dungeoncrawl@2.3.0, badmobs@9.0.3, constructionwand@1.16.5-2.2, fastfurnace@4.4.0, mcwroofs@2.0.1, relics@, ironshulkerbox@1.16.4-5.1.11, mcwdoors@1.0.2, mcwfurnitures@2.0.1, walljump@1.16.4-1.3.7, smallships@1.7.0, dummmmmmy@1.2.0, expandability@2.0.1, bettermineshafts@1.16.4-2.0.4
[15Aug2021 12:14:38.787] [Netty Client IO #6/INFO] [net.minecraftforge.fml.client.ClientHooks/CLIENTHOOKS]: Client has mods that are missing on server: [extraarmor, create_stuff_additions, treechop, glasscutter, cgm, bmorph, cavebiomes, jei, morecfm, chaosawakens, doggytalents, projecte, create, citadel, comforts, fakeblocks, modernlife, travelersbackpack, bno, ccam, upstream, apple_cows, xreliquary, mha, threecore, toolleveling, secretroomsmod, tantrum, iceandfire, mahoutsukai, sworddisplay, waila, vm, animalcrops, createplus, titanium, biomesoplenty, silentlib, vehicle, create_addon, betterdefaultbiomes, towers_of_the_wild, cavesandcliffs, fairylights, portality, curios, flywheel, hole_filler_mod, quark, gravestone, camera, jujutsukaisen, securitycraft, autoreglib, inventoryhud, obfuscate, structurize, animeverse, minecolonies, appleskin, cfm, craftable, pymtech, kimetsunoyaiba, cosmeticarmorreworked, scalinghealth, geckolib3, supertools, dungeons_gear, createaddition, xpbook]

This is shown from the server ping I think, the log ends before you actually connect to the server. For a full analysis we'd also need the log from server and client.

Link to comment
Share on other sites

Just now, diesieben07 said:

And like I said please also post the client log where it shows the actual connection. The client log you posted ends at "Starting connection".

I compared the log endings between the log that you see and the log i have and it shows the same,

I'll try to connect again and then send the log if you think that would change the ending

Link to comment
Share on other sites

Just now, diesieben07 said:

And like I said please also post the client log where it shows the actual connection. The client log you posted ends at "Starting connection".

Ok, so I connected to server just now no problem when I tried to get a new debug log

I don't know what fixed it

But thanks for the help you gave!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • It doesn't work even if I remove every mod Please help
    • Hi, so I was making an item that sends info to the server to do some work, and I want the server to send the client back the results? How do I do that? Here is my code:   The snippet that sends the packet to the server SimpleChannelNetwork.CHANNEL.sendToServer(new CreateStructureCompass("fortress"));   The file that manage the traffic package io.github.bossmania.NetherandEndMaps.core.network; import io.github.bossmania.NetherandEndMaps.NetherandEndMaps; import io.github.bossmania.NetherandEndMaps.core.network.message.CreateStructureCompass; import net.minecraft.util.ResourceLocation; import net.minecraftforge.fml.network.NetworkRegistry; import net.minecraftforge.fml.network.simple.SimpleChannel; public class SimpleChannelNetwork { public static final String NETWORK_VERSION = "0.1.0"; public static final SimpleChannel CHANNEL = NetworkRegistry.newSimpleChannel( new ResourceLocation(NetherandEndMaps.MOD_ID, "network"), () -> NETWORK_VERSION, version -> version.equals(NETWORK_VERSION), version -> version.equals(NETWORK_VERSION)); public static void init() { CHANNEL.registerMessage(0, CreateStructureCompass.class ,CreateStructureCompass::encode, CreateStructureCompass::decode, CreateStructureCompass::handle); } }   the code that handle the packet receive and where I want the server to send back a packet to the client package io.github.bossmania.NetherandEndMaps.core.network.message; import java.util.function.Supplier; import io.github.bossmania.NetherandEndMaps.common.items.TemporaryItem; import net.minecraft.entity.player.ServerPlayerEntity; import net.minecraft.item.ItemStack; import net.minecraft.network.PacketBuffer; import net.minecraft.util.math.BlockPos; import net.minecraft.world.gen.feature.structure.Structure; import net.minecraft.world.server.ServerWorld; import net.minecraftforge.fml.network.NetworkEvent; import net.minecraft.item.Item; import net.minecraft.item.ItemGroup; public class CreateStructureCompass { public String structureType; public CreateStructureCompass() { } //create the constructor and store the structureType public CreateStructureCompass(String structureType) { this.structureType = structureType; } //encode the message public static void encode(CreateStructureCompass message, PacketBuffer buffer) { buffer.writeString(message.structureType); } //decode the message public static CreateStructureCompass decode(PacketBuffer buffer) { return new CreateStructureCompass(buffer.readString()); } //execute function when message is sent to server public static void handle(CreateStructureCompass message, Supplier<NetworkEvent.Context> contextSupplier) { NetworkEvent.Context context = contextSupplier.get(); context.enqueueWork(() -> { //get the player and the server ServerPlayerEntity player = context.getSender(); ServerWorld SEWorld = player.getServerWorld(); //get the location of the structure BlockPos structureLocation = SEWorld.func_241117_a_(Structure.FORTRESS, player.getPosition(),100, false); //this is where I want the server to send structureLocation back to the player }); context.setPacketHandled(true); } }  
    • I cannot get an instance of MC Forge to run with either the vanilla launcher or GDLauncher, yet vanilla MC and Fabric MC work fine in both.  I am running the latest versions of everything, and no 1.18-compatible version of Forge will launch even though they all install without fail. Using the vanilla launcher I get exit code 0 and the following logs: Debug log Latest log With GDLauncher I get the following console output:  
    • In 1.15 and before, you could get the item being held/dragged by the cursor using PlayerInventory#getItemStack. This no longer seems to be the case. How do we do this now?
  • Topics

  • Who's Online (See full list)

  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.