Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Getting "Exit Code: 0" whenever I try to launch Forge 1.16.5, but no problems when trying other versions?


Recommended Posts

So I've run into a pretty strange issue. Whenever I try to run Forge 1.16.5, the game doesn't even begin to start, it just immediately crashes and sends me back to a launcher with an exit code 0 error. I've tried several other versions of Forge 1.16.5, same issue. With any other version this isn't a problem, including vanilla 1.16.5 and Forge 1.16.4. It's obviously not any particular mod that's an issue since there's no change when I try to run it with or without mods. I like to consider myself somewhat experienced in modding at this point but I'm beyond confused on what to do here. Help would be greatly appreciated, here's a pastebin with the launcher logs if it's helpful https://paste.ubuntu.com/p/VrNh545xXj/


Link to comment
Share on other sites

1 hour ago, diesieben07 said:

You installed a Mod that requires 1.16.5 on 1.16.4. Why are you using 1.16.4?

That log was apparently from me trying to test if my other profiles loaded up yesterday so I didn't worry about whatever mods I had loaded. After trying to run forge 1.16.5 again it looks like debug.log won't even update when launching that version.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • When I'm trying to load my game (Forge ver39.0.46) it loads everything up until it gets to "Data assets/minecraft/blockstates/brown_glazed_terracotta.json" then freezes. I've tried this on the latest version (v39.0.55) and it does the same thing. https://paste.ee/p/9sW7P   Why does this happen, and what can I do?
    • I've successful manage to make a jigsaw structure work using the JigsawManager.addPieces() class. It seems to be working fine on worldgen: public class BridgeStructure extends Structure<NoFeatureConfig> { public BridgeStructure() { super(NoFeatureConfig.field_236558_a_); } @Override public IStartFactory<NoFeatureConfig> getStartFactory() { return BridgeStructure.Start::new; } @Override public GenerationStage.Decoration getDecorationStage() { return GenerationStage.Decoration.SURFACE_STRUCTURES; } @Override // can be generated? protected boolean func_230363_a_(ChunkGenerator chunkGenerator, BiomeProvider biomeProvider, long seed, SharedSeedRandom sharedSeedRandom, int chunkX, int chunkZ, Biome biome, ChunkPos chunkPos, NoFeatureConfig noFeatureConfig) { return true; } public static class Start extends StructureStart<NoFeatureConfig> { // structureIn chunkX chunkZ mutableBoundingBox referenceIn seedIn // p_i225876_1_ p_i225876_2_ p_i225876_3_ p_i225876_4_ p_i225876_5_ p_i225876_6_ public Start(Structure<NoFeatureConfig> structureIn, int chunkX, int chunkZ, MutableBoundingBox mutableBoundingBox, int referenceIn, long seedIn) { super(structureIn, chunkX, chunkZ, mutableBoundingBox, referenceIn, seedIn); } @Override // generatePieces public void func_230364_a_(DynamicRegistries dynamicRegistries, ChunkGenerator chunkGenerator, TemplateManager templateManager, int chunkX, int chunkZ, Biome biome, NoFeatureConfig noFeatureConfig) { int x = chunkX * 16; int z = chunkZ * 16; BlockPos centerPos = new BlockPos(x, 0, z); // addPieces JigsawManager.func_242837_a( dynamicRegistries, new VillageConfig(() -> dynamicRegistries.getRegistry(Registry.JIGSAW_POOL_KEY).getOrDefault(new ResourceLocation(ModFiddle.MOD_ID, "bridge/bridge_start")), 10), AbstractVillagePiece::new, chunkGenerator, templateManager, centerPos, this.components, this.rand, false, true); int submergedBaseOffset = -6; this.components.forEach(piece -> piece.offset(0, submergedBaseOffset, 0)); this.recalculateStructureSize(); } } } I'm interested in adding some sort of logic when jigsaw pieces are added to the structure, something that I cannot do without somehow overriding (or copying) the class. For example, continuously adding jigsaw pieces so long as there are jigsaw blocks present or generating three consecutive pieces...  I'm afraid of doing something horribly stupid here. Should I not be looking into the jigsaw manager at all even? Thank for the help!
    • I meant to post that on Modder support, not forge gradle. Please discard 
    • All 3 does the same thing (sort of)
    • There seems to be an issue with the minecolonies mod. More specifically at com.ldtteam.structurize.placement.handlers.placement.PlacementHandlers on the GrassPlacementHandler.canHandle method. As the name suggest, something is trying to access a field DIRT which is none existent. If you're not a modder, maybe look for a patch on this specifically, downgrade or update the mod, or remove it.
  • Topics

  • Who's Online (See full list)

  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.