Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Forge Server 1.16.4 Not Showing Mods Folder When Made


Recommended Posts

1 hour ago, Gam3rGirlWater said:

Hello. When i tried making another server but for another version i cant seem to find a mods folder. and making one doesn't help.

Are you sure you're starting a forge server instead of a vanilla one?
Remember, there are two jars and you need to start the server via the forge one.

Link to comment
Share on other sites

[21:09:21 INFO]: Environment: authHost='https://authserver.mojang.com', accountsHost='https://api.mojang.com', sessionHost='https://sessionserver.mojang.com', servicesHost='https://api.minecraftservices.com', name='PROD'
[21:09:21 WARN]: Ambiguity between arguments [teleport, destination] and [teleport, targets] with inputs: [Player, 0123, @e, dd12be42-52a9-4a91-a8a1-11c01849e498]
[21:09:21 WARN]: Ambiguity between arguments [teleport, location] and [teleport, destination] with inputs: [0.1 -0.5 .9, 0 0 0]
[21:09:21 WARN]: Ambiguity between arguments [teleport, location] and [teleport, targets] with inputs: [0.1 -0.5 .9, 0 0 0]
[21:09:21 WARN]: Ambiguity between arguments [teleport, targets] and [teleport, destination] with inputs: [Player, 0123, dd12be42-52a9-4a91-a8a1-11c01849e498]
[21:09:21 WARN]: Ambiguity between arguments [teleport, targets, location] and [teleport, targets, destination] with inputs: [0.1 -0.5 .9, 0 0 0]
[21:09:21 INFO]: Reloading ResourceManager: Default
[21:09:22 INFO]: Loaded 7 recipes
[21:09:23 INFO]: Loaded 927 advancements
[21:09:24 INFO]: Starting minecraft server version 1.16.4
[21:09:24 INFO]: Loading properties
[21:09:24 INFO]: Default game type: SURVIVAL
[21:09:24 INFO]: Generating keypair
[21:09:24 ERROR]: Exception handling console input
java.io.IOException: The handle is invalid
    at java.io.FileInputStream.readBytes(Native Method) ~[?:?]
    at java.io.FileInputStream.read(FileInputStream.java:271) ~[?:?]
    at java.io.BufferedInputStream.read1(BufferedInputStream.java:282) ~[?:?]
    at java.io.BufferedInputStream.read(BufferedInputStream.java:343) ~[?:?]
    at sun.nio.cs.StreamDecoder.readBytes(StreamDecoder.java:297) ~[?:?]
    at sun.nio.cs.StreamDecoder.implRead(StreamDecoder.java:339) ~[?:?]
    at sun.nio.cs.StreamDecoder.read(StreamDecoder.java:188) ~[?:?]
    at java.io.InputStreamReader.read(InputStreamReader.java:178) ~[?:?]
    at java.io.BufferedReader.fill(BufferedReader.java:161) ~[?:?]
    at java.io.BufferedReader.readLine(BufferedReader.java:329) ~[?:?]
    at java.io.BufferedReader.readLine(BufferedReader.java:396) ~[?:?]
    at zg$1.run(SourceFile:95) [minecraft_server.1.16.4.jar:?]
[21:09:24 INFO]: Starting Minecraft server on *:25565
[21:09:24 INFO]: Using default channel type
[21:09:24 INFO]: Preparing level "world"
[21:09:25 INFO]: Preparing start region for dimension minecraft:overworld
[21:09:26 INFO]: Preparing spawn area: 0%
[21:09:26 INFO]: Preparing spawn area: 0%
[21:09:26 INFO]: Preparing spawn area: 0%
[21:09:29 INFO]: Preparing spawn area: 83%
[21:09:29 INFO]: Preparing spawn area: 83%
[21:09:29 INFO]: Preparing spawn area: 83%
[21:09:29 INFO]: Preparing spawn area: 83%
[21:09:29 INFO]: Preparing spawn area: 83%
[21:09:29 INFO]: Preparing spawn area: 83%
[21:09:29 INFO]: Preparing spawn area: 83%
[21:09:30 INFO]: Preparing spawn area: 83%
[21:09:30 INFO]: Preparing spawn area: 83%
[21:09:31 INFO]: Preparing spawn area: 83%
[21:09:31 INFO]: Preparing spawn area: 84%
[21:09:32 INFO]: Preparing spawn area: 87%
[21:09:32 INFO]: Preparing spawn area: 92%
[21:09:32 INFO]: Time elapsed: 7884 ms
[21:09:32 INFO]: Done (7.977s)! For help, type "help"
 

Link to comment
Share on other sites

1 hour ago, Gam3rGirlWater said:

its the java logo then Minecraft_server 1.16.4

Yea, you shouldn't be starting the Minecraft server. That starts a vanilla one.
You need to start the forge jar and I think you need to use the bat file that gets generated instead of just opening the jar.

Link to comment
Share on other sites

you just have to run it (eg. double click, if it opens notepad then you have the wrong extension), although I don't think you actually have to make a bat file, even if it's a good idea. Just running the forge server jar instead of the normal server jar should be enough

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Hello, I was wondering wether item groups are client or server-sided?
    • i would really appreciate help on this. i just can't figure out how to deobf my api module / prevent the api module from being obfuscated in the dev env.
    • I want to debug in intellij but when i click the debug icon it runs like normal, and if you go to top right(Gradle icon), normally i use runClient but if i try runServer minecraft doesnt open, or runServer with debug(https://imgur.com/a/KuSUqwt), (the eula.txt file has eula=true just in case) before minecraft window open it close with no errors, like if i closed it on purpose
    • By looking at the log output for command 'gradlew --debug runData', it appears that the Standard Library jars get passed to Forge via the '-cp' command line parameter correctly in both versions. Trying to create a workaround earlier revealed that the module resolver is aware of the Standard Library's exports, and therefore conflicts with any attempt to manually copy stdlib over to 'build/classes/kotlin/main'. This means I cannot create a workaround that way. I have also switched to 1.18, and this issue still persists. This is most likely an issue regarding JVM options, which I do not have enough knowledge about. The build.gradle snippets shown above (remember switching jvmTarget in kotlinOptions to 17 when building for 1.18), alongside with the following piece of code for a mod class, should be enough to reproduce: File: src/main/kotlin/com/example/examplemod/ExampleMod.kt package com.example.examplemod import net.minecraftforge.fml.common.Mod import org.apache.logging.log4j.LogManager import org.apache.logging.log4j.Logger @Mod("examplemod") class ExampleMod { init { LOGGER.info("Hello World!") } companion object { private val LOGGER: Logger = LogManager.getLogger() } } Note that removing the explicit type Logger (so it becomes 'private val LOGGER = LogManager.getLogger()') loads successfully, because when there is no explicit type specified, Koltin implicitly infers a so-called platform type, shown in IDE as 'Logger!' (note the exclamation mark). This platform type is not null checked by default, so there are no references to 'kotlin.jvm.internal.Intrinsics' for null checks. Specifying the type explicitly as not null however creates a null check under the hood, because in Kotlin, for a type to be nullable, it has to be suffixed with a question mark (Logger?). Otherwise it is guaranteed to be not null. Explanation for those not knowing Kotlin: The 'init' block is essentially a constructor block. The Java equivalent would be 'public ExampleMod() { LOGGER.info("Hello World!"); }'. Declarations inside 'companion object' basically behave like static declarations, so the Java equivalent would be 'private static Logger LOGGER = LogManager.getLogger();'. Looking forward to a fix! Thank you for your time.
    • affter a bit of time this worked: @SubscribeEvent public static void renderPlayerPre(RenderPlayerEvent.Pre event) { //here i was canceling the pre event so... event.getRenderer().getEntityModel().bipedLeftArm.showModel = false; } @SubscribeEvent public static void renderPlayerPost(RenderPlayerEvent.Post event) { PlayerEntity player = event.getPlayer(); PlayerModel<AbstractClientPlayerEntity> model = event.getRenderer().getEntityModel(); ModelRenderer rightArm = model.bipedLeftArm; rightArm.showModel = true; rightArm.render( event.getMatrixStack(), event.getBuffers().getBuffer(RenderType.getEntitySolid(((AbstractClientPlayerEntity)player).getLocationSkin())), Minecraft.getInstance().getRenderManager().getPackedLight(player, 1f), OverlayTexture.NO_OVERLAY); } But just one more thing, i promess no more questions..., the hand is like this: https://imgur.com/a/KTVudC3, and there is no offsetX, Y, or Z, do i need arm.rotationPointSOMETHING to move the hand wherever i want?
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.