Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.17.1] BlockEntity with Renderer doesn't load/client-sync until interaction


Logix
 Share

Recommended Posts

I'll keep this short and sweet. I have a BlockEntity which has an inventory, and a custom renderer class. The renderer displays an item/items from that inventory in the world. The problem is, that when the world is loaded, it doesn't render the items until the player has interacted with the block.

I don't know if this means the BlockEntity doesn't load its contents until interaction (such as with chests when they generate loot, since I was using the Chest code as a bit of a guide), or that the Renderer doesn't see the items because they aren't synced with the client until I interact with the block.

If anyone can shed some light on this, that'd be greatly appreciated. Thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.