Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

solved [1.16.5 - 36.2.0]ForgeFlowingFluid.Properties... slopFindDistance levelDecreasePerBlock missing


frakier
 Share

Recommended Posts

So it has been awhile... and I know my brain is like a sieve but...
I'm following a online tutorial on adding custom fluids and it goes ok up until this part...

they are using the old way of doing mappings and I'm using the new stuff [seriously considering swapping back as it makes most tutorials and videos a pain to follow as MS seems to have looked at the mapping in use and renamed everything with a contrarian attitude aimed at making things difficult]....anyway back on topic.
 

public static final ForgeFlowingFluid.Properties SLUDGE_PROPERTIES = new ForgeFlowingFluid.Properties(
			() -> ModFluids.SLUDGE_FLUID.get(),
			() -> ModFluids.SLUDGE_FLOWING.get(),
			FluidAttributes.builder(SLUDGE_STILL_RF, SLUDGE_FLOWING_RF)
			.density(15).luminosity(2).viscosity(5).sound(SoundEvents.LAVA_AMBIENT).overlay(SLUDGE_OVERLAY_RF)
			.color(0xbffed0d0)//color is //argb
			);

then they say add.

.slopeFindDistance(2).levelDecreasePerBlock(2)

but properties do not exist... so I go look at the code in ForgeFlowingFluid and those properties are there.. Like I said it has been awhile and maybe I'm overlooking some private somewhere but I did not see a problem.
So is it the mappings playing with me? Maybe I should go take a nap and come back with fresh eyes....
Any and all help appreciated.

Edited by frakier
Link to comment
Share on other sites

  • frakier changed the title to solved [1.16.5 - 36.2.0]ForgeFlowingFluid.Properties... slopFindDistance levelDecreasePerBlock missing
Posted (edited)

Solved... found the tutorial online to compare and...

 

	public static final ForgeFlowingFluid.Properties SLUDGE_PROPERTIES = new ForgeFlowingFluid.Properties(
			() -> ModFluids.SLUDGE_FLUID.get(),
			() -> ModFluids.SLUDGE_FLOWING.get(),
			FluidAttributes.builder(SLUDGE_STILL_RF, SLUDGE_FLOWING_RF)
			.density(15).luminosity(2).viscosity(5).sound(SoundEvents.LAVA_AMBIENT).overlay(SLUDGE_OVERLAY_RF)
			.color(0xbffed0d0)//color is //argb
			).slopeFindDistance(2).levelDecreasePerBlock(2);

I missed the closing parenthesis before ).slopeFindDistance(2).levelDecreasePerBlock(2);
and just could not see it for the trees. The added problem of using the ms mappings and not knowing if it was that or if it was me did not help.

Edited by frakier
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.