Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Forge 1.17.1 not launching


LuigiFox
 Share

Recommended Posts

I recently installed forge for Minecraft 1.17, but when I try to launch my game, I receive an error message and the game never launches. I've been searching for a solution but I've found nothing, hope u can give me a hand.

These are the lines on my console before the error:

Client> WARNING: Unknown module: cpw.mods.securejarhandler specified to --add-exports
Client> WARNING: Unknown module: cpw.mods.securejarhandler specified to --add-opens
Searching for old native files to clean up...
Client> Exception in thread "main" java.lang.module.FindException: Module org.objectweb.asm.commons not found, required by org.openjdk.nashorn
Client>     at java.base/java.lang.module.Resolver.findFail(Resolver.java:893)
Client>     at java.base/java.lang.module.Resolver.resolve(Resolver.java:192)
Client>     at java.base/java.lang.module.Resolver.resolve(Resolver.java:141)
Client>     at java.base/java.lang.module.Configuration.resolveAndBind(Configuration.java:492)
Client>     at java.base/java.lang.module.Configuration.resolveAndBind(Configuration.java:298)
Client>     at cpw.mods.bootstraplauncher.BootstrapLauncher.main(BootstrapLauncher.java:83)
The game ended on a wrong way (exit code 1)

I've been trying to find any crash report or log file on my .minecraft folder, but there's nothing in there.

Edited by LuigiFox
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • public static void onPlayerCloned(PlayerEvent.Clone event) { if (!event.getOriginal().world.isRemote() && !event.getPlayer().world.isRemote() && event.getOriginal() != null && event.getPlayer() != null) { LazyOptional<IMindCapability> oldMindCap = event.getOriginal().getCapability(LibCapabilities.MIND_CAPABILITY); LazyOptional<IMindCapability> newMindCap = event.getPlayer().getCapability(LibCapabilities.MIND_CAPABILITY); if (oldMindCap.isPresent() && newMindCap.isPresent()) { newMindCap.ifPresent(capability -> { oldMindCap.ifPresent(capabilityOld -> { event.getPlayer().sendMessage(new StringTextComponent("Before: " + capability.getMindStrength()), CommonProxy.IN_GAME_UUID); capability.deserializeNBT(capabilityOld.serializeNBT()); event.getPlayer().sendMessage(new StringTextComponent("After: " + capability.getMindStrength()), CommonProxy.IN_GAME_UUID); }); // This don't work, the value on the client side is still the initial value SCPacketHandler.INSTANCE.send(PacketDistributor.PLAYER.with(() -> (ServerPlayerEntity) event.getPlayer()), new MSGMindCapabilitySync(capability.getMindStrength())); // It works,the value on the client side is correct, but I don't know why, I think it's just a coincidence. // SCPacketHandler.INSTANCE.sendToServer(new MSGMindCapabilitySync(capability.getMindStrength())); }); } } }   This is my message code. public class MSGMindCapabilitySync { private final int mindStrength; public MSGMindCapabilitySync(int mindStrength) { this.mindStrength = mindStrength; } public static void encodingMSG(MSGMindCapabilitySync msg, PacketBuffer buffer) { buffer.writeInt(msg.mindStrength); } public static MSGMindCapabilitySync decodingMSG(PacketBuffer buffer) { return new MSGMindCapabilitySync(buffer.readInt()); } public static void handle(MSGMindCapabilitySync msg, Supplier<NetworkEvent.Context> ctx) { ctx.get().enqueueWork(() -> { // Form client to server ServerPlayerEntity serverPlayer = ctx.get().getSender(); if (serverPlayer != null) { serverPlayer.getCapability(LibCapabilities.MIND_CAPABILITY).ifPresent((capability -> { capability.setMindStrength(msg.mindStrength); })); SaintChapter.LOGGER.info("Form client to server. Done"); } // From server to client DistExecutor.unsafeRunWhenOn(Dist.CLIENT, () -> () -> { if (Minecraft.getInstance().player == null) return; Minecraft.getInstance().player.getCapability(LibCapabilities.MIND_CAPABILITY).ifPresent((capability -> { capability.setMindStrength(msg.mindStrength); })); SaintChapter.LOGGER.info("From server to client. Done"); }); }); ctx.get().setPacketHandled(true); } }
    • I don't know what you used to post the log here, but next time please upload the log to a paste site, this is horrible to look at with all the formatting removed One of your server configs is failing to load properly, if you have not modified it delete ironfurnaces-server.toml
    • Did you download the server-specific files for the pack or did you copy the mods from the client and hope?
    • 1.12 is no longer supported on this forum. Please update to a modern version of Minecraft to receive support.
    • [18:32:34] [Server thread/WARN] [ne.mi.co.ForgeConfigSpec/CORE]: Configuration file .\saves\New World (2)\serverconfig\forge-server.toml is not correct. Correcting [18:32:34] [Server thread/WARN] [ne.mi.co.ForgeConfigSpec/CORE]: Incorrect key server was corrected from null to its default, SimpleCommentedConfig:{   Using that code and before I get that. And my mob still don't work.
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.