Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Forge 1.17.1 not launching


LuigiFox
 Share

Recommended Posts

I recently installed forge for Minecraft 1.17, but when I try to launch my game, I receive an error message and the game never launches. I've been searching for a solution but I've found nothing, hope u can give me a hand.

These are the lines on my console before the error:

Client> WARNING: Unknown module: cpw.mods.securejarhandler specified to --add-exports
Client> WARNING: Unknown module: cpw.mods.securejarhandler specified to --add-opens
Searching for old native files to clean up...
Client> Exception in thread "main" java.lang.module.FindException: Module org.objectweb.asm.commons not found, required by org.openjdk.nashorn
Client>     at java.base/java.lang.module.Resolver.findFail(Resolver.java:893)
Client>     at java.base/java.lang.module.Resolver.resolve(Resolver.java:192)
Client>     at java.base/java.lang.module.Resolver.resolve(Resolver.java:141)
Client>     at java.base/java.lang.module.Configuration.resolveAndBind(Configuration.java:492)
Client>     at java.base/java.lang.module.Configuration.resolveAndBind(Configuration.java:298)
Client>     at cpw.mods.bootstraplauncher.BootstrapLauncher.main(BootstrapLauncher.java:83)
The game ended on a wrong way (exit code 1)

I've been trying to find any crash report or log file on my .minecraft folder, but there's nothing in there.

Edited by LuigiFox
Link to comment
Share on other sites

I have the same issue

the problem is Minecraft 1.17.1 itself runs but when I try the forge profile it gives this error

Idk if its important but I had to change JMV Executable path after I updated Java to C:\Program Files\Java\jdk-17.0.1\bin\java.exe

Link to comment
Share on other sites

I found the problem, it is a file from the forge libraries. Specifically, the file is found in the path of:

.minecraft / libraries / cpw / mods / bootstraplauncher / 0.1.17 / bootstraplauncher-0.1.17.jar

I don't have internet, so I haven't the resources to fix it, but if you could contact someone responsible for forge, comment that it is necessary to specify a module with the asm library that is included, precisely it does not recognize the module belonging to the library asm-commons-9.1.jar:

.minecraft / libraries / org / ow2 / asm / asm-commons / 9.1 /

I don't know if it has to do with adding the asm libraries to the ignore list or something else.

 

U can call me Nitro119

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • i would really appreciate help on this. i just can't figure out how to deobf my api module / prevent the api module from being obfuscated in the dev env.
    • I want to debug in intellij but when i click the debug icon it runs like normal, and if you go to top right(Gradle icon), normally i use runClient but if i try runServer minecraft doesnt open, or runServer with debug(https://imgur.com/a/KuSUqwt), (the eula.txt file has eula=true just in case) before minecraft window open it close with no errors, like if i closed it on purpose
    • By looking at the log output for command 'gradlew --debug runData', it appears that the Standard Library jars get passed to Forge via the '-cp' command line parameter correctly in both versions. Trying to create a workaround earlier revealed that the module resolver is aware of the Standard Library's exports, and therefore conflicts with any attempt to manually copy stdlib over to 'build/classes/kotlin/main'. This means I cannot create a workaround that way. I have also switched to 1.18, and this issue still persists. This is most likely an issue regarding JVM options, which I do not have enough knowledge about. The build.gradle snippets shown above (remember switching jvmTarget in kotlinOptions to 17 when building for 1.18), alongside with the following piece of code for a mod class, should be enough to reproduce: File: src/main/kotlin/com/example/examplemod/ExampleMod.kt package com.example.examplemod import net.minecraftforge.fml.common.Mod import org.apache.logging.log4j.LogManager import org.apache.logging.log4j.Logger @Mod("examplemod") class ExampleMod { init { LOGGER.info("Hello World!") } companion object { private val LOGGER: Logger = LogManager.getLogger() } } Note that removing the explicit type Logger (so it becomes 'private val LOGGER = LogManager.getLogger()') loads successfully, because when there is no explicit type specified, Koltin implicitly infers a so-called platform type, shown in IDE as 'Logger!' (note the exclamation mark). This platform type is not null checked by default, so there are no references to 'kotlin.jvm.internal.Intrinsics' for null checks. Specifying the type explicitly as not null however creates a null check under the hood, because in Kotlin, for a type to be nullable, it has to be suffixed with a question mark (Logger?). Otherwise it is guaranteed to be not null. Explanation for those not knowing Kotlin: The 'init' block is essentially a constructor block. The Java equivalent would be 'public ExampleMod() { LOGGER.info("Hello World!"); }'. Declarations inside 'companion object' basically behave like static declarations, so the Java equivalent would be 'private static Logger LOGGER = LogManager.getLogger();'. Looking forward to a fix! Thank you for your time.
    • affter a bit of time this worked: @SubscribeEvent public static void renderPlayerPre(RenderPlayerEvent.Pre event) { //here i was canceling the pre event so... event.getRenderer().getEntityModel().bipedLeftArm.showModel = false; } @SubscribeEvent public static void renderPlayerPost(RenderPlayerEvent.Post event) { PlayerEntity player = event.getPlayer(); PlayerModel<AbstractClientPlayerEntity> model = event.getRenderer().getEntityModel(); ModelRenderer rightArm = model.bipedLeftArm; rightArm.showModel = true; rightArm.render( event.getMatrixStack(), event.getBuffers().getBuffer(RenderType.getEntitySolid(((AbstractClientPlayerEntity)player).getLocationSkin())), Minecraft.getInstance().getRenderManager().getPackedLight(player, 1f), OverlayTexture.NO_OVERLAY); } But just one more thing, i promess no more questions..., the hand is like this: https://imgur.com/a/KTVudC3, and there is no offsetX, Y, or Z, do i need arm.rotationPointSOMETHING to move the hand wherever i want?
    • 1.12 is no longer supported on this forum. Please update to a modern version of Minecraft to receive support.
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.