Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Issue with custom Dimension (Minecraft 1.16.5) [solved]


Recommended Posts

Alright I am having a major issue with my custom dimension. Whenever I allow my mod's worldgen features to generate in my dimension (this doesn't happen when I disable them), Minecraft either has a memory leak or the server thread hangs, causing Minecraft to be unresponsive.

Biome Provider: https://gitlab.com/NoahJelen/paradisemod/-/blob/1.16.5/src/main/java/net/paradisemod/world/dimension/biomeprovider/OWCBiomeProvider.java

Chunk Generator: https://gitlab.com/NoahJelen/paradisemod/-/blob/1.16.5/src/main/java/net/paradisemod/world/dimension/chunkgen/OWCChunkGenerator.java

Dimension JSON: https://gitlab.com/NoahJelen/paradisemod/-/blob/1.16.5/src/main/resources/data/paradisemod/dimension/overworld_core.json

Dimension Type JSON: https://gitlab.com/NoahJelen/paradisemod/-/blob/1.16.5/src/main/resources/data/paradisemod/dimension_type/overworld_core.json

I am at the end of my wits on solving this issue.

Edited by NetherNoah777
My issue is fixed
Link to comment
Share on other sites

And I think my thread hanging issue may have had to do with the fact that villages were trying generate in my dimension (I need to investigate this more). In my BiomeProvider, I removed all the biomes associated with villages and Minecraft seemed to stopped hanging, however I still need to investigate the memory leak that causes my system's OOM killer to kick in and kill Minecraft.

Edited by NetherNoah777
Link to comment
Share on other sites

Alright, I believe I may have discovered what my issue was. It seems that when overworld biomes are generated in underground dimensions (the dimension in question is underground), their feature generation doesn't seem to play very nice with the chunk structure (it is 256 blocks high). As of right now, I have my dimension generating the Nether Wastes biome right now and I have been exploring it for over an hour now without any issue. To anyone who happens to have this issue when creating an underground dimension in the future, don't use overworld biomes in it (especially if the chunk is 256 blocks tall). Thank for your help Luis_ST.

Edited by NetherNoah777
Link to comment
Share on other sites

  • NetherNoah777 changed the title to Issue with custom Dimension (Minecraft 1.16.5) [solved]

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.