Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Minecraft 1.17.1 crash on Crafting Table search button being clicked


Recommended Posts

First-time poster, longtime MC Forge player, please be kind, and thank you for your excellent work!

I've been experiencing crashes now since about Forge 1.17.1-37.0.88, so I removed all mods and tried running a new world.  Previously *with* a few mods installed crashes took a few hours of play before occurring, but this time the 2nd time that I tried to use the Crafting Table (within around 5 minutes), when I was trying to switch the recipe view to show only craftable items, the game stopped and dumped me out to the loader.

Debug.log is at <script src="https://gist.github.com/frag0nard/073c4f504a3358f5910ec17413243ab8.js"></script>


Link to comment
Share on other sites

Would it show up in a different log file perhaps?  I don't know the various log file types and what they're associated with, I know I got "EXCEPTION" messages in the logs I have looked at ... like this:


Description: Rendering screen

java.lang.NullPointerException: Cannot invoke "net.minecraft.world.item.ItemStack.m_41720_()" because "stack" is null
    at net.minecraftforge.client.RenderProperties.get(RenderProperties.java:43) ~[forge-1.17.1-37.0.90-universal.jar%2357!:?] {re:classloading}
    at net.minecraftforge.client.ForgeHooksClient.getTooltipFont(ForgeHooksClient.java:1089) ~[forge-1.17.1-37.0.90-universal.jar%2357!:?] {re:classloading}


I also see a .gzip file from the time of the crash, but it's not readable (by me)

So where do we go to figure out what is not working when we get Exceptions but there's no crash?

I'll go re-read the instructions too.

Link to comment
Share on other sites

The game crashed whilst rendering screen Error: java.lang.NullPointerException: Cannot invoke "net.minecraft.world.item.ItemStack.m_41720_()" because "stack" is null Exit Code: -1

when I tried the same action (clicking on the Search button) with the most recent Forge (.95).  I noticed I've forgotten to remove the resource pack I have been using, so in case THAT's what's my issue, I'll do that.

Launcher doesn't present me with debug.log, but rather with a "crash report."  Not sure whether they're the same.

Link to comment
Share on other sites

Same issue here when hovering over cartable / non creatable recopies but only on the crafting table, i get:  Cannot invoke "net.minecraft.world.item.ItemStack.m_41720_()" because "stack" is null.
others on reddit experiencing issues, 

Not sure if it could also be an issue with Xaero's mini map, as i also have this installed.

Can post full crash log if its helpful.

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.