Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Minecraft crashes when I try to summon my entity


ArianKG
 Share

Recommended Posts

  • Don't do this: https://github.com/ArianKG/KGForge/blob/main/src/main/java/com/kg/kgforge/init/Init.java#L7. Do not store the event bus in a static field.
  • Do not put a DeferredRegister and its entries in separate classes. You will cause issues.
  • Do not create registry entries (PaintingType and EntityType in your case) in a static initializer. It must be done in a registry event, DeferredRegister is recommended.
  • You must register a renderer for your entities using RenderingRegistry.registerEntityRenderingHandler.
Link to comment
Share on other sites

  1. Use the ModEventBus direct and not the Field you create
  2. move the DeferredRegister into the same class where you use it (where you create the RegistryObjects, what you're not doing yet)
  3. use RegistryObjects instead of static initializer
    public static final Block EXAMPLE = new ExampleBlock();
    // should be:
    public static final RegistryObject<ExampleBlock> EXAMPLE = <DeferredRegister_Field>.register("example", new ExampleBlock());
  4. call RenderingRegistry#registerEntityRenderingHandler in FMLClientSetupEvent and register the Renderer
Edited by Luis_ST
Link to comment
Share on other sites

you haven't, you still store the ModEventBus in a static Field and you register the Renderer of your Entity in FMLCommonSetupEvent and not in FMLClientSetupEvent

Edit: you still use static initializer for your EntityTypes, I would recommend you to look again at the basics for the Registry System: FCW or the Forge doc

Edited by Luis_ST
Link to comment
Share on other sites

21 hours ago, diesieben07 said:

You have fixed none of these issues.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Hi, I'm trying to set up a simple forge server just to play with a couple of my friends, but no matter what I do or try I cannot seem to get a Mods folder and for the actual forge part of the server to actually launch. Every time I try to launch the forge.jar via a .bat file I just get a bunch of errors [Errors below] I'm not sure what I'm doing wrong. If I can get some help that would be awesome, thanks C:\Users\User\Desktop\Server>java -Xms2G -Xmx6G -jar forge-1.12.2-14.23.5.2855.jar nogui A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException         at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)         at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:78)         at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)         at java.base/java.lang.reflect.Method.invoke(Method.java:567)         at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:70)         at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:34) Caused by: java.lang.ClassCastException: class jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to class java.net.URLClassLoader (jdk.internal.loader.ClassLoaders$AppClassLoader and java.net.URLClassLoader are in module java.base of loader 'bootstrap')         at net.minecraft.launchwrapper.Launch.<init>(Launch.java:34)         at net.minecraft.launchwrapper.Launch.main(Launch.java:28)         ... 6 more C:\Users\User\Desktop\Server>pause Press any key to continue . . .  
    • And just in case I also set the amount of RAM it can use in the gradle.properties file to org.gradle.jvmargs=-Xmx8G.
    • So I'm trying to build the clean phobos, but I keep getting this error: Unable to start the daemon process. This problem might be caused by incorrect configuration of the daemon. For example, an unrecognized jvm option is used. Please refer to the user guide chapter on the daemon at https://docs.gradle.org/4.9/userguide/gradle_daemon.html Please read the following process output to find out more:   I have my JAVA_HOME pointed at the right folder (C:\Program Files\Java\jdk-17.0.1) (I have a 64bit system), so I don't know what the problem is. Any suggestions?
    • So I should extend ITrade?
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.