Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[SOLVED][1.17.1] How to get EntityModelSet (to add custom layers to the player rendering)


JimiIT92
 Share

Recommended Posts

I'm trying to add a custom layer to the vanilla player rendering. Specifically, I'm trying to create some custom Elytras. I've already extended the vanilla Elytra Layer, and tried to attach it inside the RenderPlayerEvent.Pre event (which I'm not sure if is the right place, I'm using a 1.16.x code base as reference)

@SubscribeEvent
public static void renderPlayer(final RenderPlayerEvent.Pre event) {
	Player player = event.getPlayer();
  	PlayerRenderer renderer = event.getRenderer();
  	renderer.addLayer(new BlackElytraLayer<>(renderer, ?));
  	//? is for the missing EntityModelSet parameter
}

However, the ElytraLayer requires an EntityModelSet as parameter, to bake the Elytra Model

public ElytraLayer(RenderLayerParent<T, M> parent, EntityModelSet modelSet) {
	super(parent);
  	this.elytraModel = new ElytraModel<>(modelSet.bakeLayer(ModelLayers.ELYTRA));
}

But inside the event I see nothing that can get me an instance of this varaiable, leading me to bake the Elytra Model as well. 
So is there any way to get this or do I just have to recreate the entire Elytra model and use that in the custom layer?

Edited by JimiIT92
solved

Don't blame me if i always ask for your help. I just want to learn to be better :)

Link to comment
Share on other sites

Oh, I see. So I was listening to the wrong event. But now the problem is getting the first parameter correctly, the RenderLayerParent parameter, which I don't see being referenced by the event (sorry but I've never used this event so I don't know exactly where to look) :/

Don't blame me if i always ask for your help. I just want to learn to be better :)

Link to comment
Share on other sites

Allright, so I got the correct event now, and I'm adding the layer like this
 

@Mod.EventBusSubscriber(modid = MOD_ID, value = Dist.CLIENT)
public final class LayerRenderSubscriber {

    @SubscribeEvent(priority = EventPriority.LOW)
    public static void renderPlayer(final EntityRenderersEvent.AddLayers event) {
        LivingEntityRenderer<Player, PlayerModel<Player>> renderer = event.getRenderer(EntityType.PLAYER);
        BlackElytraLayer<Player, PlayerModel<Player>> layer = new BlackElytraLayer<>(renderer, event.getEntityModels());
        renderer.addLayer(layer);
    }
}

But the Layer doesn't render at all. Even worse, if I start the game in debug mode, a breakpoint into the event doesn't hit, so it seems like the event isn't even fired. Do I need to register something or do something else that I'm missing?

Don't blame me if i always ask for your help. I just want to learn to be better :)

Link to comment
Share on other sites

Aaah, I see! I saw that I also need to register the Layer inside the EntityRenderersEvent.RegisterLayers event. Now that I registered the layer and moved the listener to the Mod bus is finally showing 😁 Thank for your tips :) 

Don't blame me if i always ask for your help. I just want to learn to be better :)

Link to comment
Share on other sites

  • JimiIT92 changed the title to [SOLVED][1.17.1] How to get EntityModelSet (to add custom layers to the player rendering)

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.