Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[Solved] Cant run forge [1.17.1-37.0.110]


<Gl33p_0r4nge>
 Share

Recommended Posts

Hi,

I dont know why but apparently I cant run the mod at all. It worked few days ago but I dont remember what changes I did and not sure if that is the problem but heres what I got:
 

Spoiler

WARNING: Unknown module: cpw.mods.securejarhandler specified to --add-exports
WARNING: Unknown module: cpw.mods.securejarhandler specified to --add-opens
Connected to the target VM, address: '127.0.0.1:55755', transport: 'socket'
OpenJDK 64-Bit Server VM warning: Sharing is only supported for boot loader classes because bootstrap classpath has been appended
Exception in thread "main" java.lang.module.FindException: Module cpw.mods.securejarhandler not found, required by cpw.mods.modlauncher
    at java.base/java.lang.module.Resolver.findFail(Resolver.java:900)
    at java.base/java.lang.module.Resolver.resolve(Resolver.java:191)
    at java.base/java.lang.module.Resolver.resolve(Resolver.java:140)
    at java.base/java.lang.module.Configuration.resolveAndBind(Configuration.java:492)
    at java.base/java.lang.module.Configuration.resolveAndBind(Configuration.java:298)
    at cpw.mods.bootstraplauncher.BootstrapLauncher.main(BootstrapLauncher.java:83)
Disconnected from the target VM, address: '127.0.0.1:55755', transport: 'socket'

Process finished with exit code 1
 

 

Edited by <Gl33p_0r4nge>
Link to comment
Share on other sites

In File > Project Structure under ProjectSettings / Project make sure Java 16 is selected as the Project SDK. Then in File > Settings > Build, Execution, Deployment > Build Tools > Gradle (also reachable via Wrench Icon > Gradle Settings in the gradle sidebar) make sure "Project SDK" is selected as the Gradle JVM.

Link to comment
Share on other sites

  • <Gl33p_0r4nge> changed the title to [Solved] Cant run forge [1.17.1-37.0.110]

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.