Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Translucent Mob Textures


karasik
 Share

Recommended Posts

Heyo!
So I'm kinda new to this stuff, but I really need to make an entity with translucent details. Since half-transparent PNG textures don't work
I figured there are two types of render for transparent blocks & solid ones in minecraft. Also I saw someone recommended using the code to change the way of render:

@Override
public void doRender(Entity entity, double x, double y, double z, float f, float partialTicks) {



GlStateManager.pushMatrix();

GlStateManager.enableAlpha();
GlStateManager.enableBlend();



GlStateManager.color(1.0F, 1.0F, 1.0F, 0.5F);



super.doRender(entity, x, y, z, f, partialTicks);



GlStateManager.color(1.0F, 1.0F, 1.0F, 1F);



GlStateManager.disableAlpha();
GlStateManager.disableBlend();



GlStateManager.popMatrix();

super.doRender(entity, x, y, z, f, partialTicks);
}

 

Now, will it work if I use this code? And where should I put it? Like what folder, file etc.

Also, if anybody knows if there's an easier way to do that please let me know.

Thanks in advance :)

Link to comment
Share on other sites

I have no idea whether this code would work, but it would go in your mob's renderer class.

See one of mine here: https://github.com/GenElectrovise/MagiksMostEvile/blob/1.16.5/src/main/java/genelectrovise/magiksmostevile/entity/boss/kitty_the_kraken/KittyTheKrakenRenderer.java

 

I also have little idea of which method in which to put that code, though the parameters nearly match those of 

protected void applyRotations(SquidEntity entityLiving, MatrixStack matrixStackIn, float ageInTicks, float rotationYaw, float partialTicks)

... so that might be a reasonable place to start? (I know the method name doesn't match - there may be another one which is a better match but I do not have an IDE right now).

Unless someone with more knowledge can come along and enlighten us, you may need to solve this issue with trial-and-error and vanilla-code-browsing.

How to ask a good coding question: https://stackoverflow.com/help/how-to-ask

Give logs, code, desired effects, and actual effects. Be thorough or we can't help you. Don't post code without putting it in a code block (the <> button on the post - select "C-type Language"): syntax highlighting makes everything easier, and it keeps the post tidy.

 

My own mod, Magiks Most Evile: GitHub (https://github.com/GenElectrovise/MagiksMostEvile) Wiki (https://magiksmostevile.fandom.com/wiki/Magiks_Most_Evile_Wiki)

Edit your own signature at https://www.minecraftforge.net/forum/settings/signature/

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • I've used forge before, but I can't get it to work with 1.18+   Launcher code: [0116/225441.672:INFO:main_context.cpp(136)] CEF initialized successfully. [0116/225441.673:INFO:main_context.cpp(138)] CEF version: 85.3.13+gcd6cbe0+chromium-85.0.4183.121 [0116/225502.918:WARNING:angle_platform_impl.cc(48)] compileToBinary(257):  C:\fakepath(107,1-13): warning X3557: loop only executes for 1 iteration(s), forcing loop to unroll C:\fakepath(102,1-13): warning X3557: loop only executes for 1 iteration(s), forcing loop to unroll [0116/225508.369:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=2 [0116/225515.224:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=2 [0116/225515.353:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=2 [0116/225525.860:INFO:LauncherAppRenderer.cpp(51)] [Info: 2022-01-16 21:55:17.9581899: LauncherMain.cpp(104)] Initiated models [0116/225525.861:INFO:LauncherAppRenderer.cpp(51)] [Info: 2022-01-16 21:55:17.9592226: LauncherController.cpp(435)] Constructing launcher controller with workDir: C:\...\.minecraft, isActive: 0 [0116/225525.861:INFO:LauncherAppRenderer.cpp(51)] [Info: 2022-01-16 21:55:17.9819604: LauncherAppRenderer.cpp(172)] Javascript bridge extended in OnWebKitInitialized. [0116/225526.215:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=3 [0116/225526.238:INFO:LauncherAppRenderer.cpp(69)] OnBrowserDestroyed: id=3 [0116/225526.387:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=3 [0116/225538.615:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=1 [0116/225825.050:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=5 [0116/230007.904:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=6     "Latest" code [16jan.2022 23:00:09.457] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--username, Elverea, --version, 1.18.1-forge-39.0.36, --gameDir, C:\Users\Norge\AppData\Roaming\.minecraft, --assetsDir, C:\Users\Norge\AppData\Roaming\.minecraft\assets, --assetIndex, 1.18, --uuid, 31cc9858833c43488f09a460a739f964, --accessToken, ????????, --clientId, NzcyMWNmNWYtZGZhNS00YmY1LWFkMTgtMTljYjVhNzZhODM5, --xuid, 2535453675472907, --userType, msa, --versionType, release, --launchTarget, forgeclient, --fml.forgeVersion, 39.0.36, --fml.mcVersion, 1.18.1, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20211210.034407] [16jan.2022 23:00:09.462] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 9.0.7+91+master.8569cdf starting: java version 17.0.1 by Microsoft
    • Hello I'm running minecraft server 1.18.1 with forge 39.0.36 in ubuntu and tried to remove a mod, even thou the server starts it throws a bunch of  "Found a missing id from the world", I did the -Dfml.queryResult=confirm but it shows also tried to run the command directly like fml confirm and it throws ¿Which is the correct solution to get rid of all the "Found a missing id from the world" in 39.0.36?
    • Game crashes as soon as i load a chunk with my MineColonies City. https://pastebin.com/VNKgTV4T With forge-39.0.7 works well. Tested on 39.0.20 with the same behaviour (crash).
    • also there is a program called bearded octo nemesis that deobfuscate any .class files(is made for minecraft) but it doesnt work
    • I was intending to port it to 1.16.5 anyways, so yes. I am just porting my base to 1.16.5. All i am here for is to collect a few approaches on how you could achieve this.
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.