Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

It seems forge is broken when it comes to detecting what mod versions are installed


Ninjaguy169
 Share

Recommended Posts

To clarify further, forge for 1.16.5 (versions 36.2.0 - 36.2.4) has been having problems with mods. You see, I wanted to play an old kitchensink modpack that I made almost a year ago, and it worked perfectly fine. I grabbed the mod files exactly where I left them off and pasted them into the mods folder. However, I got this error when I loaded forge up:

https://imgur.com/mIPPnow

Now to clarify, not only has this worked previously with me back when I played this modpack long ago, I have also attempted to install specified versions of mods mentioned on the error screen, but to no avail.

 

My theory here was/is that forge is somehow corrupted/broken. To test that theory out, I grabbed my old server files (containing all mods used when firing up this installation of forge, including client side ones since back then I wasn't exactly fluent with minecraft modding) and launched the server successfully. It should be noted that no server-side mods (except performant) were included in my forge mods directory. 

 

In conclusion, I'm asking for any possible solutions to forge simply refusing to detect that the installed mod versions are compatible with each other. Yes, some 1.16.3 mods (as mentioned in the above screenshot) do work on 1.16.5, according to how I launched it myself. Finally, this wouldn't be a proper forge forums post without including my crash report and latest.log file.

 

(It's worth noting that since it crashes so early during the pre-loading phase, no other mods show up in the crash report file)

 

Apologies for any obvious mistakes I may have not noticed while posting this here in advance, if there were any.

 

https://gist.github.com/RaveTr/6a30411b367958c30e8f37dbc9b4d25a

 

https://gist.github.com/RaveTr/56308af48ecdf60f3f32106a3a138170

Link to comment
Share on other sites

This looks like the result of a bug in Forge where the version requirements of mods were not correctly checked. Some mods "used" this bug, in that they had incorrect dependency configurations, which didn't prevent the game from launching because this bug was present. Now the bug has been fixed, so these incorrect requirements correctly prevent the game from launching.

You either need to downgrade Forge back to the version with the bug (not recommended) or find updates for these mods.

Link to comment
Share on other sites

  • 4 weeks later...

Apologies for the late reply, but thanks. Turned out the issue was with immersive portals not being up to date with the forge version I was using at the time (mixin changes to be exact). Hope this helps anyone reading this running into this problem, even if its by the slightest

Edited by Ninjaguy169
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.