Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Pixelmon Crashes Whenever I Launch


Recommended Posts

I was add NPC's and shop items and after i finished changing them and having the .json files checked for errors (said all files that were edited were good) but when I launch the game it give me this error.

Caused by: java.io.FileNotFoundException: pixelmon:models/blocks/den/raid_den.pqc

 

 

 

---- Minecraft Crash Report ----
// I bet Cylons wouldn't have this problem.

Time: 1/16/22 2:42 AM
Description: Initializing game

java.lang.RuntimeException: java.io.FileNotFoundException: pixelmon:models/blocks/den/raid_den.pqc
    at com.pixelmonmod.pixelmon.client.ClientProxy.getStreamForResourceLocation(ClientProxy.java:844)
    at com.pixelmonmod.pixelmon.client.models.smd.ValveStudioModel.loadQC(ValveStudioModel.java:223)
    at com.pixelmonmod.pixelmon.client.models.smd.ValveStudioModel.<init>(ValveStudioModel.java:66)
    at com.pixelmonmod.pixelmon.client.models.smd.ValveStudioModelLoader.loadModel(ValveStudioModelLoader.java:53)
    at com.pixelmonmod.pixelmon.client.models.blocks.GenericSmdModel.reloadModel(GenericSmdModel.java:39)
    at com.pixelmonmod.pixelmon.client.models.blocks.GenericSmdModel.<init>(GenericSmdModel.java:25)
    at com.pixelmonmod.pixelmon.client.render.GenericModelHolder.loadModel(GenericModelHolder.java:61)
    at com.pixelmonmod.pixelmon.client.models.ModelHolder.getModel(ModelHolder.java:27)
    at com.pixelmonmod.pixelmon.client.render.RenderDen.<init>(RenderDen.java:38)
    at net.minecraftforge.fml.client.registry.RenderingRegistry.register(RenderingRegistry.java:77)
    at net.minecraftforge.fml.client.registry.RenderingRegistry.loadEntityRenderers(RenderingRegistry.java:70)
    at net.minecraft.client.renderer.entity.RenderManager.<init>(RenderManager.java:230)
    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:518)
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:378)
    at net.minecraft.client.main.Main.main(SourceFile:123)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
Caused by: java.io.FileNotFoundException: pixelmon:models/blocks/den/raid_den.pqc
    at net.minecraft.client.resources.FallbackResourceManager.func_110536_a(FallbackResourceManager.java:69)
    at net.minecraft.client.resources.SimpleReloadableResourceManager.func_110536_a(SimpleReloadableResourceManager.java:65)
    at com.pixelmonmod.pixelmon.client.ClientProxy.getStreamForResourceLocation(ClientProxy.java:842)
    ... 20 more


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- Head --
Thread: Client thread
Stacktrace:
    at com.pixelmonmod.pixelmon.client.ClientProxy.getStreamForResourceLocation(ClientProxy.java:844)
    at com.pixelmonmod.pixelmon.client.models.smd.ValveStudioModel.loadQC(ValveStudioModel.java:223)
    at com.pixelmonmod.pixelmon.client.models.smd.ValveStudioModel.<init>(ValveStudioModel.java:66)
    at com.pixelmonmod.pixelmon.client.models.smd.ValveStudioModelLoader.loadModel(ValveStudioModelLoader.java:53)
    at com.pixelmonmod.pixelmon.client.models.blocks.GenericSmdModel.reloadModel(GenericSmdModel.java:39)
    at com.pixelmonmod.pixelmon.client.models.blocks.GenericSmdModel.<init>(GenericSmdModel.java:25)
    at com.pixelmonmod.pixelmon.client.render.GenericModelHolder.loadModel(GenericModelHolder.java:61)
    at com.pixelmonmod.pixelmon.client.models.ModelHolder.getModel(ModelHolder.java:27)
    at com.pixelmonmod.pixelmon.client.render.RenderDen.<init>(RenderDen.java:38)
    at net.minecraftforge.fml.client.registry.RenderingRegistry.register(RenderingRegistry.java:77)
    at net.minecraftforge.fml.client.registry.RenderingRegistry.loadEntityRenderers(RenderingRegistry.java:70)
    at net.minecraft.client.renderer.entity.RenderManager.<init>(RenderManager.java:230)
    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:518)

-- Initialization --
Details:
Stacktrace:
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:378)
    at net.minecraft.client.main.Main.main(SourceFile:123)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

 

Edited by Cereal4Breakfast
removed system details
Link to comment
Share on other sites

I found out that my modpack didn't have the textures file so I transferred it over and it's still giving me the same error but the den file is raid_den.png and its wants a raid.den.pqc

Edited by Cereal4Breakfast
typed the file name wrong
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • server failed to start and gives me "Failed to load data packs, can't proceed with server load. You can either fix your data packs or reset to vanilla with --safeMode" error when i look in my logs. its updated to the latest version of forge(40.1.0), and I don't have any data packs installed as far as I know. And I will upload the full logs if asked as i dont know how to attach a document to this post.  
    • Pioneer Craft [modded] {1.18.2} {SMP} {Community} {Light Roleplay} We are Pioneer Craft and we seek you !!! We are building a community of passionate players to build, trade, and share some laughs with. Are you tired of playing alone? Or are you here seeking a server with dedicated members; a server where you are not overlooked and can voice your opinions? If you are interested in these things too, then come join us in Pioneer Craft! Our server is player built and driven. We have a custom mod pack with mods chosen by our community to suit our needs. We have designed our server for player driven roleplay! There will be four communities which will each be self-sufficient. We encourage and seek builders who want to create a beautiful world to live in. This is a whitelist server and we are looking for dedicated applicants and experienced builders. Applications are located on our website which can be accessed through the discord. Other than the application questions, we are requesting photos of your prior builds which will be taken into consideration. Please show photos of your builds in the share-your-work section of the discord. The server uses CurseForge to run. This server is for mature members (16+) . Discord (must join): https://discord.gg/c4uJvb29CN
    • Pioneer Craft [modded] {1.18.2} {SMP} {Community} {Light Roleplay} We are Pioneer Craft and we seek you !!! We are building a community of passionate players to build, trade, and share some laughs with. Are you tired of playing alone? Or are you here seeking a server with dedicated members; a server where you are not overlooked and can voice your opinions? If you are interested in these things too, then come join us in Pioneer Craft! Our server is player built and driven. We have a custom mod pack with mods chosen by our community to suit our needs. We have designed our server for player driven roleplay! There will be four communities which will each be self-sufficient. We encourage and seek builders who want to create a beautiful world to live in. This is a whitelist server and we are looking for dedicated applicants and experienced builders. Applications are located on our website which can be accessed through the discord. Other than the application questions, we are requesting photos of your prior builds which will be taken into consideration. Please show photos of your builds in the share-your-work section of the discord. The server uses CurseForge to run. This server is for mature members (16+) . Discord (must join): https://discord.gg/c4uJvb29CN 
    • Update: I didn't need capabilities. In fact, I didn't need to override applyEffectTick at all. But it seems like I need reflections. The increased hitbox size now works for both entity and block collision--with a little drawback. This is what it looks like so far: // this event handler checks every tick if the living entity has the "big" effect @SubscribeEvent public static void entitySizeChange(LivingEvent.LivingUpdateEvent event) { LivingEntity livingEntity = event.getEntityLiving(); if (livingEntity.getActiveEffectsMap() != null && livingEntity.hasEffect(ModEffects.BIG.get())) { EntityDimensions newDims = livingEntity.getDimensions(livingEntity.getPose()).scale(8.0F, 2.0F); try { // using reflection Field field = Entity.class.getDeclaredField("dimensions"); field.setAccessible(true); field.set(livingEntity, newDims); // setting the living entity's EntityDimensions EntityDimensions newEntityDimensions = (EntityDimensions) field.get(livingEntity); livingEntity.setBoundingBox(newEntityDimensions.makeBoundingBox( // setting the living entity's AABB livingEntity.getX(), livingEntity.getY(), livingEntity.getZ() )); } catch (NoSuchFieldException | IllegalAccessException e) { e.printStackTrace(); } } }   The aforementioned drawback is that, when the effect wears off, the living entity's still keeps its bigger hitbox until it changes pose (i.e. my player crouching). Given that the EntityEvent.Size event fires whenever an entity changes pose, should I manually fire it with EVENT_BUS::post when that entity's effect wears off? If so, where? I tried manually firing EntityEvent.Size on my overridden removeAttributeModifiers(), but to no avail. 
    • I'm working with very limited recourses on my PC so I wish this graph worked properly I allowed 3gbs when I created the server and now decided to bump it up to 6G's I'm having the same issue as OP there is no update on the GUI itself that says so, it gets to 1% free and seems to stop at 2800ish MB's of space and the entire server starts to lag. This is extremely frustrating I've looked around the internet and can't seem to find ANY fix about this. My user_jvm_args file looks as so. # Xmx and Xms set the maximum and minimum RAM usage, respectively. # They can take any number, followed by an M or a G. # M means Megabyte, G means Gigabyte. # For example, to set the maximum to 3GB: -Xmx3G # To set the minimum to 2.5GB: -Xms2500M # A good default for a modded server is 4GB. # Uncomment the next line to set it. -Xmx4G -Xms2G I read on reddit that adding an Xms command at the end fixed it for someone but it didn't for me at all.
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.