Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Updating from 1.16.4 to 1.16.5 (javafml)


MWR
 Share

Recommended Posts

I have been trying to update my mod from 1.16.4 to 1.16.5, so I updated the Gradle and mods.toml file to match with 1.16.5. Even when refreshing, I boot up the dev client and get the error "Mod File in-development needs language provider javafml:36 or above to load." How can I update javafml? Or am I updating the mod incorrectly?

Link to comment
Share on other sites

11 hours ago, Luis_ST said:

you also need to update the loaderVersion in the mods.toml

I did, but it still won’t update, even after refreshing the Gradle and entire project.

Edited by MWR
Link to comment
Share on other sites

3 hours ago, Luis_ST said:

post mods.toml

modLoader="javafml"
loaderVersion="[36,)"
license="MIT"
[[mods]]
modId="honeystickypistonmod"
version="${file.jarVersion}"
displayName="Honey Sticky Piston Mod"
logoFile="examplemod.png"
credits="Thanks to Cy4 and their community for teaching me how to mod and samjviana for some helpful code!"
authors="MWR_"
description='''
A new sticky piston that you can craft with honey!
'''
[[dependencies.myfirstmod]]
    modId="forge"
    mandatory=true
    versionRange="[36,)"
    ordering="NONE"
    side="BOTH"
[[dependencies.myfirstmod]]
    modId="minecraft"
    mandatory=true
    versionRange="[1.16.5,1.17)"
    ordering="NONE"
    side="BOTH"

Actually I think I know the problem. It isn't the mod itself but the referenced libraries. Even with refreshing, it still keeps the jar files for 1.16.4, so when I load the client, it runs 1.16.4 and not 1.16.5. If I build the mod and play it through the Minecraft launcher on Forge 1.16.5, it works fine.

If that's the issue, then how do I refresh those libraries?

Edited by MWR
Found potential problem
Link to comment
Share on other sites

2 hours ago, MFMods said:

there is a "dependencies" section in build gradle. did you update that? if not, download MDK for the new version, compare two build.gradle files and update old one.

I already have, and I've learned that the mod works in 1.16.5, but the version of Minecraft I run within Eclipse is not working. It keeps trying to run 1.16.4. I ran the genEclipseRuns task in the command line, which said it downloaded forge 1.16.5, but Eclipse still refers to the old version. I tried refreshing both the Gradle and entire project, but nothing worked.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.