Jump to content

Glowing block render help


Dawars
 Share

Recommended Posts

Okay, I think I've got it and what about animation?

i dont really understand the question, what kind of animation you want to do

because if its

How can I render the breaking texture on the top?

that will be taken care of automaticly, like every other block :)

how to debug 101:http://www.minecraftforge.net/wiki/Debug_101

-hydroflame, author of the forge revolution-

Link to comment
Share on other sites

I thougt that I make a blockrenderer because that's where I can disable lighting I think but then I think it won't display the breaking textures.

blockrenderer =ISimpleBlockRenderingHandler ?

because the breaking texture will appear no mater what you do.

 

I have like 10 textures in a file and the block changes the current one constatnly and if I make a new renderer I don't know how to change them regularly

texture dont go in files, IMAGES go in files (texture ares on GPU)

10 of those in the same file is kinda of bad btw (yes notch is bad in that way)

how are they changing ? depending on metadata? or time based ? (or other factor)

 

if its something else then metadata you will need to use a TESR and its not recommended if it's a block apparearing in huge quantity

how to debug 101:http://www.minecraftforge.net/wiki/Debug_101

-hydroflame, author of the forge revolution-

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • yeah i did. tried activating and deactivating mods at random until it stopped crashing but it didn't change anything ty!
    • also, just had to set up account to post this and noticed like 3 times I had to pick the right segments of images to verify before moving on.  I can't imagine that there are enough threat actors with their attention on minecraft modding communities to justify that level of protection.  Maybe the guys making these amazing and cool mods are kind of jerks about it, hahah?  Maybe, like other companies, customer service or satisfaction isn't that high a priority.  I don't feel like they get paid very much for making Forge and Minecraft Mods, I mean I wasn't required to pay anything to the creators to set this up.   Anyway, just wanted to vent.
    • Ok, I found this site while searching for the missing version .jar file, which didn't show up in a net query through DuckDuckGo.  The thread on this site was closed after a comment from someone listed as a coder who stated that it was meant to work in this way, without a .jar file which is no longer necessary.  From earlier posts it seems that this person believed the OP had issues due to use of non vanilla launcher, which to me means he thinks they use a client or something like this.  The OP immediately said that they use vanilla, but doesn't seem like the coder believed them.  They began asking for logs, OP did not provide them.  No need to go further into details. I just reinstalled Windows on an SSD and just installed Minecraft Java, Optifine, Shader, Forge.  That is all that exists on my pc right now, and I had the same issue with 1.19.2 Forge versions not creating .jar file. Now I admit that I am likely missing something here and there is a technicality that isn't being fulfilled, but I have to say that it is not due to using a modified launcher.  All i have done is install optifine, put a shader into the shader folder, installed forge.  No mods yet, nothing.  What is interesting, and is the only reason I felt the need to post here, is that when I went into minecraft library folder and copied forge-1.19.2-43.1.65-client.jar, (I renamed it without the -client,) the Forge version starts up just fine with no further issues. From my point of view it seems that coders are dismissing some valid issues out of hand.  I mean, there are lots of really stupid and lazy people using computers and playing games, but not all of them are really stupid and lazy.  We all have bias, I know that I do as well, and I think it's helpful to be aware of our bias as far as we have the ability to be aware of it. Again, it could be that my assumption that there is a problem with the installer not creating a version .jar file, but I couldn't get it to work, always failed with the same message and then put the .jar file in the version folder and worked without a hitch. Oh, almost forgot, I also went into each installation and changed from 2 to 20GB RAM for the game.  In the past I had issues crashing with many mods installed due to lower RAM allocations and I have 48GB, so felt that was safe enough either way.  Maybe that caused the issue, for all I know.   Just saying, would have been nice if the coder had said go to (generic/vanilla path) and copy (version I used as example) forge-1.19.2-43.1.65-client, paste into forge version folder, rename to forge-1.19.2-43.1.65 and see if that does it.
    • What would make my mod incompatible? I'm very afraid of this. I was making some changes to the game using events. but they would only change items created in my own mod. What is the chance of incompatibility?
    • Hello, Im playing on 1.16.5 and Its keep crashing whenever I try to join a world and I get an error message saying "The game crashed whilst ticking memory connection Error: java.lang.NullPointerException: Ticking memory connection". Heres the crash log https://pastebin.com/rqZtSBms
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.