Jump to content

Pickaxe not mining


Recommended Posts

I'm using forge 1.18.2 and I can't use my pickaxe. Whenever I break a stone or ores with it nothing drops, and it mines as slowly as an empty hand. Has anyone else encountered this problem? if so, have you found any fixes? I've tried reimstalling minecraft and forge, but that did nothing.

Link to comment
Share on other sites

Is this a modded pickaxe you created? Post the code for your pickaxe, in particular




If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

  • 3 months later...

Same here. Those are the mods i installed before my pickaxes stopped working: incantationem-1.1.6+1.19, peculia-0.1.6-beta-1.19, FishingRework-0.2.2, midnightlib-0.6.1, repurposed_structures_fabric-6.1.1+1.19, Professions-1.19.2-FABRIC-1.0.0.jar, BambooEverything-fabric-2.2.1-build.27+mc1.19.2, simplyswords-1.30-1.19.x, autoswitch-5.4.4, BetterF3-1.4.0-Fabric-1.19.2, almost_bedtime-1.0-1.19.2, bydesign-1.0.1, redpanda-fabric-1.19.2-1.0.1 and DisableCustomWorldsAdvice-3.0.


Link to comment
Share on other sites

  • 2 months later...
  • 1 month later...

I also have that problem, someone said it was a problem with deeper and darker, which I uninstalled, and its still not working.

mod list:

(1.19.2 forge)

anthill inside

apple skin

Aquatic additions

aquatic torches

additional additions

additional structures

alexs armory

alexs mobs

auto third person 




banilla claws

bartering station

better fishing rods




brutal bosses

chiseled bricks

choiceTheorem’s overhauled village


climb ladders fast

cloth config API



creative core

creatures and beasts

creeper overhaul


curios API

customized dungeon loot

darker depths

deepslate tweaks

different guardians

dungeon clusters

dungeons enhanced

easy magic

eating animation

enchant with mob

enchantment descriptions

enhanced celestials

epic knights

epic paladins

evocation and annihilation

extra golems

fabric API

falling attack

first person model

forge creeper heal (unofficial)


friends and foes

from spores

from the shadows





Goblin traders

goblin community

guard villagers

hunter illager

illage and spillage

illagers wear armor

immersive armor

inventory hud

iron bows

iron chests

iron furnaces

it takes a pillage

item upgrader

item upgrader core

just enough golems



L_Enders cataclysm

library ferret

loot beams


magic totems

mimic mod

monster plus

more babies

more villagers

more yoyos

mouse tweaks

MrCrayfish gun mod

muffins slime golem


nether depths upgrade


not enough animations

Nyfs spiders


player companions

player revive

productive bees

puzzles lib

pyrologer and friends


quark oddities


rare ice

reimplemented additions


savage and ravage

simplecore api


spells and shields

spelunking bags

spikey spikes

spoorn weapon attributes 

spoorn armor attributes 


structory: towers

structure gel api

sullys mod

tameable beasts

the conjurer

towns and towers



underground villages

unique enchantments

unique enchantments - battle

unique enchantments - utils

unique enchantments base


withers weapons

YDMs allay

YDMs weird mobs


if you made it this far thank you and pls help!!



  • Like 1
Link to comment
Share on other sites

  • 1 month later...

if you extract a mod, lets say modA, then go into data then minecraft then tags then blocks then into minable then into the pickaxe file(its a bunch of code) this is where the blocks that can be mined with a pickaxe are specified. if stone or other blocks are not there then it is modA that is causing this problem

Link to comment
Share on other sites

when you make custom blocks
if you want them to break whith a picaxe item you must declare block name inside the pickaxe file  


		    "replace": false,
		    "values": [


but if you mispell a block name or add a non existing block or you forget  

the ".requiresCorrectToolForDrops()" thing at declaring just one of the blocks

	public static final RegistryObject<Block> TOILET_BLOCK_COBBLESTONE = registerBlock("toilet_block_cobblestone",
			() -> new toilet(Block.Properties.copy(Blocks.COBBLESTONE).requiresCorrectToolForDrops()) );

in any of this cases gonna damage the pickaxe behaveour for all the running mods 

soo be carefull whit that 

Edited by perromercenary00
Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...
  • 1 month later...
  • 1 year later...

can someone help me out I'm trying to figure out why I cannot mind nothing with a pickaxe I tried every type of pickaxe and i'm still not get any material on mine a block plz help ps and i add Load My F***ing Tags and still nothing


Edited by CrazyMexicanVr
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.