Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

DecoderException kicks


LukiP0P
 Share

Recommended Posts

Hello, again. I cant join my own 1.18.2 server because DecoderExceptions (incorrect header check, invalid distance too far back, etc.) other players dont have this problem, is it fault of my connection? Server just says "disconnected" and client is just disconnecting from server. Please help, I try to make this server work for few days, 1.18.2 is way more problematic than 1.12.2.

Link to comment
Share on other sites

Neither of those logs contains the "DecoderExceptions (incorrect header check, invalid distance too far back, etc.)" error message?

The server does have a message saying you disconnected as you say.

And the client has a message saying JEI is responding to a disconnect event, but no error message.

Quote

[05Aug2022 15:23:43.850] [Render thread/INFO] [mezz.jei.forge.startup.StartEventObserver/]: JEI StartEventObserver received class net.minecraftforge.client.event.ClientPlayerNetworkEvent$LoggedOutEvent

 

The "DecoderException" error message says there is a problem with the decompression of the network packet.

One thing I notice is you have the following on the client:

Quote

[05Aug2022 14:10:10.450] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 9.1.3+9.1.3+main.9b69c82a starting: java version 17.0.1 by Microsoft

[05Aug2022 14:18:53.519] [Server Pinger #0/DEBUG] [io.netty.util.NetUtil/]: -Djava.net.preferIPv4Stack: true

[05Aug2022 14:18:53.519] [Server Pinger #0/DEBUG] [io.netty.util.NetUtil/]: -Djava.net.preferIPv6Addresses: false

[05Aug2022 14:18:53.924] [Server Pinger #0/DEBUG] [io.netty.util.NetUtilInitializations/]: Loopback interface: lo (Software Loopback Interface 1, 127.0.0.1)

but on the server it is

Quote

[05Aug2022 14:06:30.433] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 9.1.3+9.1.3+main.9b69c82a starting: java version 17.0.4 by N/A

[05Aug2022 14:10:00.889] [Server thread/DEBUG] [io.netty.util.NetUtil/]: -Djava.net.preferIPv4Stack: false

[05Aug2022 14:10:00.889] [Server thread/DEBUG] [io.netty.util.NetUtil/]: -Djava.net.preferIPv6Addresses: false

[05Aug2022 14:10:00.893] [Server thread/DEBUG] [io.netty.util.NetUtilInitializations/]: Loopback interface: lo (lo, 0:0:0:0:0:0:0:1%lo)

So it looks like the server is trying to use ipv6.

 

If you look at the changelog for forge 1.18.2

https://maven.minecraftforge.net/net/minecraftforge/forge/1.18.2-40.1.69/forge-1.18.2-40.1.69-changelog.txt

It says

Quote

- 40.1.62 [1.18.x] Implement full support for IPv6 (#8376)

 

So one option would be try the latest release of forge, 40.1.69 which has this change.

 

Another would be to configure the server to use ipv4 like the client?

-Djava.net.preferIPv4Stack=true

 

NOTE: I don't know if this really the cause of the DecoderException, it could be caused by one of the mods and the ip version is just a red herring. 🙂

  • Like 1
Link to comment
Share on other sites

6 hours ago, warjort said:

Neither of those logs contains the "DecoderExceptions (incorrect header check, invalid distance too far back, etc.)" error message?

The server does have a message saying you disconnected as you say.

And the client has a message saying JEI is responding to a disconnect event, but no error message.

 

The "DecoderException" error message says there is a problem with the decompression of the network packet.

One thing I notice is you have the following on the client:

but on the server it is

So it looks like the server is trying to use ipv6.

 

If you look at the changelog for forge 1.18.2

https://maven.minecraftforge.net/net/minecraftforge/forge/1.18.2-40.1.69/forge-1.18.2-40.1.69-changelog.txt

It says

 

So one option would be try the latest release of forge, 40.1.69 which has this change.

 

Another would be to configure the server to use ipv4 like the client?

-Djava.net.preferIPv4Stack=true

 

NOTE: I don't know if this really the cause of the DecoderException, it could be caused by one of the mods and the ip version is just a red herring. 🙂

server now kicks me off rarely, but theres connection reset more often and kicks everyone, output says only timed out

Link to comment
Share on other sites

Quote

[05Aug2022 23:49:40.694] [Render thread/WARN] [net.minecraft.client.multiplayer.ClientPacketListener/]: Unknown custom packet identifier: supermartijn642configlib:sync_configs

[05Aug2022 23:49:40.694] [Render thread/WARN] [net.minecraft.client.multiplayer.ClientPacketListener/]: Unknown custom packet identifier: spawnermod:main

These messages look suspicious. They represent network packets the server sent, but the client doesn't understand them.

Check you have latest versions of those mods on the client and server and then ask the mod authors if these are a problem.

Edited by warjort
Link to comment
Share on other sites

You also have a number of long ticks before you got disconnected.

Quote

[05Aug2022 23:50:26.884] [Server thread/WARN] [net.minecraft.server.MinecraftServer/]: Can't keep up! Is the server overloaded? Running 4621ms or 92 ticks behind

[05Aug2022 23:50:46.016] [Server thread/WARN] [net.minecraft.server.MinecraftServer/]: Can't keep up! Is the server overloaded? Running 4153ms or 83 ticks behind

[05Aug2022 23:51:05.733] [Server thread/WARN] [net.minecraft.server.MinecraftServer/]: Can't keep up! Is the server overloaded? Running 4720ms or 94 ticks behind

[05Aug2022 23:51:25.138] [Server thread/WARN] [net.minecraft.server.MinecraftServer/]: Can't keep up! Is the server overloaded? Running 4426ms or 88 ticks behind

[05Aug2022 23:51:44.664] [Server thread/WARN] [net.minecraft.server.MinecraftServer/]: Can't keep up! Is the server overloaded? Running 4552ms or 91 ticks behind

[05Aug2022 23:52:03.629] [Server thread/WARN] [net.minecraft.server.MinecraftServer/]: Can't keep up! Is the server overloaded? Running 3966ms or 79 ticks behind

[05Aug2022 23:52:08.472] [Server thread/INFO] [net.minecraft.server.network.ServerGamePacketListenerImpl/]: LukiP0P lost connection: Timed out

Are you sure your computer can run both the server and your client at the same time?

Look at task manager and check your memory status.

It might be doing a lot of paging of memory to and from disk if you don't have enough real memory to run both.

Link to comment
Share on other sites

13 hours ago, warjort said:

You also have a number of long ticks before you got disconnected.

Are you sure your computer can run both the server and your client at the same time?

Look at task manager and check your memory status.

It might be doing a lot of paging of memory to and from disk if you don't have enough real memory to run both.

Client is running on diffrent machine, cpu usage on machine where server is hosted is like max 50/60% and memory is on around 70%

Link to comment
Share on other sites

13 hours ago, warjort said:

These messages look suspicious. They represent network packets the server sent, but the client doesn't understand them.

Check you have latest versions of those mods on the client and server and then ask the mod authors if these are a problem.

I dont think thats cause of the problem, Ive had same problem before adding this lib, and mod version is same on both machines

Edited by LukiP0P
Link to comment
Share on other sites

13 hours ago, warjort said:

[05Aug2022 23:50:26.884] [Server thread/WARN] [net.minecraft.server.MinecraftServer/]: Can't keep up! Is the server overloaded? Running 4621ms or 92 ticks behind

[05Aug2022 23:50:46.016] [Server thread/WARN] [net.minecraft.server.MinecraftServer/]: Can't keep up! Is the server overloaded? Running 4153ms or 83 ticks behind

[05Aug2022 23:51:05.733] [Server thread/WARN] [net.minecraft.server.MinecraftServer/]: Can't keep up! Is the server overloaded? Running 4720ms or 94 ticks behind

[05Aug2022 23:51:25.138] [Server thread/WARN] [net.minecraft.server.MinecraftServer/]: Can't keep up! Is the server overloaded? Running 4426ms or 88 ticks behind

[05Aug2022 23:51:44.664] [Server thread/WARN] [net.minecraft.server.MinecraftServer/]: Can't keep up! Is the server overloaded? Running 4552ms or 91 ticks behind

[05Aug2022 23:52:03.629] [Server thread/WARN] [net.minecraft.server.MinecraftServer/]: Can't keep up! Is the server overloaded? Running 3966ms or 79 ticks behind

[05Aug2022 23:52:08.472] [Server thread/INFO] [net.minecraft.server.network.ServerGamePacketListenerImpl/]: LukiP0P lost connection: Timed out

This is moment where ive had "connection retry" message at client after geting kicked

Link to comment
Share on other sites

To be sure, you run the Forge Server without Mods and join with a client without Mods?
If this is the case one of the Mods you are using is broken, unfortunately the logs do not contains any helpful informations.
Because of this, you probably have no choice but to use binary search to find the broken Mod.

The procedure is simple:

  1. Remove half of the existing things, and put them aside.
  2. Run the program / game.
  3. Does the issue still exist?
    If YES: Repeat from step 1 with the current things.
    IF NO: Swap out the current things with the ones set aside, and repeat from step 1.
  4. Repeat this process until the problematic thing/s have been found.
  5. If you have found the Mod which cause the issue, make sure the Mod is the on with the issue by only use this Mod.
  6. Report the Bug to the Mod author, and tell us which Mod was it (for further issues).
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.