Jump to content

Forge keeps not wanting to load into my server and I cannot for the life of me figure out why.


Recommended Posts

I've been trying to figure out why for hours. Absolutely impossible for me, maybe someone smarter in here can help.

Idk where to post logs since they're too long for hastebin , so here's a download of both Server and client logs: https://fromsmash.com/Bpfnsjg9BW-dt

Edited by andylmfao
Link to comment
Share on other sites

It's the original log. Whenever you open the game, the last log gets put in a zip folder when you open the game. I accidentally opened the wrong modpack, where i didn't try to join the server, hence why i posted debug-1.log, the original log. It is the exact same thing, It just has a different name.

Link to comment
Share on other sites

Quote

[14Aug2022 16:15:40.220] [modloading-worker-0/ERROR] [REI/]: Failed to load plugin: org.cyclops.integrateddynamicscompat.modcompat.jei.JEIIntegratedDynamicsConfig
java.lang.NoClassDefFoundError: mezz/jei/forge/platform/PlatformHelper
        at org.cyclops.integrateddynamicscompat.modcompat.jei.JEIIntegratedDynamicsConfig.<clinit>(JEIIntegratedDynamicsConfig.java:47) ~[IntegratedDynamics-1.18.2-1.11.8.jar%23199!/:1.11.8]
        at java.lang.Class.forName0(Native Method) ~[?:?]
        at java.lang.Class.forName(Class.java:375) ~[?:?]
        at me.shedaniel.rei.forge.AnnotationUtils.scanAnnotation(AnnotationUtils.java:73) ~[RoughlyEnoughItems-8.3.525.jar%23268!/:?]
  Caused by: java.lang.ClassNotFoundException: mezz.jei.forge.platform.PlatformHelper
        at jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:641) ~[?:?]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:520) ~[?:?]
        at cpw.mods.cl.ModuleClassLoader.loadClass(ModuleClassLoader.java:134) ~[securejarhandler-1.0.3.jar:?]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:520) ~[?:?]
        at cpw.mods.cl.ModuleClassLoader.loadClass(ModuleClassLoader.java:134) ~[securejarhandler-1.0.3.jar:?]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:520) ~[?:?]
 

It looks like you have an issue where IntegratedDynamics is expecting to find a JEI class, but you have REI installed?

You should check you have the latest version of these mods then contact the mod authors.

Boilerplate:

If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.