Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Problem with 'java.lang.NoSuchFieldError'


Sajeyson
 Share

Recommended Posts

To test my library (main module) I have another module 'mod' (basically new mod built on library), which works absolutely perfectly. But after building the library and putting as dependency for another project, all is great until,  I using final field from my own library. Exception: 'java.lang.NoSuchFieldError'.

Gradle dependencies:

flatDir {
	dir 'libs' // Contains LibraryName-version.jar and Contains LibraryName-version-sources.jar
}

dependencies {
  implementation name: 'LibraryName'
}

Used final fields from library:

public class FormattingUtils {
    public static Style newColor(String color) {
        return Style.EMPTY.withColor(TextColor.parseColor(color));
    }
}

public class UsefulColors { 
    public static final Style ACTUAL_GREEN = FormattingUtils.newColor("#00b36b");
    //...
	//...
}

Minecraft Forge: 1.19.2-43.0.7

Possible fixes?

Link to comment
Share on other sites

If your library is the obfuscated version, you need to use fg.deobf, examples from the mdk

https://github.com/MinecraftForge/MinecraftForge/blob/1.19.x/mdk/build.gradle#L134

Boilerplate:

If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

Posted (edited)

Thanks! It's working, but, when I looking at library's classes I get:

// Failed to get sources. Instead, stub sources have been generated by the disassembler.
// Implementation of methods is unavailable.

 

Edited by Sajeyson
Link to comment
Share on other sites

Don't know sorry.

I've never used flatdir so I don't know how it works or interacts with ForgeGradle deobfuscation.

You might have to attach the sources manually in your ide?

 

Boilerplate:

If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.