Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[SOLVED] [1.19.2] Item rendering dark in inventory


JimiIT92
 Share

Recommended Posts

I'm porting my mod to 1.19.2 and I noticed that Items with the forge:separate_transforms loader in the Item Model are rendered too dark inside the Inventory.

This is how one of them looks right now

SF9i8NG.png

And this is how it looks inside an Item Frame (which is correct)

l4ZBDDQ.png

This is the Item model file

{
  "loader": "forge:separate_transforms",
  "base": {
    "parent": "builtin/entity",
    "gui_light": "front",
    "textures": {
      "particle": "blazersmod:item/spear"
    },
    "display": {
      "thirdperson_righthand": {
        "rotation": [ 0, 60, 0 ],
        "translation": [ 11, 17, -2 ],
        "scale": [ 1, 1, 1 ]
      },
      "thirdperson_lefthand": {
        "rotation": [ 0, 60, 0 ],
        "translation": [ 3, 17, 12 ],
        "scale": [ 1, 1, 1 ]
      },
      "firstperson_righthand": {
        "rotation": [ 0, -90, 25 ],
        "translation": [ -3, 17, 1],
        "scale": [ 1, 1, 1 ]
      },
      "firstperson_lefthand": {
        "rotation": [ 0, 90, -25 ],
        "translation": [ 13, 17, 1],
        "scale": [ 1, 1, 1 ]
      }
    }
  },
  "perspectives": {
    "gui": {
      "parent": "blazersmod:item/spear_inventory"
    },
    "fixed": {
      "parent": "blazersmod:item/spear_inventory"
    },
    "ground": {
      "parent": "blazersmod:item/spear_inventory"
    }
  },
  "overrides": [
    {
      "predicate": {
        "throwing": 1
      },
      "model": "blazersmod:item/spear_throwing"
    }
  ]
}

And this is the Inventory model file

{
  "parent": "item/generated",
  "gui_light": "front",
  "textures": {
    "layer0": "blazersmod:item/spear"
  }
}

As you can see I already tried to add the gui_light: front property to the Inventory model, but it looks like is ignored.

What should I add to light those items correctly?

Edited by JimiIT92
Solved

Don't blame me if i always ask for your help. I just want to learn to be better :)

Link to comment
Share on other sites

Thank you, for some reasone I didn't tried that and I thought it wasn't necessary since you override it 😅 Added outside the base object, now it works :) 

  • Like 1

Don't blame me if i always ask for your help. I just want to learn to be better :)

Link to comment
Share on other sites

  • JimiIT92 changed the title to [SOLVED] [1.19.2] Item rendering dark in inventory

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.