Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Minecraft crashes ingame.


Raven118
 Share

Recommended Posts

So I'm installing a bunch of mods and it worked fine until I was actually inside a world playing.

Right above the error report it mentioned forge with a problem so I figured I should post the report I got after using cmd to start minecraft.

 

Method not found: forge.ForgeHooks.onEntityLivingJump

setupTexture: "/particles.png", id: 61

Method not found: forge.ForgeHooks.onEntityLivingFall

setupTexture: "/mob/enderman.png", id: 62

setupTexture: "/mob/enderman_eyes.png", id: 63

Method not found: forge.ForgeHooks.onEntityLivingAttacked

Method not found: forge.ForgeHooks.onEntityLivingHurt

java.lang.ClassCastException: java.lang.Boolean cannot be cast to java.lang.Inte

ger

        at Reflector.callInt(Reflector.java:199)

        at acq.c(EntityLiving.java:972)

        at acq.a(EntityLiving.java:835)

        at yy.a(SourceFile:42)

        at acq.e(EntityLiving.java:1160)

        at nn.a(Entity.java:935)

        at nn.b(Entity.java:779)

        at acq.a_(EntityLiving.java:1271)

        at acq.e(EntityLiving.java:1489)

        at yy.e(SourceFile:26)

        at cb.e(SourceFile:31)

        at acq.J_(EntityLiving.java:687)

        at yy.J_(SourceFile:30)

        at cb.J_(SourceFile:36)

        at xD.a(World.java:2194)

        at xD.f(World.java:2165)

        at xD.n(World.java:2047)

        at net.minecraft.client.Minecraft.k(Minecraft.java:1867)

        at net.minecraft.client.Minecraft.x(Minecraft.java:822)

        at net.minecraft.client.Minecraft.run(Minecraft.java:750)

        at java.lang.Thread.run(Unknown Source)

2012-08-11 23:50:47 [sEVERE] A critical error has occurred.

java.lang.ClassCastException: java.lang.Boolean cannot be cast to java.lang.Inte

ger

        at Reflector.callInt(Reflector.java:199)

        at acq.c(EntityLiving.java:972)

        at acq.a(EntityLiving.java:835)

        at yy.a(SourceFile:42)

        at acq.e(EntityLiving.java:1160)

        at nn.a(Entity.java:935)

        at nn.b(Entity.java:779)

        at acq.a_(EntityLiving.java:1271)

        at acq.e(EntityLiving.java:1489)

        at yy.e(SourceFile:26)

        at cb.e(SourceFile:31)

        at acq.J_(EntityLiving.java:687)

        at yy.J_(SourceFile:30)

        at cb.J_(SourceFile:36)

        at xD.a(World.java:2194)

        at xD.f(World.java:2165)

        at xD.n(World.java:2047)

        at net.minecraft.client.Minecraft.k(Minecraft.java:1867)

        at net.minecraft.client.Minecraft.x(Minecraft.java:822)

        at net.minecraft.client.Minecraft.run(Minecraft.java:750)

        at java.lang.Thread.run(Unknown Source)

2012-08-11 23:50:47 [sEVERE] 9 mods loaded

Optifine OptiFine_1.2.5_HD_U_C7

Minecraft Forge 3.3.7.135

FML v2.2.48.135

Forge Mod Loader version 2.2.48.135 for Minecraft 1.2.5

        mod_MinecraftForge : Available (minecraft.jar)

        mod_Arrows : Available (minecraft.jar)

        mod_adventureItems : Available (adventureItems.zip)

        mod_Armor : Available (ArmorStand 1.2.5.zip)

        mod_betterDungeons : Available (BetterDungeons.zip)

        MillÚnaire : Available (millenaire3.0.0r3.zip)

        mod_Shelf : Available (Shelf 1.2.5.zip)

        Balkon's WeaponMod : Available (WeaponMod.zip)

        mod_ThaumCraft : Available (ThaumCraft2.1.6d.zip)

 

Now I went and ran it with cmd agien to get the full report.

 

 

C:\Users\Emil Thorndal\Desktop>java -Xms1G -Xmx1G -cp Minecraft.exe net.minecraf

t.LauncherFrame

27 achievements

182 recipes

Setting user: ladan208, -7726939135900711266

LWJGL Version: 2.4.2

Skipping bad option: ofChunkLoading:2

 

OptiFine_1.2.5_HD_U_C7

Sun Aug 12 16:03:20 CEST 2012

OS: Windows 7 (amd64) version 6.1

Java: 1.7.0_05, Oracle Corporation

VM: Java HotSpot 64-Bit Server VM (mixed mode), Oracle Corporation

LWJGL: 2.4.2

OpenGL: Intel® HD Graphics Family version 3.0.0 - Build 8.15.10.2342, Intel

OpenGL Version: 3.0

OpenGL Fancy fog: Not available (GL_NV_fog_distance)

Checking for new version

setupTexture: "/title/mojang.png", id: 1

Aug 12, 2012 4:03:20 PM cpw.mods.fml.common.FMLCommonHandler beginLoading

INFO: Attempting early MinecraftForge initialization

Aug 12, 2012 4:03:20 PM cpw.mods.fml.common.FMLCommonHandler beginLoading

INFO: Completed early MinecraftForge initialization

2012-08-12 16:03:20 [iNFO] Forge Mod Loader version 2.2.48.135 for Minecraft 1.2

.5 loading

2012-08-12 16:03:20 [iNFO] Forge Mod Loader has detected optifine OptiFine_1.2.5

_HD_U_C7, enabling compatibility features

2012-08-12 16:03:20 [iNFO] Loading mods from C:\Users\Emil Thorndal\AppData\Roam

ing\.minecraft\mods

2012-08-12 16:03:20 [iNFO] File AudioMod 1.2.5.zip contained no mods

2012-08-12 16:03:20 [iNFO] Directory millenaire contained no mods

2012-08-12 16:03:20 [iNFO] Directory millenaire-custom contained no mods

2012-08-12 16:03:20 [iNFO] Directory weaponmod contained no mods

2012-08-12 16:03:20 [iNFO] Forge Mod Loader has loaded 10 mods

MinecraftForge v3.3.7.135 Initialized

2012-08-12 16:03:21 [iNFO] MinecraftForge v3.3.7.135 Initialized

2012-08-12 16:03:21 [iNFO] [WeaponMod] Properties file read succesfully!

WARNING: Found unknown Windows version: Windows 7

Attempting to use default windows plug-in.

Loading: net.java.games.input.DirectAndRawInputEnvironmentPlugin

en_US

41

322

381

322

381

264

Read config in config.txt. Logging: false/true

Read config in config-custom.txt. Logging: false/true

setupTexture: "/thaumcraft/resources/blocks.png", id: 7

setupTexture: "/thaumcraft/resources/items.png", id: 8

setupTexture: "/thaumcraft/resources/particles.png", id: 9

setupTexture: "/thaumcraft/resources/s_0_0.png", id: 10

setupTexture: "/thaumcraft/resources/s_0_1.png", id: 11

setupTexture: "/thaumcraft/resources/s_0_2.png", id: 12

setupTexture: "/thaumcraft/resources/s_0_3.png", id: 13

setupTexture: "/thaumcraft/resources/s_0_4.png", id: 14

setupTexture: "/thaumcraft/resources/s_0_5.png", id: 15

setupTexture: "/thaumcraft/resources/s_1_0.png", id: 16

setupTexture: "/thaumcraft/resources/s_1_1.png", id: 17

setupTexture: "/thaumcraft/resources/s_1_2.png", id: 18

setupTexture: "/thaumcraft/resources/s_1_3.png", id: 19

setupTexture: "/thaumcraft/resources/s_1_4.png", id: 20

setupTexture: "/thaumcraft/resources/s_1_5.png", id: 21

setupTexture: "/thaumcraft/resources/seal5.png", id: 22

setupTexture: "/thaumcraft/resources/tunnel.png", id: 23

setupTexture: "/thaumcraft/resources/particlefield.png", id: 24

setupTexture: "/thaumcraft/resources/particlefield32.png", id: 25

setupTexture: "/thaumcraft/resources/p_large.png", id: 26

setupTexture: "/thaumcraft/resources/p_small.png", id: 27

setupTexture: "/thaumcraft/resources/tcubeanim.png", id: 28

setupTexture: "/thaumcraft/resources/tcrucibleanim.png", id: 29

2012-08-12 16:03:26 [iNFO] Forge Mod Loader load complete, 10 mods loaded

Skipping bad option: ofChunkLoading:2

 

Starting up SoundSystem...

Initializing LWJGL OpenAL

    (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.or

g)

OpenAL initialized.

 

setupTexture: "/terrain.png", id: 30

TextureFX registered: bv@ee13d0, texId: 30, index: 237

TextureFX registered: qa@312cd9dc, texId: 30, index: 205

TextureFX registered: zp@779313bc, texId: 30, index: 14

setupTexture: "/gui/items.png", id: 31

TextureFX registered: tu@527bfdaf, texId: 31, index: 54

TextureFX registered: ht@3d93bdb5, texId: 31, index: 70

TextureFX registered: ael@4822220b, texId: 30, index: 206

TextureFX registered: gf@38e9252c, texId: 30, index: 238

TextureFX registered: nh@528788e4, texId: 30, index: 31

TextureFX registered: nh@402c5b10, texId: 30, index: 47

TextureFX removed: bv@ee13d0, texId: 30, index: 237

TextureFX registered: TextureHDLavaFX@36dccbc7, texId: 30, index: 237

TextureFX removed: qa@312cd9dc, texId: 30, index: 205

TextureFX registered: TextureHDWaterFX@59c691f4, texId: 30, index: 205

TextureFX removed: zp@779313bc, texId: 30, index: 14

TextureFX registered: TextureHDPortalFX@7b985837, texId: 30, index: 14

TextureFX removed: ael@4822220b, texId: 30, index: 206

TextureFX registered: TextureHDWaterFlowFX@4ec7c245, texId: 30, index: 206

TextureFX removed: gf@38e9252c, texId: 30, index: 238

TextureFX registered: TextureHDLavaFlowFX@1ca3686b, texId: 30, index: 238

TextureFX removed: nh@528788e4, texId: 30, index: 31

TextureFX registered: TextureHDFlamesFX@2c1c577d, texId: 30, index: 31

TextureFX removed: nh@402c5b10, texId: 30, index: 47

TextureFX registered: TextureHDFlamesFX@7a7db2a8, texId: 30, index: 47

TextureFX removed: tu@527bfdaf, texId: 31, index: 54

TextureFX registered: TextureHDCompassFX@21f52bf4, texId: 31, index: 54

TextureFX removed: ht@3d93bdb5, texId: 31, index: 70

TextureFX registered: TextureHDWatchFX@13bab1a1, texId: 31, index: 70

Loading custom colors: /misc/grasscolor.png

Loading custom colors: /misc/foliagecolor.png

setupTexture: "/ctm.png", id: 32

MatchingCtmPng: true

Registering default ConnectedTextures

natural.properties not found

Using default configuration for Natural Textures.

setupTexture: "/title/bg/panorama0.png", id: 35

setupTexture: "/title/bg/panorama1.png", id: 36

setupTexture: "/title/bg/panorama2.png", id: 37

setupTexture: "/title/bg/panorama3.png", id: 38

setupTexture: "/title/bg/panorama4.png", id: 39

setupTexture: "/title/bg/panorama5.png", id: 40

setupTexture: "/title/mclogo.png", id: 41

setupTexture: "/gui/gui.png", id: 42

setupTexture: "/gui/particles.png", id: 43

setupTexture: "/gui/background.png", id: 44

TextureFX registered: thaumcraft.FXAnimatedTexture@6d3c62b9, texId: 7, index: 25

4

TextureFX registered: thaumcraft.FXAnimatedTexture@177597b6, texId: 7, index: 25

2

TextureFX registered: thaumcraft.FXAnimatedTexture@72767cfb, texId: 7, index: 25

3

TextureFX registered: org.millenaire.client.TextureAlechemistAmulet@52bce8b8, te

xId: 31, index: 162

TextureFX registered: org.millenaire.client.TextureVishnuAmulet@7052b277, texId:

31, index: 161

TextureFX registered: thaumcraft.arcana.TextureVoidCompassFX@4542dc3d, texId: 8,

index: 61

TextureFX registered: org.millenaire.client.TextureYddrasilAmulet@28894c51, texI

d: 31, index: 163

TextureFX registered: ModTextureStatic /gui/items.png @ 102, texId: 31, index: 1

02

TextureFX registered: ModTextureStatic /gui/items.png @ 118, texId: 31, index: 1

18

TextureFX registered: ModTextureStatic /gui/items.png @ 119, texId: 31, index: 1

19

TextureFX registered: ModTextureStatic /gui/items.png @ 120, texId: 31, index: 1

20

TextureFX registered: ModTextureStatic /gui/items.png @ 134, texId: 31, index: 1

34

TextureFX registered: ModTextureStatic /gui/items.png @ 144, texId: 31, index: 1

44

TextureFX registered: ModTextureStatic /gui/items.png @ 145, texId: 31, index: 1

45

TextureFX registered: ModTextureStatic /gui/items.png @ 146, texId: 31, index: 1

46

TextureFX registered: ModTextureStatic /gui/items.png @ 147, texId: 31, index: 1

47

TextureFX registered: ModTextureStatic /gui/items.png @ 148, texId: 31, index: 1

48

TextureFX registered: ModTextureStatic /gui/items.png @ 149, texId: 31, index: 1

49

TextureFX registered: ModTextureStatic /gui/items.png @ 150, texId: 31, index: 1

50

TextureFX registered: ModTextureStatic /gui/items.png @ 152, texId: 31, index: 1

52

TextureFX registered: ModTextureStatic /gui/items.png @ 160, texId: 31, index: 1

60

setupTexture: "/graphics/ML_sprites.png", id: 46

C:\Users\Emil Thorndal\AppData\Roaming\.minecraft

2012-08-12 16:03:34 [iNFO] [Thaumcraft] Loading custom sounds.

2012-08-12 16:03:34 [iNFO] [Thaumcraft] Loaded 0 research projects.

2012-08-12 16:03:34 [iNFO] [Thaumcraft] Loaded 1 special tiles.

2012-08-12 16:03:34 [iNFO] [Thaumcraft] Loaded 260 auras.

2012-08-12 16:03:34 [iNFO] [Thaumcraft] Saving data.

setupTexture: "/terrain/sun.png", id: 47

setupTexture: "/terrain/moon_phases.png", id: 48

Class not present: LightCache

setupTexture: "/gui/icons.png", id: 50

setupTexture: "/thaumcraft/resources/crystal.png", id: 51

setupTexture: "/thaumcraft/resources/crystalb.png", id: 52

setupTexture: "/thaumcraft/resources/crystaly.png", id: 53

Method not found: forge.ForgeHooks.onEntityLivingUpdate

Method not found: forge.ForgeHooks.onEntityLivingAttacked

Method not found: forge.ForgeHooks.onEntityLivingHurt

java.lang.ClassCastException: java.lang.Boolean cannot be cast to java.lang.Inte

ger

        at Reflector.callInt(Reflector.java:199)

        at acq.c(EntityLiving.java:972)

        at acq.a(EntityLiving.java:835)

        at bc.a(SourceFile:124)

        at acq.B(EntityLiving.java:489)

        at nn.J_(Entity.java:349)

        at acq.J_(EntityLiving.java:674)

        at xD.a(World.java:2194)

        at xD.f(World.java:2165)

        at xD.n(World.java:2047)

        at net.minecraft.client.Minecraft.k(Minecraft.java:1867)

        at net.minecraft.client.Minecraft.x(Minecraft.java:822)

        at net.minecraft.client.Minecraft.run(Minecraft.java:750)

        at java.lang.Thread.run(Unknown Source)

2012-08-12 16:03:47 [sEVERE] A critical error has occurred.

java.lang.ClassCastException: java.lang.Boolean cannot be cast to java.lang.Inte

ger

        at Reflector.callInt(Reflector.java:199)

        at acq.c(EntityLiving.java:972)

        at acq.a(EntityLiving.java:835)

        at bc.a(SourceFile:124)

        at acq.B(EntityLiving.java:489)

        at nn.J_(Entity.java:349)

        at acq.J_(EntityLiving.java:674)

        at xD.a(World.java:2194)

        at xD.f(World.java:2165)

        at xD.n(World.java:2047)

        at net.minecraft.client.Minecraft.k(Minecraft.java:1867)

        at net.minecraft.client.Minecraft.x(Minecraft.java:822)

        at net.minecraft.client.Minecraft.run(Minecraft.java:750)

        at java.lang.Thread.run(Unknown Source)

2012-08-12 16:03:47 [sEVERE] 10 mods loaded

Optifine OptiFine_1.2.5_HD_U_C7

Minecraft Forge 3.3.7.135

FML v2.2.48.135

Forge Mod Loader version 2.2.48.135 for Minecraft 1.2.5

        mod_MinecraftForge : Available (minecraft.jar)

        mod_Arrows : Available (minecraft.jar)

        mod_Shelf : Available (minecraft.jar)

        mod_Armor : Available (minecraft.jar)

        mod_adventureItems : Available (adventureItems.zip)

        mod_betterDungeons : Available (BetterDungeons.zip)

        mod_InvTweaks : Available (InvTweaks-1.41b-1.2.4.zip)

        MillÚnaire : Available (millenaire3.0.0r3.zip)

        Balkon's WeaponMod : Available (WeaponMod.zip)

        mod_ThaumCraft : Available (ThaumCraft2.1.6d.zip)

 

Stopping!

 

SoundSystem shutting down...

    Author: Paul Lamb, www.paulscode.com

 

 

 

[glow=green,2,300]Mods =[/glow][glow=blue,2,300]Adventure Items. Armor Stand (In Jar). Audio Mod. BetterDungeons. Millenaire. Shelf (In Jar). Thaumcraft 2. Balkons Weapon Mod. Optifine Ultra 1.2.5 (In jar) Forge 3.3.7 (In Jar)  [/glow]

Too bad I don't know anything about Java so I'm pretty useless in this situation.

ForgeModLoader-0.log

Link to comment
Share on other sites

Raven118,

 

  I can't find where, but you should update your Forge version to the latest Recommended Build. I have a feeling that is the issue since the entity living FAQ on the Millénaire forum states to check to make sure you installed it properly. Also your shelf mod, and armor stand mod should be installed into the .jar per the install instructions of the mods in question. That should hopefully solve all your problems.

Link to comment
Share on other sites

Don't triple post.

 

Firstly, Optifine Ultra is mainly for Minecraft 1.3.1. Forge is not out for 1.3.1, and the only 1.2.5 version of Optifine Ultra available is a "Preview" which probably means that it's not so stable. Try getting one of the versions that are stable. (Standard, smooth, etc...)

 

Next, I'm pretty sure you don't need to install Audiomod. Also, I don't know why wishinguponyou said they need to be installed to the .jar, but Shelf and Armor Stand mod work just fine for me when placed in the mods folder. (next to 60 other mods, in case you're worrying about incompatibilities... )

 

Lastly, everything goes into the mods folder. Except, as Overmind said, Forge and Optifine, which go into your minecraft.jar. Remember to install Optifine AFTER Forge. Make sure all the mods you're downloading are for 1.2.5 and not 1.3.1. Also, if your game isn't working already, don't add more mods to the mix while you're asking for help. >.<

 

So, do the following...

[*]Force Update to clean your Minecraft.jar, replacing the 1.3.1 jar with a fresh 1.2.5 jar. (can get 1.2.5 jar here) [straight from minecraft site]

[*]Download and install Forge, THEN Optifine into the .jar

[*]Delete META-INF folder from within the .jar

[*]Download all those other mods you're wanting and place them into the mods folder, not in the .jar. Make sure you're getting the 1.2.5 versions.

[*]If you installed anything besides Forge and Optifine into the .jar, start from step one again. (unless you get NEI or something too)

 

P.S. - I said ".jar" 8 times in my post... Wow. Hi Atrain. :P

Check out my

Texture Packs Thread here on the Forge Forum. :)

Currently in the process of adding some mod support for JohnSmith Texture Pack.

width=105 height=12https://www.sugarsync.com/piv/D8135159_67366891_21351[/img]

 

width=209 height=19https://www.sugarsync.com/piv/D8135159_67366891_772852[/img]

Link to comment
Share on other sites

Did what you said and changed Optifine Ultra to Multi Core and installed forge first then optifine.

Now i get this annoying black screen and an error report saying theres missing a class file.

 

 

C:\Users\Raven\Desktop>java -Xms1G -Xmx1G -cp Minecraft.exe net.minecraf

t.LauncherFrame

Exception in thread "Thread-5" java.lang.NoClassDefFoundError: org/lwjgl/LWJGLEx

ception

        at net.minecraft.client.MinecraftApplet.init(MinecraftApplet.java:31)

        at net.minecraft.Launcher.replace(Launcher.java:134)

        at net.minecraft.Launcher$1.run(Launcher.java:78)

Caused by: java.lang.ClassNotFoundException: org.lwjgl.LWJGLException

        at java.net.URLClassLoader$1.run(Unknown Source)

        at java.net.URLClassLoader$1.run(Unknown Source)

        at java.security.AccessController.doPrivileged(Native Method)

        at java.net.URLClassLoader.findClass(Unknown Source)

        at java.lang.ClassLoader.loadClass(Unknown Source)

        at java.lang.ClassLoader.loadClass(Unknown Source)

        ... 3 more

 

 

 

Edit: So I failed pretty much I only placed the 1.2.5 jar into the bin instead of force updating and then place it there.

I'm glad you guys forced me to do research myself by not posting anything....

Anyways I'll go check if it crashes ingame now with the latest version.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • I uninstalled Java 17, and installed java 8. I launch the server and now have a different error: [19Jan2022 16:51:20.604] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.2.23, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge, nogui] [19Jan2022 16:51:20.608] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 1.8.0_321 by Oracle Corporation [19Jan2022 16:51:21.615] [main/INFO] [net.minecraftforge.fml.loading.FixSSL/CORE]: Added Lets Encrypt root certificates as additional trust [19Jan2022 16:51:21.654] [main/INFO] [mixin/]: SpongePowered MIXIN Subsystem Version=0.8.4 Source=file:/D:/MCS/Vault%20Hunters/libraries/org/spongepowered/mixin/0.8.4/mixin-0.8.4.jar Service=ModLauncher Env=SERVER [19Jan2022 16:51:23.376] [main/INFO] [STDERR/]: [org.antlr.v4.runtime.ConsoleErrorListener:syntaxError:38]: line 1:0 token recognition error at: '~' [19Jan2022 16:51:24.498] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: java.lang.NoSuchMethodError: sun.security.util.ManifestEntryVerifier.<init>(Ljava/util/jar/Manifest;)V [19Jan2022 16:51:24.499] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at cpw.mods.modlauncher.SecureJarHandler.createCodeSource(SecureJarHandler.java:66) [19Jan2022 16:51:24.499] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at cpw.mods.modlauncher.TransformingClassLoader$DelegatedClassLoader.findClass(TransformingClassLoader.java:275) [19Jan2022 16:51:24.499] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at cpw.mods.modlauncher.TransformingClassLoader.loadClass(TransformingClassLoader.java:136) [19Jan2022 16:51:24.499] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at cpw.mods.modlauncher.TransformingClassLoader.loadClass(TransformingClassLoader.java:98) [19Jan2022 16:51:24.499] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at java.lang.ClassLoader.loadClass(Unknown Source) [19Jan2022 16:51:24.500] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at java.lang.Class.forName0(Native Method) [19Jan2022 16:51:24.500] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at java.lang.Class.forName(Unknown Source) [19Jan2022 16:51:24.500] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at org.spongepowered.asm.service.modlauncher.ModLauncherClassProvider.findClass(ModLauncherClassProvider.java:67) [19Jan2022 16:51:24.500] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at org.spongepowered.asm.launch.platform.MixinConnectorManager.loadConnectors(MixinConnectorManager.java:70) [19Jan2022 16:51:24.501] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at org.spongepowered.asm.launch.platform.MixinConnectorManager.inject(MixinConnectorManager.java:59) [19Jan2022 16:51:24.502] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at org.spongepowered.asm.launch.platform.MixinPlatformManager.inject(MixinPlatformManager.java:196) [19Jan2022 16:51:24.502] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at org.spongepowered.asm.launch.MixinBootstrap.inject(MixinBootstrap.java:202) [19Jan2022 16:51:24.503] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at org.spongepowered.asm.launch.MixinLaunchPluginLegacy.initializeLaunch(MixinLaunchPluginLegacy.java:201) [19Jan2022 16:51:24.503] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at org.spongepowered.asm.launch.MixinLaunchPluginLegacy.initializeLaunch(MixinLaunchPluginLegacy.java:195) [19Jan2022 16:51:24.504] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at cpw.mods.modlauncher.LaunchPluginHandler.lambda$announceLaunch$9(LaunchPluginHandler.java:97) [19Jan2022 16:51:24.504] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at java.util.HashMap.forEach(Unknown Source) [19Jan2022 16:51:24.505] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at cpw.mods.modlauncher.LaunchPluginHandler.announceLaunch(LaunchPluginHandler.java:97) [19Jan2022 16:51:24.505] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:52) [19Jan2022 16:51:24.505] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:72) [19Jan2022 16:51:24.506] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at cpw.mods.modlauncher.Launcher.run(Launcher.java:82) [19Jan2022 16:51:24.506] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at cpw.mods.modlauncher.Launcher.main(Launcher.java:66) [19Jan2022 16:51:24.507] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:63) [19Jan2022 16:51:24.509] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:60) [19Jan2022 16:51:24.510] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: at net.minecraftforge.server.ServerMain.main(ServerMain.java:57)
    • I do not know how to check the sites certificate on my phone
    • Oh ok, thank you. Should I uninstall java 17 and get java 8, or have both?
    • I have installed a forge server, and tried launching it. It launches as a vanilla server if I run the file called "minecraft_server.1.16.5.jar" If i run the file called "forge-1.16.5-36.2.23.jar", nothing at all happens, it just creates a log with these 2 lines: [19Jan2022 16:08:29.340] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.2.23, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge] [19Jan2022 16:08:29.345] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 17.0.1 by Oracle Corporation I have also tried running both files (since I don't know which one I'm supposed to use) using the command line like this: java -Xmx6000M -Xms6000M -jar {serverName}.jar nogui pause If I run the the server file, i get a vanilla server as well. If i run the forge file, the log file looks the same as before, and I get this result in the terminal: D:\MCS\VH>java -Xmx6000M -Xms6000M -jar forge-1.16.5-36.2.23.jar nogui 2022-01-19 16:16:32,476 main WARN Advanced terminal features are not available in this environment [16:16:32] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.2.23, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge, nogui] [16:16:32] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 17.0.1 by Oracle Corporation Exception in thread "main" java.lang.IllegalAccessError: class cpw.mods.modlauncher.SecureJarHandler (in unnamed module @0xadd0edd) cannot access class sun.security.util.ManifestEntryVerifier (in module java.base) because module java.base does not export sun.security.util to unnamed module @0xadd0edd at cpw.mods.modlauncher.SecureJarHandler.lambda$static$1(SecureJarHandler.java:41) at cpw.mods.modlauncher.api.LamdbaExceptionUtils.uncheck(LamdbaExceptionUtils.java:95) at cpw.mods.modlauncher.SecureJarHandler.<clinit>(SecureJarHandler.java:41) at cpw.mods.modlauncher.Launcher.lambda$new$6(Launcher.java:55) at java.base/java.util.concurrent.ConcurrentHashMap.computeIfAbsent(ConcurrentHashMap.java:1708) at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:52) at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:47) at cpw.mods.modlauncher.Environment.computePropertyIfAbsent(Environment.java:62) at cpw.mods.modlauncher.Launcher.<init>(Launcher.java:55) at cpw.mods.modlauncher.Launcher.main(Launcher.java:66) at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:63) at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:60) at net.minecraftforge.server.ServerMain.main(ServerMain.java:57) D:\MCS\VH>pause Press any key to continue . . . I have also tried launching old servers that I had on SkyFactory 3 that worked fine before, but they have stopped working too. When I launch them I get this result: Starting Sky Factory 3 Server... A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:77) at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.base/java.lang.reflect.Method.invoke(Method.java:568) at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:62) at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:31) Caused by: java.lang.ClassCastException: class jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to class java.net.URLClassLoader (jdk.internal.loader.ClassLoaders$AppClassLoader and java.net.URLClassLoader are in module java.base of loader 'bootstrap') at net.minecraft.launchwrapper.Launch.<init>(Launch.java:34) at net.minecraft.launchwrapper.Launch.main(Launch.java:28) ... 6 more Press any key to continue . . . I assume this means that something has changed on my pc, causing forge servers not to run correctly, but I cannot imagine what that could be. I hope this is enough information to be able to help
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.