Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[Solved] Forge install fails.


Recommended Posts

After trying to install multiple versions of the Forge source from http://files.minecraftforge.net/, I always get a fatal error. I've tried about 5 different versions of the Forge src but nothing seems to work.

 

Log from "\forge\mcp\logs\mcp.log": http://pastebin.com/wRWAkKEn

 

I also tried to open the files in eclipse from "C:\forge\mcp\eclipse" but it fails to launch the game with the error:

Aug 29, 2013 4:21:35 PM net.minecraft.launchwrapper.LogWrapper log
INFO: Using tweak class name cpw.mods.fml.common.launcher.FMLTweaker
Aug 29, 2013 4:21:35 PM net.minecraft.launchwrapper.LogWrapper log
SEVERE: Unable to launch
java.lang.ClassNotFoundException: cpw.mods.fml.common.launcher.FMLTweaker
at java.net.URLClassLoader$1.run(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:99)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:49)
at net.minecraft.launchwrapper.Launch.main(Launch.java:18)

I have also got the latest JDK installed. I hope I've made myself clear, if not please tell me and I'll try and explain further. Any help would be greatly appreciated!

Link to post
Share on other sites

Interesting interesting. It seems that it cant find java correctly.

find fml/fml.py

Line 662

add:

from pprint import pprint

pprint(results)

 

That should print out the result array and tell us what failed. Please run with that modification.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to post
Share on other sites

Okay, I assume you meant run the install.cmd after making the changes, and these are the results of the command prompt:

C:\Users\Thomas\Downloads\forge\fml>echo off
Traceback (most recent call last):
  File "install.py", line 56, in <module>
    decompile=options.decompile, gen_conf=False)
  File "install.py", line 8, in fml_main
    from fml import download_mcp, setup_mcp, decompile_minecraft, apply_fml_patc
hes, finish_setup_fml
  File "C:\Users\Thomas\Downloads\forge\fml\fml.py", line 663
    pprint(results)
    ^
IndentationError: unexpected indent
Press any key to continue . . .

Link to post
Share on other sites

Console log please, not the log file, that's mcp's and doesn't contain {I cant figure out how to make it contain} FML or Forge's log entries.. Annoying I know but logging in python is a PITA

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to post
Share on other sites

Interesting it didnt print anything out.

For some reason it's not finding your java install path.

Is java in your PATH?

Start a command window

and type java -version

If it errors then you should add java/javac to your path

if it doesnt then.. im not sure whats derped.

Something is giving you a '%1' which isn't in any of the code there.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to post
Share on other sites

After I reinstalled my Java's, I re-added the paths of them. And after typing "java -version" in a command prompt, I get:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Thomas>java -version
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b17)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

C:\Users\Thomas>

 

So it might just be something screwing up with my computer... I'll try running install.cmd on another computer and try copying the files over. I'll report back soon with what happens.

Link to post
Share on other sites

Thanks for all your help, Lex. I managed to get the forge install working on another computer and by copying over the files, I managed to fix the issue. So I'll just have to install it on another computer from now on. But once again, thanks for all your help!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.