Jump to content

Textures not recognized after upgrading from 1.19.2 to 1.19.3


Recommended Posts

So, after reading all the "debacle" happening with the support for both minor versions, I decided to upgrade my project to 1.19.3

I managed to fix everything after upgrading forge and the mappings, everything works now except not a single texture gets recognized. This is the error it gives for all items and blocks:

[00:12:28] [Worker-Main-11/WARN] [minecraft/ModelManager]: Missing textures in model chrmscmds:testitem1#inventory:      


I used both addcreative and buildcontents to make and use a custom creative tab (which is working)

Everything else is as its supposed to work on 1.19.2 with the jsons under resources/assets/mod_id, the models themselves being recognized and blockstates working as they're supposed to.

I also have stumbled upon ResourceLocation but I'm not sure if that's the way to go.

Has anything changed on .3 in regard to resource locating or I'm just dumb?



Edited by chxr
minor typos
Link to comment
Share on other sites

  • 1 month later...
On 12/25/2022 at 3:05 PM, ChampionAsh5357 said:

Your item and block textures need to be in textures/item and textures/block respectively. Mojang changed how textures are loaded to improve performance, meaning it will only recognize the above two locations unless otherwise specified by the resource pack.

That's where they are now, inside resources/assets/mod_id/ (unless I did not understand soomething in which case sorry)

I tried changing the name from plural to singular (textures->texture, blocks->block) but still does not recognize the textures

EDIT: Okay that was the error. I have come back to my mod after a month and I forgot I had to change the texture json file from plural to singular too, so you're right

Edited by chxr
Link to comment
Share on other sites

  • 1 month later...

Thing is, in my cit/item folder i used to have seperate folders for every item i changed, not only to easily find them again when needed but also because some of the items i changed by name are the same base item like netherite tools for example.

This change basically made it impossible to have multiple textures named for 1 item due to not being able to have the same named .properties files in the same location.
Unless there will be a modded support for it like optifine or CIT resewn or any of the other CIT mods could allow for files to be read beyond just the cit/item and then your image and properties files.

What i have (and maybe loads of other people do to is assets/optifine/cit/item/(name of item changed) and then the properties and image files.

I don't know about all of this for sure i made this conclusion after some testing i did but to me this appears to be the problem, i'd really like to be proven wrong on this to be honest.
Otherwise we'd have to wait for CIT mods to update to read more files than minecraft its-self allows.

Link to comment
Share on other sites

Not sure if this help, because I am not familiar with what you are talking about.


The release notes for 1.19.3 explains the configuration file for where minecraft looks to populate each atlas.

Search for atlas here: https://www.minecraft.net/en-us/article/minecraft-java-edition-1-19-3


This is the most recent default/vanilla configuration of the block atlas texture locations: https://github.com/misode/mcmeta/blob/assets/assets/minecraft/atlases/blocks.json

Edited by warjort


If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

That helped loads actually, after i looked through the way Minecraft now looks at its item directory it is more restrictive then before 1.19.3 but still very stable.
I think the main issue is that the average CIT user tried to find out what happened to their textures and why some may have worked and some didn't.

The problem for most people seems to be that the files they use to seperate what items they use seem to have spaces in the name and minecraft will no longer read that.
And the main thing i figured from the directory is that even within your CIT file you will now need to copy minecraft's normal directory.

Where before you could just have random names and spaces in your file names in CIT you can no longer do this,
the simple solution is just to change your files to assets/optifine/cit/items/specificitem

So now in CIT you'd need to make an items folder so minecraft can still read it and have no spaces within the next folder that contains your texture and properties file.
Mojang did indeed just try and optimize the directory process by limiting what it can search for and find.

So as a final example to anyone who has this problem after changing to 1.19.3 and hasn't found out what happened yet.

Change your file directory to,

assets/optifine/cit/items/(specificitem)/    And within the specific item folder you created for your texture you put your properties and png files. Keep in mind it won't recognize space bars anymore.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • every time I try to load forge version 1. 12. 2 with the blockbuster mod the mclib and the metamorphs mod The game crashed and this is the crash m whilst there was a severe problem during mod loading that has caused the game to fail Error: net.minecraftforge.fml.common.LoaderExceptionModCrash: Caught exception from Blockbuster (blockbuster)
    • Join the Ultimate EarthSMP - [RiftMC SMP] play.riftmc.net https://riftmc.net/ Join Our Discord     Are you ready to embark on a Minecraft adventure like no other? Look no further than RiftMC! With our server, you'll be transported to a world of endless possibilities, where your imagination can run wild.   Have you ever dreamed of building your own kingdom, or exploring vast landscapes with your friends? At RiftMC, you can do just that and more. With multiple gameplay options, including survival, earthsmp, and PvP gameplay, you'll never run out of things to do.   Are you looking for a challenge? Our survival mode will test your skills as you brave the dangers of the wilderness. Or, if you're feeling creative, our custom world is the perfect canvas for you to unleash your imagination and build whatever your heart desires.   Do you thrive on competition? Our PvP arenas are the perfect place for you to battle it out with other players for supremacy. Or, if you prefer a more cooperative experience, join up with other players to form communities and build sprawling cities.   But that's not all - we also have a thriving economic system, where you can buy and sell goods with other players and even start your own businesses. And with our friendly and dedicated staff, you can rest assured that you'll always have the help and support you need.   So, what are you waiting for? Are you ready to experience the adventure of a lifetime? Join the thousands of players who have already discovered the magic of RiftMC! Simply connect to play.riftmc.net and let the journey begin. Are you ready to dive in?  
    • I want a sword that will kill all hostile mobs with one hit, so is there any way to do that?
    • I have that error when i started my forge server, can anyone help me? C:\Users\orden\Desktop\Servidor MC>REM Forge requires a configured set of both JVM and program arguments. C:\Users\orden\Desktop\Servidor MC>REM Add custom JVM arguments to the user_jvm_args.txt C:\Users\orden\Desktop\Servidor MC>REM Add custom program arguments {such as nogui} to this file in the next line before the  or C:\Users\orden\Desktop\Servidor MC>REM  pass them to this script directly C:\Users\orden\Desktop\Servidor MC>java @user_jvm_args.txt @libraries/net/minecraftforge/forge/1.18.2-40.1.57/win_args.txt 2023-04-01 21:15:43,376 main WARN Advanced terminal features are not available in this environment [21:15:43] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--launchTarget, forgeserver, --fml.forgeVersion, 40.1.57, --fml.mcVersion, 1.18.2, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20220404.173914, -nogui] [21:15:43] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 9.1.3+9.1.3+main.9b69c82a starting: java version 20 by Oracle Corporation [21:15:43] [main/INFO] [op.OptiFineTransformationService/]: OptiFineTransformationService.onLoad [21:15:43] [main/INFO] [op.OptiFineTransformationService/]: OptiFine ZIP file URL: union:/C:/Users/orden/Desktop/Servidor%20MC/mods/OptiFine-1.18.2_HD_U_H7.jar%2338!/ [21:15:43] [main/INFO] [op.OptiFineTransformationService/]: OptiFine ZIP file: C:\Users\orden\Desktop\Servidor MC\mods\OptiFine-1.18.2_HD_U_H7.jar [21:15:43] [main/INFO] [op.OptiFineTransformer/]: Target.PRE_CLASS is available [21:15:43] [main/INFO] [mixin/]: SpongePowered MIXIN Subsystem Version=0.8.5 Source=union:/C:/Users/orden/Desktop/Servidor%20MC/libraries/org/spongepowered/mixin/0.8.5/mixin-0.8.5.jar%2314!/ Service=ModLauncher Env=SERVER [21:15:43] [main/INFO] [op.OptiFineTransformationService/]: OptiFineTransformationService.initialize [21:15:45] [main/INFO] [op.OptiFineTransformationService/]: OptiFineTransformationService.transformers [21:15:45] [main/INFO] [op.OptiFineTransformer/]: Targets: 350 [21:15:45] [main/INFO] [op.OptiFineTransformationService/]: additionalClassesLocator: [optifine., net.optifine.] [21:15:47] [main/INFO] [mixin/]: Compatibility level set to JAVA_17 [21:15:47] [main/INFO] [mixin/]: Successfully loaded Mixin Connector [de.maxhenkel.camera.MixinConnector] [21:15:47] [main/INFO] [mixin/]: Successfully loaded Mixin Connector [tictim.paraglider.MixinConnector] [21:15:47] [main/INFO] [cp.mo.mo.LaunchServiceHandler/MODLAUNCHER]: Launching target 'forgeserver' with arguments [-nogui] [21:15:47] [main/WARN] [mixin/]: Error loading class: net/minecraft/server/level/ChunkMap (java.lang.IllegalArgumentException: Unsupported class file major version 64) [21:15:47] [main/WARN] [mixin/]: @Mixin target net.minecraft.server.level.ChunkMap was not found securitycraft.mixins.json:camera.ChunkMapMixin [21:15:47] [main/WARN] [mixin/]: Error loading class: de/maxhenkel/gravestone/events/DeathEvents (java.lang.ClassNotFoundException: de.maxhenkel.gravestone.events.DeathEvents) [21:15:47] [main/WARN] [mixin/]: Error loading class: net/minecraft/world/item/ItemStack (java.lang.IllegalArgumentException: Unsupported class file major version 64) [21:15:47] [main/WARN] [mixin/]: @Mixin target net.minecraft.world.item.ItemStack was not found tombstone.mixins.json:ItemStackMixin [21:15:47] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [21:15:47] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [21:15:47] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [21:15:47] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [21:15:47] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [21:15:47] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [21:15:47] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [21:15:47] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [21:15:47] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [21:15:47] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [21:15:47] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [21:15:47] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [21:15:47] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [21:15:47] [main/WARN] [mixin/]: Error loading class: java/util/concurrent/CompletableFuture (java.lang.IllegalArgumentException: Unsupported class file major version 64) Exception in thread "main" org.spongepowered.asm.mixin.transformer.throwables.MixinTransformerError: An unexpected critical error was encountered         at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.MixinProcessor.applyMixins(MixinProcessor.java:392)         at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.MixinTransformer.transformClass(MixinTransformer.java:250)         at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.service.modlauncher.MixinTransformationHandler.processClass(MixinTransformationHandler.java:131)         at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.launch.MixinLaunchPluginLegacy.processClass(MixinLaunchPluginLegacy.java:131)         at MC-BOOTSTRAP/cpw.mods.modlauncher@9.1.3/cpw.mods.modlauncher.serviceapi.ILaunchPluginService.processClassWithFlags(ILaunchPluginService.java:156)         at MC-BOOTSTRAP/cpw.mods.modlauncher@9.1.3/cpw.mods.modlauncher.LaunchPluginHandler.offerClassNodeToPlugins(LaunchPluginHandler.java:88)         at MC-BOOTSTRAP/cpw.mods.modlauncher@9.1.3/cpw.mods.modlauncher.ClassTransformer.transform(ClassTransformer.java:120)         at MC-BOOTSTRAP/cpw.mods.modlauncher@9.1.3/cpw.mods.modlauncher.TransformingClassLoader.maybeTransformClassBytes(TransformingClassLoader.java:50)         at cpw.mods.securejarhandler@1.0.3/cpw.mods.cl.ModuleClassLoader.readerToClass(ModuleClassLoader.java:110)         at cpw.mods.securejarhandler@1.0.3/cpw.mods.cl.ModuleClassLoader.lambda$findClass$16(ModuleClassLoader.java:216)         at cpw.mods.securejarhandler@1.0.3/cpw.mods.cl.ModuleClassLoader.loadFromModule(ModuleClassLoader.java:226)         at cpw.mods.securejarhandler@1.0.3/cpw.mods.cl.ModuleClassLoader.findClass(ModuleClassLoader.java:216)         at cpw.mods.securejarhandler@1.0.3/cpw.mods.cl.ModuleClassLoader.loadClass(ModuleClassLoader.java:132)         at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)         at java.base/java.lang.Class.getDeclaredMethods0(Native Method)         at java.base/java.lang.Class.privateGetDeclaredMethods(Class.java:3502)         at java.base/java.lang.Class.getMethodsRecursive(Class.java:3643)         at java.base/java.lang.Class.getMethod0(Class.java:3629)         at java.base/java.lang.Class.getMethod(Class.java:2319)         at MC-BOOTSTRAP/fmlloader@1.18.2-40.1.57/net.minecraftforge.fml.loading.targets.CommonServerLaunchHandler.lambda$launchService$0(CommonServerLaunchHandler.java:32)         at MC-BOOTSTRAP/cpw.mods.modlauncher@9.1.3/cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:37)         at MC-BOOTSTRAP/cpw.mods.modlauncher@9.1.3/cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:53)         at MC-BOOTSTRAP/cpw.mods.modlauncher@9.1.3/cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:71)         at MC-BOOTSTRAP/cpw.mods.modlauncher@9.1.3/cpw.mods.modlauncher.Launcher.run(Launcher.java:106)         at MC-BOOTSTRAP/cpw.mods.modlauncher@9.1.3/cpw.mods.modlauncher.Launcher.main(Launcher.java:77)         at MC-BOOTSTRAP/cpw.mods.modlauncher@9.1.3/cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:26)         at MC-BOOTSTRAP/cpw.mods.modlauncher@9.1.3/cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:23)         at cpw.mods.bootstraplauncher@1.0.0/cpw.mods.bootstraplauncher.BootstrapLauncher.main(BootstrapLauncher.java:149) Caused by: org.spongepowered.asm.mixin.throwables.ClassMetadataNotFoundException: java.util.concurrent.CompletableFuture         at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.MixinPreProcessorStandard.transformMethod(MixinPreProcessorStandard.java:754)         at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.MixinPreProcessorStandard.transform(MixinPreProcessorStandard.java:739)         at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.MixinPreProcessorStandard.attach(MixinPreProcessorStandard.java:310)         at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.MixinPreProcessorStandard.createContextFor(MixinPreProcessorStandard.java:280)         at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.MixinInfo.createContextFor(MixinInfo.java:1288)         at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.MixinApplicatorStandard.apply(MixinApplicatorStandard.java:292)         at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.TargetClassContext.apply(TargetClassContext.java:383)         at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.TargetClassContext.applyMixins(TargetClassContext.java:365)         at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.MixinProcessor.applyMixins(MixinProcessor.java:363)         ... 27 more C:\Users\orden\Desktop\Servidor MC>pause Presione una tecla para continuar . . .
  • Topics

  • Who's Online (See full list)

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.