Jump to content

Modded Minecraft 1.19.2 ATM 8 (forge) Errors in currently selected datapacks prevented the world from loading.


Recommended Posts

So I launched a Curseforge profile yesterday and created a singleplayer world, and it worked fine the whole time. The next time I tried to open the world I got the warning "Errors in currently selected datapacks prevented the world from loading."  So I chose the "Safe Mode" option, and eventually after loading for a while it just presented me with the same error again, ("safe mode" not helping) . I tried this about 3 times and got the same result every time.

Here is my debug.log file: Mega | debug.log (link bc its about 1 Gb)

Any help is appreciated.

Edited by ElectricCosmos
adjust
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • The version you are using is no longer supported on this forum. Please update to a modern version of Minecraft to receive support. Currently supported versions are 1.19.3 (Latest), 1.19.2, and 1.18.2 (LTS).
    • Technically, you can reuse the crafting recipe classes as long as you change the RecipeType since that's what determines whether the recipes can be used by a given system or not.
    • I mean...it's neither. You are trying to play a 1.19.2 mod on 1.19.3. It won't work. 1.19.2 does not equal 1.19.3.
    • Hi all, lately I've started developing mods that are server-side only, so I've already started working with packets, I thought it was a pretty simple thing (having already worked on it when developing plugins) (I know it's completely different at code level, but logical I think it's the same) but I ran into multiple problems, I'm developing a mod in 1.19.2 server side which for now has to send a simple message to individual clients by executing a command, like a sort of "hello world" debugging. I developed the command part and it works, but I really have no idea how to send a chatmessagepacket to the client, could someone help me? Test.java -- Command Class (Working) public class Test { public Test (CommandDispatcher<CommandSourceStack> dispatcher){ dispatcher.register(Commands.literal("test").executes((command) -> { return 0; })); } private int prova(CommandSourceStack source) throws CommandSyntaxException{ ServerPlayer player = source.getPlayer(); BlockPos pos = player.blockPosition(); //here must send a packet to the client return 1; } } PacketHandler.java public class PacketHandler { private static SimpleChannel INSTANCE; private static int packetId = 0; public static void register(){ SimpleChannel net = NetworkRegistry.ChannelBuilder .named(new ResourceLocation(Mceconomy.MODID, "main")) .networkProtocolVersion(() -> "1.0") .clientAcceptedVersions(s -> true) .serverAcceptedVersions(s -> true) .simpleChannel(); INSTANCE = net; net.messageBuilder(MessagePacket.class, id(), NetworkDirection.PLAY_TO_SERVER) .encoder(MessagePacket::toBytes) .decoder(MessagePacket::new) .consumerMainThread(MessagePacket::handle) .add(); } private static int id() { return packetId++; } public static <MSG> void sendToServer(MSG message) { INSTANCE.sendToServer(message); } public static <MSG> void sendToClient(MSG message, ServerPlayer player) { INSTANCE.send(PacketDistributor.PLAYER.with(() -> player), message); } } MessagePacket.java -- (StringTextComponent can't find it and I don't know why) public class MessagePacket { public MessagePacket() { } public MessagePacket(FriendlyByteBuf buf) { } public void toBytes(FriendlyByteBuf buf) { } public boolean handle(Supplier<NetworkEvent.Context> supplier) { NetworkEvent.Context context = supplier.get(); context.enqueueWork(() -> { //On the server ServerPlayer player = context.getSender(); ServerLevel world = player.getLevel(); player.sendSystemMessage(new StringTextComponent("Hello World!")); }); return true; } } Any ideas?
    • Alright, so for a second I thought I had a solution when I remembered the old position Entities use for lerping is public public final Vec3 getPosition(float p_20319_) { double d0 = Mth.lerp((double)p_20319_, this.xo, this.getX()); double d1 = Mth.lerp((double)p_20319_, this.yo, this.getY()); double d2 = Mth.lerp((double)p_20319_, this.zo, this.getZ()); return new Vec3(d0, d1, d2); } and while I was able to get the position on server, I found out the old position is identical to the current position (both on client and server), which means if I subtract it from the current position, I still get 0.0, what's up with that? I how can the game lerp motion if the two positions are the same?
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.