Jump to content

1.19.2 - Looking to modify a mod's loot table


Recommended Posts

I'm running a small server for some friends, and we run Dragon Mounts Legacy as part of our small selection of mods. We wanted to up the drop rate for the dragon eggs, and thus - total noob as far as creating datapacks/etc goes - I am now trying to find a way to modify the drop rates.

The github for the loot_modifier part of the mod is here:

And my question basically is: loot_modifier is a forge specific thing, but can I possibly run a datapack to override these modifications with my own? Or what would be the most straightforward way for me to basically control the drop rates for the eggs myself?

Link to comment
Share on other sites

Yes, they are designed to be used in datapacks.

But the global loot modifiers are a bit subtle. They are additive by default, like tags. So it will run both the mod's and your loot modifier.

If you don't want this, you need a data/forge/loot_modifiers/global_loot_modifiers.json and use the "replace" option  to stop the mod's loot modifier from being run.

That's not something I have ever done, so I don't have an example.

See: https://forge.gemwire.uk/wiki/Dynamic_Loot_Modification#The_global_loot_modifiers.json for more details.


If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

TO update, no dice, sadly. I switched replace to true, but it's not showing up. I found something odd though. I installed JER to verify the loot tables for the dragon eggs, but it's not working on those items. I made sure that the server-config to allow loot tables was enabled for the single player world I'm testing in as well. It almost seems like the mod itself is not spawning eggs at all for some reason, but I figure a loot modifier should still make that happen regardless?

Link to comment
Share on other sites

Okay, I have ZERO understanding how loot tables work via Forge. But, before I started modding, I had no trouble altering existing loot tables or adding new ones via datapacks alone - whether these loot tables were mine, from a mod, or vanilla. This link is a good starting point for that if you'd like to do it via a datapack alone: here. You can also go here to help you build a loot table as well. I'm sure there are probably other tutorials out there for this if you need to find them. I wish I had an answer for Forge specifically though. Maybe someone else does?

Edited by Warren Tode
Corrected spelling error
Link to comment
Share on other sites

Thank you for the links, I used the first one to learn about loot tables before beginning, it was quite helpful actually, the second one should definitely come in handy if I do make my own from scratch, too!

To provide some more info, I'll put the global_loot_modifiers.json here, as well as list the file structure, just to make sure everything is correct.

  "replace": true,
  "entries": [


file structure:

[datapack name] / data / forge / loot_modifiers / global_loot_modifiers.json

[datapack name] / data / dragonmounts / loot_modifiers / ghost / chests / abandoned_mineshaft.json

there are more folders in loot_modifiers for the other dungeon chests, all intended - as a test right now - to convey a 100% spawn chance for a dragon egg (usually it is around 7.5 to 30%). However testing with this I found no eggs anywhere, and like I said, JER does not show any drop information for dragon eggs, but does show drop information for other items, chests and mob drops both.

For completness sake, an excerpt of one of the loot table modifiers, this one for the mineshaft:

  "conditions": [
      "condition": "forge:loot_table_id",
      "loot_table_id": "minecraft:chests/abandoned_mineshaft"
      "condition": "minecraft:random_chance",
      "chance": 1.0
  "breed": "dragonmounts:ghost",
  "type": "dragonmounts:dragon_egg_loot"

I appreciate all the feedback here so far, by the way, thanks for everyone who replied!

Link to comment
Share on other sites

I do know that the server-config.cfg in your world folder will have a loot table option, it /should/ default to false, but that would be the setting you want. Looks like we're having opposite issues, hah.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I tried removing super class but it made no difference to the rendering. I found it thank you, I didn't know what to put for the bone PartPose setting but I do now.  
    • ---- Minecraft Crash Report ---- // Hi. I'm Minecraft, and I'm a crashaholic. Time: 09/06/2023 18:57 Description: Rendering overlay net.minecraftforge.fml.config.ConfigFileTypeHandler$ConfigLoadingException: Failed loading config file forge-client.toml of type CLIENT for modid forge     at net.minecraftforge.fml.config.ConfigFileTypeHandler.lambda$reader$1(ConfigFileTypeHandler.java:47) ~[fmlcore-1.18.2-40.2.4.jar%23100!/:?] {}     at net.minecraftforge.fml.config.ConfigTracker.openConfig(ConfigTracker.java:60) ~[fmlcore-1.18.2-40.2.4.jar%23100!/:?] {}     at net.minecraftforge.fml.config.ConfigTracker.lambda$loadConfigs$1(ConfigTracker.java:50) ~[fmlcore-1.18.2-40.2.4.jar%23100!/:?] {}     at java.lang.Iterable.forEach(Iterable.java:75) ~[?:?] {re:mixin}     at java.util.Collections$SynchronizedCollection.forEach(Collections.java:2131) ~[?:?] {}     at net.minecraftforge.fml.config.ConfigTracker.loadConfigs(ConfigTracker.java:50) ~[fmlcore-1.18.2-40.2.4.jar%23100!/:?] {}     at net.minecraftforge.fml.core.ModStateProvider.lambda$new$1(ModStateProvider.java:33) ~[forge-1.18.2-40.2.4-universal.jar%23104!/:?] {re:classloading}     at net.minecraftforge.fml.DistExecutor.unsafeRunWhenOn(DistExecutor.java:111) ~[fmlcore-1.18.2-40.2.4.jar%23100!/:?] {}     at net.minecraftforge.fml.core.ModStateProvider.lambda$new$3(ModStateProvider.java:33) ~[forge-1.18.2-40.2.4-universal.jar%23104!/:?] {re:classloading}     at net.minecraftforge.fml.ModLoader.lambda$dispatchAndHandleError$20(ModLoader.java:186) ~[fmlcore-1.18.2-40.2.4.jar%23100!/:?] {}     at java.util.Optional.ifPresent(Optional.java:178) ~[?:?] {re:mixin}     at net.minecraftforge.fml.ModLoader.dispatchAndHandleError(ModLoader.java:186) ~[fmlcore-1.18.2-40.2.4.jar%23100!/:?] {}     at net.minecraftforge.fml.ModLoader.lambda$loadMods$14(ModLoader.java:170) ~[fmlcore-1.18.2-40.2.4.jar%23100!/:?] {}     at java.lang.Iterable.forEach(Iterable.java:75) ~[?:?] {re:mixin}     at net.minecraftforge.fml.ModLoader.loadMods(ModLoader.java:170) ~[fmlcore-1.18.2-40.2.4.jar%23100!/:?] {}     at net.minecraftforge.client.loading.ClientModLoader.lambda$startModLoading$5(ClientModLoader.java:121) ~[forge-1.18.2-40.2.4-universal.jar%23104!/:?] {re:classloading,pl:runtimedistcleaner:A}     at net.minecraftforge.client.loading.ClientModLoader.lambda$createRunnableWithCatch$4(ClientModLoader.java:112) ~[forge-1.18.2-40.2.4-universal.jar%23104!/:?] {re:classloading,pl:runtimedistcleaner:A}     at net.minecraftforge.client.loading.ClientModLoader.startModLoading(ClientModLoader.java:121) ~[forge-1.18.2-40.2.4-universal.jar%23104!/:?] {re:classloading,pl:runtimedistcleaner:A}     at net.minecraftforge.client.loading.ClientModLoader.lambda$onResourceReload$2(ClientModLoader.java:103) ~[forge-1.18.2-40.2.4-universal.jar%23104!/:?] {re:classloading,pl:runtimedistcleaner:A}     at net.minecraftforge.client.loading.ClientModLoader.lambda$createRunnableWithCatch$4(ClientModLoader.java:112) ~[forge-1.18.2-40.2.4-universal.jar%23104!/:?] {re:classloading,pl:runtimedistcleaner:A}     at java.util.concurrent.CompletableFuture$AsyncRun.run(CompletableFuture.java:1804) ~[?:?] {}     at java.util.concurrent.CompletableFuture$AsyncRun.exec(CompletableFuture.java:1796) ~[?:?] {}     at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:373) ~[?:?] {}     at java.util.concurrent.ForkJoinPool$WorkQueue.topLevelExec(ForkJoinPool.java:1182) ~[?:?] {}     at java.util.concurrent.ForkJoinPool.scan(ForkJoinPool.java:1655) ~[?:?] {}     at java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1622) ~[?:?] {}     at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:165) ~[?:?] {} Caused by: com.electronwill.nightconfig.core.io.ParsingException: Not enough data available     at com.electronwill.nightconfig.core.io.ParsingException.notEnoughData(ParsingException.java:22) ~[core-3.6.4.jar%237!/:?] {}     at com.electronwill.nightconfig.core.io.ReaderInput.directReadChar(ReaderInput.java:36) ~[core-3.6.4.jar%237!/:?] {}     at com.electronwill.nightconfig.core.io.AbstractInput.readChar(AbstractInput.java:49) ~[core-3.6.4.jar%237!/:?] {}     at com.electronwill.nightconfig.core.io.AbstractInput.readCharsUntil(AbstractInput.java:123) ~[core-3.6.4.jar%237!/:?] {}     at com.electronwill.nightconfig.toml.TableParser.parseKey(TableParser.java:166) ~[toml-3.6.4.jar%238!/:?] {}     at com.electronwill.nightconfig.toml.TableParser.parseDottedKey(TableParser.java:145) ~[toml-3.6.4.jar%238!/:?] {}     at com.electronwill.nightconfig.toml.TableParser.parseNormal(TableParser.java:55) ~[toml-3.6.4.jar%238!/:?] {}     at com.electronwill.nightconfig.toml.TomlParser.parse(TomlParser.java:44) ~[toml-3.6.4.jar%238!/:?] {}     at com.electronwill.nightconfig.toml.TomlParser.parse(TomlParser.java:37) ~[toml-3.6.4.jar%238!/:?] {}     at com.electronwill.nightconfig.core.io.ConfigParser.parse(ConfigParser.java:113) ~[core-3.6.4.jar%237!/:?] {}     at com.electronwill.nightconfig.core.io.ConfigParser.parse(ConfigParser.java:219) ~[core-3.6.4.jar%237!/:?] {}     at com.electronwill.nightconfig.core.io.ConfigParser.parse(ConfigParser.java:202) ~[core-3.6.4.jar%237!/:?] {}     at com.electronwill.nightconfig.core.file.WriteSyncFileConfig.load(WriteSyncFileConfig.java:73) ~[core-3.6.4.jar%237!/:?] {}     at com.electronwill.nightconfig.core.file.AutosaveCommentedFileConfig.load(AutosaveCommentedFileConfig.java:85) ~[core-3.6.4.jar%237!/:?] {}     at net.minecraftforge.fml.config.ConfigFileTypeHandler.lambda$reader$1(ConfigFileTypeHandler.java:43) ~[fmlcore-1.18.2-40.2.4.jar%23100!/:?] {}     ... 26 more A detailed walkthrough of the error, its code path and all known details is as follows: --------------------------------------------------------------------------------------- -- Head -- Thread: Render thread Stacktrace:     at net.minecraftforge.fml.config.ConfigFileTypeHandler.lambda$reader$1(ConfigFileTypeHandler.java:47) ~[fmlcore-1.18.2-40.2.4.jar%23100!/:?] {}     at net.minecraftforge.fml.config.ConfigTracker.openConfig(ConfigTracker.java:60) ~[fmlcore-1.18.2-40.2.4.jar%23100!/:?] {}     at net.minecraftforge.fml.config.ConfigTracker.lambda$loadConfigs$1(ConfigTracker.java:50) ~[fmlcore-1.18.2-40.2.4.jar%23100!/:?] {}     at java.lang.Iterable.forEach(Iterable.java:75) ~[?:?] {re:mixin}     at java.util.Collections$SynchronizedCollection.forEach(Collections.java:2131) ~[?:?] {}     at net.minecraftforge.fml.config.ConfigTracker.loadConfigs(ConfigTracker.java:50) ~[fmlcore-1.18.2-40.2.4.jar%23100!/:?] {}     at net.minecraftforge.fml.core.ModStateProvider.lambda$new$1(ModStateProvider.java:33) ~[forge-1.18.2-40.2.4-universal.jar%23104!/:?] {re:classloading}     at net.minecraftforge.fml.DistExecutor.unsafeRunWhenOn(DistExecutor.java:111) ~[fmlcore-1.18.2-40.2.4.jar%23100!/:?] {}     at net.minecraftforge.fml.core.ModStateProvider.lambda$new$3(ModStateProvider.java:33) ~[forge-1.18.2-40.2.4-universal.jar%23104!/:?] {re:classloading}     at net.minecraftforge.fml.ModLoader.lambda$dispatchAndHandleError$20(ModLoader.java:186) ~[fmlcore-1.18.2-40.2.4.jar%23100!/:?] {} -- Overlay render details -- Details:     Overlay name: net.minecraft.client.gui.screens.LoadingOverlay Stacktrace:     at net.minecraft.client.renderer.GameRenderer.m_109093_(GameRenderer.java:882) ~[client-1.18.2-20220404.173914-srg.jar%2399!/:?] {re:mixin,pl:accesstransformer:B,pl:runtimedistcleaner:A,re:classloading,pl:accesstransformer:B,pl:mixin:A,pl:runtimedistcleaner:A}     at net.minecraft.client.Minecraft.m_91383_(Minecraft.java:1046) ~[client-1.18.2-20220404.173914-srg.jar%2399!/:?] {re:mixin,pl:accesstransformer:B,pl:runtimedistcleaner:A,re:classloading,pl:accesstransformer:B,pl:mixin:APP:bettercombat.mixins.json:client.MinecraftClientAccessor,pl:mixin:APP:bettercombat.mixins.json:client.MinecraftClientInject,pl:mixin:APP:flywheel.mixins.json:PausedPartialTickAccessor,pl:mixin:APP:architectury.mixins.json:MixinMinecraft,pl:mixin:APP:balm.mixins.json:MinecraftMixin,pl:mixin:APP:waterframes.mixin.json:MinecraftMixin,pl:mixin:APP:playerrevive.mixins.json:MinecraftAccessor,pl:mixin:APP:create.mixins.json:client.WindowResizeMixin,pl:mixin:APP:securitycraft.mixins.json:camera.MinecraftMixin,pl:mixin:A,pl:runtimedistcleaner:A}     at net.minecraft.client.Minecraft.m_91374_(Minecraft.java:665) ~[client-1.18.2-20220404.173914-srg.jar%2399!/:?] {re:mixin,pl:accesstransformer:B,pl:runtimedistcleaner:A,re:classloading,pl:accesstransformer:B,pl:mixin:APP:bettercombat.mixins.json:client.MinecraftClientAccessor,pl:mixin:APP:bettercombat.mixins.json:client.MinecraftClientInject,pl:mixin:APP:flywheel.mixins.json:PausedPartialTickAccessor,pl:mixin:APP:architectury.mixins.json:MixinMinecraft,pl:mixin:APP:balm.mixins.json:MinecraftMixin,pl:mixin:APP:waterframes.mixin.json:MinecraftMixin,pl:mixin:APP:playerrevive.mixins.json:MinecraftAccessor,pl:mixin:APP:create.mixins.json:client.WindowResizeMixin,pl:mixin:APP:securitycraft.mixins.json:camera.MinecraftMixin,pl:mixin:A,pl:runtimedistcleaner:A}     at net.minecraft.client.main.Main.main(Main.java:205) ~[client-1.18.2-20220404.173914-srg.jar%2399!/:?] {re:classloading,re:mixin,pl:runtimedistcleaner:A,pl:mixin:A,pl:runtimedistcleaner:A}     at jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:?] {}     at jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:77) ~[?:?] {}     at jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:?] {}     at java.lang.reflect.Method.invoke(Method.java:568) ~[?:?] {}     at net.minecraftforge.fml.loading.targets.CommonClientLaunchHandler.lambda$launchService$0(CommonClientLaunchHandler.java:31) ~[fmlloader-1.18.2-40.2.4.jar%2318!/:?] {}     at cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:37) [modlauncher-9.1.3.jar%235!/:?] {}     at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:53) [modlauncher-9.1.3.jar%235!/:?] {}     at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:71) [modlauncher-9.1.3.jar%235!/:?] {}     at cpw.mods.modlauncher.Launcher.run(Launcher.java:106) [modlauncher-9.1.3.jar%235!/:?] {}     at cpw.mods.modlauncher.Launcher.main(Launcher.java:77) [modlauncher-9.1.3.jar%235!/:?] {}     at cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:26) [modlauncher-9.1.3.jar%235!/:?] {}     at cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:23) [modlauncher-9.1.3.jar%235!/:?] {}     at cpw.mods.bootstraplauncher.BootstrapLauncher.main(BootstrapLauncher.java:149) [bootstraplauncher-1.0.0.jar:?] {} -- Last reload -- Details:     Reload number: 1     Reload reason: initial     Finished: No     Packs: Default, Mod Resources -- System Details -- Details:     Minecraft Version: 1.18.2     Minecraft Version ID: 1.18.2     Operating System: Windows 10 (amd64) version 10.0     Java Version: 17.0.1, Microsoft     Java VM Version: OpenJDK 64-Bit Server VM (mixed mode), Microsoft     Memory: 1178886632 bytes (1124 MiB) / 2113929216 bytes (2016 MiB) up to 2113929216 bytes (2016 MiB)     CPUs: 4     Processor Vendor: GenuineIntel     Processor Name: Intel(R) Core(TM) i3-5005U CPU @ 2.00GHz     Identifier: Intel64 Family 6 Model 61 Stepping 4     Microarchitecture: Broadwell (Client)     Frequency (GHz): 2,00     Number of physical packages: 1     Number of physical CPUs: 2     Number of logical CPUs: 4     Graphics card #0 name: Intel(R) HD Graphics 5500     Graphics card #0 vendor: Intel Corporation (0x8086)     Graphics card #0 VRAM (MB): 1024,00     Graphics card #0 deviceId: 0x1616     Graphics card #0 versionInfo: DriverVersion=     Memory slot #0 capacity (MB): 4096,00     Memory slot #0 clockSpeed (GHz): 1,60     Memory slot #0 type: DDR3     Virtual memory max (MB): 13513,16     Virtual memory used (MB): 10482,60     Swap memory total (MB): 9506,55     Swap memory used (MB): 1887,78     JVM Flags: 8 total; -XX:+UnlockExperimentalVMOptions -XX:+UseG1GC -XX:G1NewSizePercent=20 -XX:G1ReservePercent=20 -XX:MaxGCPauseMillis=50 -XX:G1HeapRegionSize=16M -Xmx2003m -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump     Launched Version: 1.18.2-forge-40.2.4     Backend library: LWJGL version 3.2.2 SNAPSHOT     Backend API: Intel(R) HD Graphics 5500 GL version 3.2.0 - Build, Intel     Window size: 854x480     GL Caps: Using framebuffer using OpenGL 3.2     GL debug messages:      Using VBOs: Yes     Is Modded: Definitely; Client brand changed to 'forge'     Type: Client (map_client.txt)     Graphics mode: fancy     Resource Packs:      Current Language: English (US)     CPU: 4x Intel(R) Core(TM) i3-5005U CPU @ 2.00GHz     ModLauncher: 9.1.3+9.1.3+main.9b69c82a     ModLauncher launch target: forgeclient     ModLauncher naming: srg     ModLauncher services:           mixin PLUGINSERVICE           eventbus PLUGINSERVICE           slf4jfixer PLUGINSERVICE           object_holder_definalize PLUGINSERVICE           runtime_enum_extender PLUGINSERVICE           capability_token_subclass PLUGINSERVICE           accesstransformer PLUGINSERVICE           runtimedistcleaner PLUGINSERVICE           mixin TRANSFORMATIONSERVICE           fml TRANSFORMATIONSERVICE      FML Language Providers:          minecraft@1.0         lowcodefml@null         javafml@null     Mod List:          client-1.18.2-20220404.173914-srg.jar             |Minecraft                     |minecraft                     |1.18.2              |COMMON_SET|Manifest: a1:d4:5e:04:4f:d3:d6:e0:7b:37:97:cf:77:b0:de:ad:4a:47:ce:8c:96:49:5f:0a:cf:8c:ae:b2:6d:4b:8a:3f         player-animation-lib-forge-          |Player Animator               |playeranimator                |1.0.2+1.18          |COMMON_SET|Manifest: NOSIGNATURE         CreativeCore_FORGE_v2.6.16_mc1.18.2 (1).jar       |CreativeCore                  |creativecore                  |0.0NONE             |COMMON_SET|Manifest: NOSIGNATURE         jei-1.18.2-                          |Just Enough Items             |jei                           |           |COMMON_SET|Manifest: NOSIGNATURE         born_in_chaos_Forge1.18.2_1.13.jar                |Born in Chaos                 |born_in_chaos_v1              |1.0.0               |COMMON_SET|Manifest: NOSIGNATURE         FancyVideo-API-forge-                  |FancyVideo API                |fancyvideo_api                |             |COMMON_SET|Manifest: NOSIGNATURE         sophisticatedcore-1.18.2-         |Sophisticated Core            |sophisticatedcore             |1.18.2-   |COMMON_SET|Manifest: NOSIGNATURE         curios-forge-1.18.2-                   |Curios API                    |curios                        |1.18.2-      |COMMON_SET|Manifest: NOSIGNATURE         flywheel-forge-1.18.2-0.6.8.a-99.jar              |Flywheel                      |flywheel                      |0.6.8.a-99          |COMMON_SET|Manifest: NOSIGNATURE         create-1.18.2-0.5.1.b.jar                         |Create                        |create                        |0.5.1.b             |COMMON_SET|Manifest: NOSIGNATURE         waystones-forge-1.18.2-10.2.1.jar                 |Waystones                     |waystones                     |10.2.1              |COMMON_SET|Manifest: NOSIGNATURE         collective-1.18.2-6.55.jar                        |Collective                    |collective                    |6.55                |COMMON_SET|Manifest: NOSIGNATURE         WeaponThrow-1.18.2-5.7.jar                        |Weapon Throw                  |weaponthrow                   |1.18.2-5.7          |COMMON_SET|Manifest: NOSIGNATURE         CTM-1.18.2-1.1.55.jar                             |ConnectedTexturesMod          |ctm                           |1.18.2-1.1.5+5      |COMMON_SET|Manifest: NOSIGNATURE         modernlife-1.18.2-1.54.jar                        |Modern Life                   |modernlife                    |1.18.2-1.54         |COMMON_SET|Manifest: NOSIGNATURE         1.18.2SecurityCraftv1.9.6.1.jar                   |SecurityCraft                 |securitycraft                 |             |COMMON_SET|Manifest: NOSIGNATURE         artifacts-1.18.2-4.2.1.jar                        |Artifacts                     |artifacts                     |1.18.2-4.2.1        |COMMON_SET|Manifest: NOSIGNATURE         CustomPlayerModels-1.18-0.6.8a.jar                |Customizable Player Models    |cpm                           |0.6.8a              |COMMON_SET|Manifest: NOSIGNATURE         elevatorid-1.18.2-1.8.4.jar                       |Elevator Mod                  |elevatorid                    |1.18.2-1.8.4        |COMMON_SET|Manifest: NOSIGNATURE         sophisticatedbackpacks-1.18.2-   |Sophisticated Backpacks       |sophisticatedbackpacks        |1.18.2-  |COMMON_SET|Manifest: NOSIGNATURE         MoreVanillaArmor-1.18.2-3.1.2_1.jar               |MoreVanillaArmor              |morevanillaarmor              |1.18.2-3.1.2        |COMMON_SET|Manifest: NOSIGNATURE         architectury-4.11.93-forge.jar                    |Architectury                  |architectury                  |4.11.93             |COMMON_SET|Manifest: NOSIGNATURE         ftb-library-forge-1802.3.11-build.177.jar         |FTB Library                   |ftblibrary                    |1802.3.11-build.177 |COMMON_SET|Manifest: NOSIGNATURE         item-filters-forge-1802.2.8-build.50.jar          |Item Filters                  |itemfilters                   |1802.2.8-build.50   |COMMON_SET|Manifest: NOSIGNATURE         balm-3.2.6.jar                                    |Balm                          |balm                          |3.2.6               |COMMON_SET|Manifest: NOSIGNATURE         immersive_armors-            |Immersive Armors              |immersive_armors              |1.5.5+1.18.2        |COMMON_SET|Manifest: NOSIGNATURE         VideoPlayer-1.0-RELEASE-1.18.2.jar                |VideoPlayer                   |videoplayer                   |1.0                 |COMMON_SET|Manifest: NOSIGNATURE         ftb-teams-forge-1802.2.10-build.96.jar            |FTB Teams                     |ftbteams                      |1802.2.10-build.96  |COMMON_SET|Manifest: NOSIGNATURE         ftb-quests-forge-1802.3.14-build.191.jar          |FTB Quests                    |ftbquests                     |1802.3.14-build.191 |COMMON_SET|Manifest: NOSIGNATURE         cloth-config-6.4.90-forge.jar                     |Cloth Config v4 API           |cloth_config                  |6.4.90              |COMMON_SET|Manifest: NOSIGNATURE         voicechat-forge-1.18.2-2.4.8.jar                  |Simple Voice Chat             |voicechat                     |1.18.2-2.4.8        |COMMON_SET|Manifest: NOSIGNATURE         bettercombat-forge-                |Better Combat                 |bettercombat                  |1.6.2+1.18.2        |COMMON_SET|Manifest: NOSIGNATURE         soundphysics-forge-1.18.2-1.0.6.jar               |Sound Physics Remastered      |sound_physics_remastered      |1.18.2-1.0.6        |COMMON_SET|Manifest: NOSIGNATURE         forge-1.18.2-40.2.4-universal.jar                 |Forge                         |forge                         |40.2.4              |COMMON_SET|Manifest: 84:ce:76:e8:45:35:e4:0e:63:86:df:47:59:80:0f:67:6c:c1:5f:6e:5f:4d:b3:54:47:1a:9f:7f:ed:5e:f2:90         appleskin-forge-mc1.18.2-2.4.1.jar                |AppleSkin                     |appleskin                     |2.4.1+mc1.18.2      |COMMON_SET|Manifest: NOSIGNATURE         infinitetrading-1.18.2-4.0.jar                    |Infinite Trading              |infinitetrading               |4.0                 |COMMON_SET|Manifest: NOSIGNATURE         RPG_style_more_weapons_4.6.2RF.jar                |RPG_style_More_Weapons        |rpgsmw                        |4.6.2               |COMMON_SET|Manifest: NOSIGNATURE         expandability-6.0.0.jar                           |ExpandAbility                 |expandability                 |6.0.0               |COMMON_SET|Manifest: NOSIGNATURE         CosmeticArmorReworked-1.18.2-v2a.jar              |CosmeticArmorReworked         |cosmeticarmorreworked         |1.18.2-v2a          |COMMON_SET|Manifest: 5e:ed:25:99:e4:44:14:c0:dd:89:c1:a9:4c:10:b5:0d:e4:b1:52:50:45:82:13:d8:d0:32:89:67:56:57:01:53         WATERFrAMES-1.18.2-1.2.0c.jar                     |WATERFrAMES                   |waterframes                   |1.18.2-1.2.0c       |COMMON_SET|Manifest: NOSIGNATURE         PlayerRevive_FORGE_v2.0.13_mc1.18.2.jar           |PlayerRevive                  |playerrevive                  |2.0.13              |COMMON_SET|Manifest: NOSIGNATURE         geckolib-forge-1.18-3.0.57.jar                    |GeckoLib                      |geckolib3                     |3.0.57              |COMMON_SET|Manifest: NOSIGNATURE         emotecraft-for-MC1.18.2-2.2.5-forge.jar           |Emotecraft                    |emotecraft                    |2.2.5               |COMMON_SET|Manifest: NOSIGNATURE         UndeadUnleashed-1.0.3b-1.18.2.jar                 |Undead Unleashed              |undead_unleashed              |1.0.3               |COMMON_SET|Manifest: NOSIGNATURE         enemyexpansion1.13requiresgeckolib.jar            |Enemy Expansion               |enemyexpansion                |1.12.1              |COMMON_SET|Manifest: NOSIGNATURE         corpse-1.18.2-1.0.1.jar                           |Corpse                        |corpse                        |1.18.2-1.0.1        |COMMON_SET|Manifest: NOSIGNATURE         chipped-forge-1.18.2-2.0.1.jar                    |Chipped                       |chipped                       |2.0.1               |COMMON_SET|Manifest: NOSIGNATURE     Flywheel Backend: Uninitialized     Crash Report UUID: 4f21a8e0-8d7b-4225-93a9-f3f3501d162c     FML: 40.2     Forge: net.minecraftforge:40.2.4
    • I'm new to modding, but I've been able to figure out a lot of stuff alone, using the Forge forums, documentation, open-source mods, tutorials. So far so good. But I've now run into an issue that I can't seem to find a solution for on my own. Hoping someone who understands the minecraft worldgen to pitch in.   I've been able to extend Overworld depth (using data packs) by providing a data folder within my mod. Namely, I've had to provide a minecraft/dimension_type/overworld.json and a minecraft/noise_settings/overworld.json, only changing the logical_height, min_y, height fields.   The issue is, a lot of the logic in my mod relies on the world depth, which I would like to be configurable by the mod user. I could have the config affect only my mod logic and leave it to the user to also provide their own datapack, but that's 2 steps. If it was possible to just have 1 step (i.e. config only or datapack only), I would want to implement that. So I would have to find a way where the datapack's fields get their values from config (doesn't seem possible) or I would have to do this in code.   I looked into net.minecraft.world.level.levelgen.NoiseSettings and tried to shadow overworldNoiseSettings and looked into net.minecraft.world.level.dimension.DimensionType and tried to shadow DEFAULT_OVERWORLD. The shadow implementation is simply a copy-paste of the original, save for changing the -64 and 384 values to be fetched from config. This did not work; the world still ends at -64. I know the shadowing works though, because inputting an invalid height in the config causes the game to crash with the invalid height message. It's just that when the world loads under a valid height, it doesn't go beyond -64. I then did a long search and found net.minecraft.world.level.dimension.DimensionDefaults and tried to shadow the OVERWORLD variables. This did not work either; same problem. I looked into so many other classes related to world gen, but they all seemed to directly or indirectly fetch their value from NoiseSettings; so I figured I shouldn't mess with those. I was suspicious of Y_SIZE, MAX_Y, MIN_Y in DimensionType, but when I tried to shadow those, the game crashed at the world creation screen (as soon as you click Singleplayer) with the error saying something about an unbound registry key. If you would like the error log, please let me know. I didn't provide it because I feel like those variables aren't meant to be shadowed.   I feel like I'm doing this very wrong. It's like there is some variable I need to shadow somewhere; but I have very little knowledge of any of this game's code, let alone world gen. Hoping someone with more knowledge could point me somewhere. Is what I'm looking for even possible?   UNRELATED (but might be of help for someone searching the forums in the future): If you run into the MC-237017 issue, where lava aquifers would fill the deeper parts of the world, you can fix it using a mixin to shadow globalFluidPicker of NoiseBasedChunkGenerator.
    • I'm having issues spawning my flying entity in my custom biome, heres what I have currently: Inside my biomes json: "spawners": { "creature": [ { "type": "frv:zephxen", "maxCount": 2, "minCount": 1, "weight": 10 } ] }, "spawn_costs": {},   How I'm calling the SpawnPlacementRegisterEvent:   @SubscribeEvent public static void entitySpawnRestriction(SpawnPlacementRegisterEvent event) { event.register(EntitiesSTLCON.ZEPHXEN.get(), SpawnPlacements.Type.ON_GROUND, Heightmap.Types.MOTION_BLOCKING_NO_LEAVES, Zephxen::checkZephxenSpawnRules, SpawnPlacementRegisterEvent.Operation.OR); }   Finally this is how I registered the entity: public static final RegistryObject<EntityType<Zephxen>> ZEPHXEN = ENTITY_TYPES.register("zephxen", () -> EntityType.Builder.of(Zephxen::new, MobCategory.CREATURE) .sized(2.3f, 2.3f).canSpawnFarFromPlayer().clientTrackingRange(10) .build(new ResourceLocation(STLCON.MOD_ID, "zephxen").toString()));     So the problem/bug that I have is that they do spawn when I teleport to that specific biome they're supposed to spawn, but they only spawn in that area that I've teleported, when I explore my biome further they don't spawn, even if I teleport couple thousand blocks and try again in a new biome, still nothing spawns. And also I did play around with weight and min/max spawn count, it is still the same story.   I'm honestly not really sure what else am I missing, thank you in advance 🙏  
    • Can you please clarify? Would this "hidden_item" be a copy of my offhand item--and, when I delete the offhand item after some time, the "hidden_item" would be placed in a free (non-offhand) slot in my inventory? If so, I have tried that and it did not work; explanation is in my code.
  • Topics

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.