Jump to content

Custom Mod crashed when placing custom fluid and crashes when the world opens with error "Tesselating liquid in world"

Recommended Posts

You don't post all the code so it is difficult to say what the problem is.

The error is caused by some issue with your overlay texture.


I would guess this relates to how Mojang changed it so that block textures are only loaded from the "block" subdirectory by default.

See the section on resource packs here:



Yours is in "fluid" which won't get loaded into the block atlas.


public static final ResourceLocation VITALITY_MEDICINE_RL = new ResourceLocation(Learning.MOD_ID, "fluid/in_vitality_medicine");


Edited by warjort


If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

But the thing is that I tried using "block/water_overlay" instead but still got the same error. I've gone through and checked everything and turns out that using the variables for the colors of the liquid was the issue. But thanks for at least pointing me in the right direction.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.