Jump to content

[1.19.4] I have a slight issue regarding placed features.

Recommended Posts

Hello, in 1.19.4-45.0.40, I'm using the RegistrySetBuilder class to add a method that has a parameter ConfiguredFeature<?, ?>>. However, I'm unable to add it successfully. But in version 45.0.39, I was able to do it without any problems. Do you happen to have any solutions to this issue?

Link to comment
Share on other sites

I have completed everything you mentioned, and here is an example from GitHub: https://github.com/Tutorials-By-Kaupenjoe/Forge-Tutorial-1.19.3/blob/7-treeGeneration

I would like you to look at the two main classes as follows:

ModConfiguredFeatures, located in the package net.kaupenjoe.tutorialmod.worldgen

ModWorldGenProvider, located in the package net.kaupenjoe.tutorialmod.datagen

If you're using version 1.19.4-45.0.39 without updating to 45.0.40, the mentioned code works fine. However, if you switch to version 45.0.40 and try to add the method ModConfiguredFeatures::bootstrap, there will be an immediate issue. It seems like it cannot accept a method with a parameter as an instance, but it can still work properly with an instance that doesn't have an instant parameter, such as BootstapContext<PlacedFeature>.

Link to comment
Share on other sites

On 6/2/2023 at 7:50 PM, ChampionAsh5357 said:

Can you define method that has a parameter in this context? Do you mean your registry object holds a configured feature instance? If so, then your registry must be a datapack registry.

It seems like I made a slight mistake. Now I am able to use it properly. I didn't thoroughly check the data pack and it seems like there was a bug in the error checking of the IDE I was using. I don't blame anyone for this confusion. However, I can still build it even though the IDE is still indicating errors.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now


  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • https://pastebin.com/FaQ43RnJ  Este es un error que me lanza al momento de querer iniciar forge Intente de todo pero no sirve nada. This is an error that I get when I want to start forge. I tried everything but nothing works.
    • It was a stupid Eclipse problem ,the debugger was set to a lower version of java.  In what world would i want my development version different from the debugger version.   ty for looking
    • Caused by: java.lang.NullPointerException: Cannot read field "level" because "this.minecraft" is null This is my first big error when coding. I looked it up, but there are a bunch of references to Dawncraft and not enough to figure out what was going wrong. I found this, but it involves a command and my GUI only opens when you shift + right-click while holding an item. They fixed it by not calling it with a command, but I am not using a command. Here's the render of my menu, which is the only part that changed between it working and not:   @Override public void render(@Nonnull PoseStack mstack, int mouseX, int mouseY, float partialTicks) { int midx = this.width / 2; int midy = this.height / 2; this.renderBackground(mstack); drawCenteredString(mstack, font, I18n.get("config.shape_tool"), midx, 4, 0xC3D1D8); Utils.renderImage(midx - 12, midy, 20, 20, "textures/gui/plus.png", mstack); addRenderableWidget(new Button(midx - 12, midy, 10, 10, Component.translatable(""), this::increaseax)); Utils.renderImage(midx + 12, midy, 20, 20, "textures/gui/minus.png", mstack); addRenderableWidget(new Button(midx + 12, midy, 10, 10, Component.translatable(""), this::decreaseax)); drawCenteredString(mstack, font, String.valueOf(shapetoolax), midx, midy + 10, 0xC3D1D8); super.render(mstack, mouseX, mouseY, partialTicks); } Utils.renderImage is this:   public static void renderImage(int x, int y, int width, int height, String img, PoseStack mstack) { RenderSystem.setShaderColor(1, 1, 1, 1); RenderSystem.enableBlend(); RenderSystem.defaultBlendFunc(); RenderSystem.setShaderTexture(0, new ResourceLocation(PNegative.MODID, img)); blit(mstack, x, y, 0, 0, width, height, width, height); RenderSystem.disableBlend(); } I have used it before and it has worked, so it can't be a problem. 
    • I found a topic  with the very simmilar problems. I run modpack Direwolf20 1.19.2 version from FTB with dedicated server with my friends and i am the only who have this type of crashes. It has been through login process and after 5-6 crashes i can connect. And randombly it could crash me in game but mostly when i am tp'ing using Nether portals etc. I already setted up all privileges for javaw in firewall, flushed dns, reset network settings and etc. Changed java version to from FAQ too. Here's some logs from client side https://gnomebot.dev/paste/1158502890168664194 https://gnomebot.dev/paste/1158187264657063946    
    • Don't know why game keeps crashing after a few seconds or walking towards something, tried removing larger mods and someaddon performance mods but it's not working. Minecraft launchers telling me "Exit Code 1"
  • Topics

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.