Jump to content

Unable to set RAM of server. "Adv. terminal features r not available in this environment."(1.20.1/47.2.0)


Recommended Posts

I can play my server & others can connect to it but it cannot load certain chunks & times out because it's bottlenecked by the default 4GB. I know this to be the case because when copy+pastaing the exact server world into curseforge singleplayer with 8G+, all the heavy chunks load in fine. 
I have JavaSDK 17.0.9 x64-bit & reinstalled twice already as well as trying with Java 8 also installed & without. 
I tried using: java @user_jvm_args.txt @libraries/net/minecraftforge/forge/1.20.1-47.2.0/win_args.txt %*
but all that gives me is: Error: Could not find or load main class java
Caused by: java.lang.ClassNotFoundException: java 
Any ideas or help would be appreciate. 

Link to comment
Share on other sites

Hm. I did try adding that in the user_jvm_args.txt but I get this: 
Error: Could not find or load main class C:Program FilesJavajdk-17.0.9binjavaw.exe
Caused by: java.lang.ClassNotFoundException: C:Program FilesJavajdk-17.0.9binjavaw.exe
Press any key to continue . . .

I tried both with "\jdk-17\" (as it appears in the program files) as well as "\jdk-17.0.9\" 
No luck. am I placing it in the wrong file? Could the second part be incorrect? 

Link to comment
Share on other sites

Yep. I just don't know. I get this still when I run the batch. 
Error: Could not find or load main class C:Program FilesZuluzulu-17binjavaw.exe
Caused by: java.lang.ClassNotFoundException: C:Program FilesZuluzulu-17binjavaw.exe
Press any key to continue . . .

I also double-checked & made sure that I was using the 64-bit one for my computer & that the file path was correct. It was. Is it my actual run.bat that could be the issue? Or do I have messed up associations from having downloaded different javas even though I uninstalled them through control panel? idk. I'm not that savvy. 

Link to comment
Share on other sites

Okay. Thank you. I think it works now. I added the jdk-17 path to the batch instead of the jvm arguments txt file. The windows command prompt is just blank, but when I close the native windows command prompt, the java command prompt opens & loads the server. If that won't cause issues then I'm all good. 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.