Jump to content

These 2 Errors do not let join my locally hosted server 80% of the time.


Recommended Posts


I have been currently having this issue where if I join my server, I get one of these 2 errors.
I have tried fixing this issue by looking at the output log in both Server and Client side, from what I have seen I was not able to find anything I can understand that would have helped me.
These two errors pop up randomly with no pattern when attempting to join the server when it says Encrypting...
I have tried removing all mods from the Client and Server side, which did nothing and still showed the same errors (I don't remember which error showed or even if it showed both), so from what I tried to do, I do not think this is a mod Issue but rather a Forge Issue.

How do I fix this?
Here are the errors and all the information:

Internal Exception: java.lang.NoClassDefFoundError: com/google/common/util/concurrent/TrustedListenableFutureTask
Debug.log: https://www.mediafire.com/file/hbtycb1tamqt1qr/debug2.log/file
(PS: Debug.log file cannot be uploaded to Pastebin due to it crashing because of the Large Amount of Spam OpenGL logs)

Internal Exception: Internal Exception: java.lang.NoClassDefFoundError: com/google/common/collect/LinkedHashMultiMap$ValueSet
Debug.log: https://www.mediafire.com/file/o1d48z0bjfyff1e/debug.log/file
(PS: Debug.log file cannot be uploaded to Pastebin due to it crashing because of the Large Amount of Spam OpenGL logs)

Client Mods:

Server Mods:

Edited by invis7
Link to comment
Share on other sites

It didn't work with the antivirus disabled.
Internal Exception: Internal Exception: java.lang.NoClassDefFoundError: com/google/common/collect/LinkedHashMultiMap$ValueSet.

Do you think that this issue can be solved if, instead of locally hosting it, maybe hosting on a cloud service provider.

Link to comment
Share on other sites

Check for Intel/Nvidia driver updates


If there is no change, maybe a mod is conflicting with the CPU/GPU or some OpenGL features of it


Maybe make a test with a similar large modpack and check if there are the same issues

Link to comment
Share on other sites

I have no idea - maybe an issue with the internet or java or something similar


java.lang.NoClassDefFoundError: com/google/common/net/InetAddresses
java.lang.NoClassDefFoundError: com/google/common/util/concurrent/NullnessCasts


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.