Jump to content

Unable to install Forge Server 1.19.2 for FTB Skies Expert


Recommended Posts

java.lang.NullPointerException: Cannot invoke "java.util.List.stream()" because the return value of "net.minecraftforge.installer.DownloadUtils.getIps(String)" is null.

I can see all over the place that there are issues with someone mojang changed regarding DNS, however, I have also seen that 'downloading new installer will fix the issue'

First off, I want to thank the FTB team for their diligence in working through this.

With that said, I can't get past this and have re-downloaded a new version of the server installer numerous times to no avail, here: https://api.modpacks.ch/public/modpack/117/11701/server/linux

I've also tried downloading just the new Forge from here: https://files.minecraftforge.net/net/minecraftforge/forge/index_1.19.2.html, however it states it has not been updated in 17 days.

Is there anyone that can point me in the right direction?

Link to comment
Share on other sites

All the Forge installers have been fixed - if you redownload an installer from the Forge files site it should work.

The last updated reflects when the build was published, not when the installer for the build was fixed (otherwise it would show as ~4.5k builds worth of Forge all being released today :P)

Link to comment
Share on other sites

Just tried it again removed directory entirely, downloaded a brand new, fresh copy and did a fresh install, even going as far as running as root for the install to make sure I didn't hose something up permissions wise (I know its a terrible idea.), but same thing, failed install.

This is making me feel mighty dumb, I must say... any help anyone could provide would be greatly appreciated.

Link to comment
Share on other sites

In case anyone happens on this with the same issue, I was able to overcome it.

After re-reading @Paint_Ninja's last post numerous time, it finally dawned on me that he was referring wholly to the forge installer, which has nothing to do with the packaged modpack installer. As such, I downloaded the new copy of the forge installer and copied it to my linux host, then opened a second ssh session and prepared a cp command to move the new (correct) installer over to the install directory where I was installing the modpack. After the modpack installer had just about finished retrieving files, I overwrote the installer.jar file with the correct one in a seperate ssh session.

The modpack (packaged) installer then used that jar to install forge with the included files, and the install finished as I would have expected.

Thanks all!

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.