Jump to content

[1.19.2] consumeClick() not working as intended? (SOLVED)


Recommended Posts

I'm trying to have some code run on the tick that certain keybinds are initially pressed; I'm doing this in a ClientTickEvent event, and here's my code:

        public static void playerInputSignatureHandler(TickEvent.ClientTickEvent event) {
            LocalPlayer player = Minecraft.getInstance().player;
            if (player == null) {return;}
            if (player.isSpectator()) {return;}

            ((IAbilityActivatingEntity) player).greater_adventures$setTimeSinceLastInput(
                    ((IAbilityActivatingEntity) player).greater_adventures$getTimeSinceLastInput() - 1

            if (((IAbilityActivatingEntity) player).greater_adventures$getTimeSinceLastInput() <= 0) {
                ((IAbilityActivatingEntity) player).greater_adventures$resetInputSignature();

            if (event.phase == TickEvent.Phase.END) {
                while (Minecraft.getInstance().options.keyLeft.consumeClick()) {
                    if (((IAbilityActivatingEntity) player).greater_adventures$getTimeSinceLastInput() > 0) {return;}
                    if (((IAbilityActivatingEntity) player).greater_adventures$getInputSignature().contains("key.left")) {return;}

                    ((IAbilityActivatingEntity) player).greater_adventures$addToInputSignature("key.left"); // Mixins

                    player.setDeltaMovement(0, 0.2, 0); // This line is for in-game testing purposes.
	// This method is going to be used several times in the future.
        private static void setPlayerInputTime(LocalPlayer player) {
            ((IAbilityActivatingEntity) player).greater_adventures$setTimeSinceLastInput(10);

I was following the forge docs for some of this. I thought consumeClick() is supposed to return true upon the initial key press, but here the code runs as long as the keybind is held down, and I have no idea why.

Any help is appreciated

Edited by EveryBlu
Link to comment
Share on other sites

I'm on 1.20.2, so this event might not exist for you, but I'm listening to this event:


Then doing

if(event.getAction() == InputConstants.PRESS && event.getKey() == Minecraft.getInstance().options.keyJump.getKey().getValue()) {
    // do something on jump pressed

and it's working great.


If you want to keep using TickEvent.ClientTickEvent, you could do .isDown() instead of .consumeClick()

Link to comment
Share on other sites

  • EveryBlu changed the title to [1.19.2] consumeClick() not working as intended? (SOLVED)

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.