Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Vanilla bug work-around in chunk regeneration


keybounce
 Share

Recommended Posts

So tonight, I located an annoying bug. I have been going crazy on this for a few days. It turns out to be a vanilla bug.

 

When chunks regenerate, they don't regenerate structures properly. The issue appears to be with entities.

 

Specifically, in villages, neither villagers, nor chests in the smithy, nor lecterns in mystcraft huts, will be regenerated. Towns become ghost towns. And while I have not checked temples/pyramids/mineshaft chests/fortress blaze spawners (all of which are entities or tile entities), I do have concerns.

 

Yet if the structure file is removed, then everything is regenerated just fine.

 

So the idea: Since this appears to be some sort of vanilla bug -- when generating the chunks that have structure information, not everything gets regenerated -- perhaps forge can come up with some way to either fix this (unlikely; it would mean patching every generation routine), or else a way to remove structure entries for a chunk before regenerating that chunk (might be a simple and universal fix).

Jeb! The sheep! The fence pens, they do nothing still leak!

Link to comment
Share on other sites

The old saying applies: If you want something done and it's simple enough, make a PR.

Though, cpw/Lex are only accepting 1.7 PRs unless it's important enough.

Read the EAQ before posting! OR ELSE!

 

This isn't building better software, its trying to grab a place in the commit list of a highly visible github project.

 

www.forgeessentials.com

 

Don't PM me, I don't check this account unless I have to.

Link to comment
Share on other sites

There is a huge difference between knowing how to code, and knowing how to set up a forge development environment and how to make a pull request.

 

And even then, this is the suggestions board, not the "here's a proposed improvement to the codebase" area.

 

Frankly, the issue gets even better with 174. Imagine regenerating chunks, finding that it's generating a hilly colored clay biome, and in the middle of the mesa there are sandstone buildings 30 or 40 meters down inside the hillside with some airgaps around the edges and the buildings themselves buried... all the more reason to wipe out the old structure data for the chunk before regenerating the chunk.

 

Jeb! The sheep! The fence pens, they do nothing still leak!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • and what is called OreFeatureConfig, while making ore gen
    • I have been trying to download Forge but the Windows Installer isn't coming up, I can see the installer one would use for Linux but no Windows, I have downloaded Java and Jarfix but nothing is working, can someone help?  
    • So I thought that when a capability is attached to an item/entity/etc... the capability will stay until whatever it's attached to is gone. But this doesn't seem to be the case, as when I printed to console whenever a capability is attached, it seems as though a new version of the capability is attached to an item every time I select it in my hotbar, hover over it in inventory, etc. Is this how it's supposed to work? If so, why?
    • Hi, I'm trying to set up a simple forge server just to play with a couple of my friends, but no matter what I do or try I cannot seem to get a Mods folder and for the actual forge part of the server to actually launch. Every time I try to launch the forge.jar via a .bat file I just get a bunch of errors [Errors below] I'm not sure what I'm doing wrong. If I can get some help that would be awesome, thanks C:\Users\User\Desktop\Server>java -Xms2G -Xmx6G -jar forge-1.12.2-14.23.5.2855.jar nogui A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException         at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)         at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:78)         at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)         at java.base/java.lang.reflect.Method.invoke(Method.java:567)         at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:70)         at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:34) Caused by: java.lang.ClassCastException: class jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to class java.net.URLClassLoader (jdk.internal.loader.ClassLoaders$AppClassLoader and java.net.URLClassLoader are in module java.base of loader 'bootstrap')         at net.minecraft.launchwrapper.Launch.<init>(Launch.java:34)         at net.minecraft.launchwrapper.Launch.main(Launch.java:28)         ... 6 more C:\Users\User\Desktop\Server>pause Press any key to continue . . .  
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.