Jump to content

Mixin works in development environment but not in normal Minecraft


Recommended Posts

Posted (edited)

Hi, I'm trying to get into Mixin.

My test code accesses the private attribute fps in the Minecraft class.
In the development environment (IntelliJ), it outputs the FPS, as I expected it would.
But when I try it in the normal Minecraft, it crashes, and I'm not sure why.

The Mixin Code:

@Mixin(Minecraft.class)
public interface MinecraftMixin {

    @Accessor("fps")
    int getFps();
}

How I call the mixin code:

@SubscribeEvent
public void onTick(ClientTickEvent event) {

    if (Minecraft.getInstance().player == null) {
        return;
    }

    if (Minecraft.getInstance().player.isCrouching()) {
        int test = ((MinecraftMixin)Minecraft.getInstance()).getFps();
        LOGGER.info(String.valueOf(test));
    }
}

Crashlog:

https://paste.ee/p/PtO7B

Edited by Top-Set98

🐟🐠🐡

Link to comment
Share on other sites

On 5/28/2024 at 5:55 PM, a_random_something said:

Having the same problem. Could you let me know if you ever figure it out? :)

If I find something, of course.

 

I have tried a bit but I can't get mixin to run on 1.20.6 even with the latest version: 1.20.6 - 50.1.1.

🐟🐠🐡

Link to comment
Share on other sites

  • 2 weeks later...

I figured it out! Here's how I solved it:

I added:

"refmap": "<your_mod_id>.mixins.refmap.json" to my mixin json file and that solved it. You'll also need to add:

add sourceSets.main, '<your_mod_id>.mixins.refmap.json' to your build.gradle in the "mixin" block

 

my mixin file looks like this:

 

{
  "required": true,
  "minVersion": "0.8",
  "package": "<your_package>.<your_modid>.mixin",
  "compatibilityLevel": "JAVA_16",
  "refmap": "<your_mod_id>.mixins.refmap.json",
  "mixins": [
    "YourMixin1",
    "YourMixin2"
  ],
  "client": [
  ],
  "injectors": {
    "defaultRequire": 1
  }
}

This was in 1.19.2, but I don't think it should be too different

Edited by a_random_something
Link to comment
Share on other sites

Posted (edited)

My sample mod has the refmap in the mixin json file as well as "add sourceSets.main" in the "mixin" block. It is like in the documentation.

 

mixin json:

{
    "required": true,
    "minVersion": "0.8",
    "package": "com.example.examplemod.mixin",
    "compatibilityLevel": "JAVA_17",
    "refmap": "mixins.ExampleMod.refmap.json",
    "mixins": [
      "MinecraftMixin"
    ],
    "injectors": {
      "defaultRequire": 1
    }
  }

 

mixin block in build.gradle


mixin {
    // MixinGradle Settings
    add sourceSets.main, 'mixins.ExampleMod.refmap.json'
    config 'mixins.ExampleMod.json'
}

 

On 6/18/2024 at 12:41 AM, a_random_something said:

This was in 1.19.2, but I don't think it should be too different


I tried it on another Minecraft version (1.19.2 and 1.20.1) and it works.
As soon as I try Minecraft version 1.20.6 or higher it does not work anymore.

Edited by Top-Set98

🐟🐠🐡

Link to comment
Share on other sites

  • 3 weeks later...

Try modify the build.gradle by:

1. Add 

'MixinConfigs'            : "${mod_id}.mixins.json"

to the attributes array

tasks.named('jar', Jar).configure {
    manifest {
        attributes([
				....
		  ])
    }
}

2. Add a new block after the mixin block

sourceSets {
    main {
        ext.refMap = "${modid}.refmap.json"
    }
}

 

  • Thanks 1
Link to comment
Share on other sites

On 7/13/2024 at 3:13 AM, Top-Set98 said:

Does the development environment load the MixinConfigs automatically or why is it only needed for normal Minecraft?

The compiler seems could auto load the MixinConfigs in the version below 1.20.6, but it didnt work from 1.20.6. I just modified the jar file to zip and found the META-INF/MANIFEST.MF is lack of "MixinConfigs" compared with the lower version, while the build.gradle are same. So I manual added it to fix the problem.

I dont know the implmentation of this process, but a different is in 1.20.6 the jar task deleted the reobfJar task, maybe this leads the problem?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.