Jump to content

Forge server mods not working

Recommended Posts

The server loads perfectly fine, but the mod's don't work. They are in the folder but don't load in or interact at all with the server. I've tried using a server pack, but same result.


The latest.log


[08:21:34] [Server thread/INFO]: Starting minecraft server version 1.12.2
[08:21:34] [Server thread/INFO]: Loading properties
[08:21:34] [Server console handler/ERROR]: Exception handling console input
java.io.IOException: The handle is invalid
    at java.io.FileInputStream.readBytes(Native Method) ~[?:1.8.0_401]
    at java.io.FileInputStream.read(Unknown Source) ~[?:1.8.0_401]
    at java.io.BufferedInputStream.read1(Unknown Source) ~[?:1.8.0_401]
    at java.io.BufferedInputStream.read(Unknown Source) ~[?:1.8.0_401]
    at sun.nio.cs.StreamDecoder.readBytes(Unknown Source) ~[?:1.8.0_401]
    at sun.nio.cs.StreamDecoder.implRead(Unknown Source) ~[?:1.8.0_401]
    at sun.nio.cs.StreamDecoder.read(Unknown Source) ~[?:1.8.0_401]
    at java.io.InputStreamReader.read(Unknown Source) ~[?:1.8.0_401]
    at java.io.BufferedReader.fill(Unknown Source) ~[?:1.8.0_401]
    at java.io.BufferedReader.readLine(Unknown Source) ~[?:1.8.0_401]
    at java.io.BufferedReader.readLine(Unknown Source) ~[?:1.8.0_401]
    at nz$2.run(SourceFile:100) [minecraft_server.1.12.2.jar:?]
[08:21:34] [Server thread/INFO]: Default game type: SURVIVAL
[08:21:34] [Server thread/INFO]: Generating keypair
[08:21:34] [Server thread/INFO]: Starting Minecraft server on *:25565
[08:21:34] [Server thread/INFO]: Using default channel type
[08:21:36] [Server thread/INFO]: Preparing level "world"
[08:21:37] [Server thread/INFO]: Loaded 488 advancements
[08:21:37] [Server thread/INFO]: Preparing start region for level 0
[08:21:38] [Server thread/INFO]: Preparing spawn area: 4%
[08:21:39] [Server thread/INFO]: Preparing spawn area: 10%
[08:21:41] [Server thread/INFO]: Preparing spawn area: 28%
[08:21:41] [Server thread/INFO]: Done (5.662s)! For help, type "help" or "?"
[08:21:57] [Server thread/INFO]: Stopping server
[08:21:57] [Server thread/INFO]: Saving players
[08:21:57] [Server thread/INFO]: Saving worlds
[08:21:57] [Server thread/INFO]: Saving chunks for level 'world'/overworld
[08:21:57] [Server Shutdown Thread/INFO]: Stopping server
[08:21:57] [Server Shutdown Thread/INFO]: Saving players
[08:21:57] [Server Shutdown Thread/INFO]: Saving worlds

As you can see, it loads as normal. but no mods were loaded.

Link to comment
Share on other sites

Posted (edited)

How can I fix this? This makes perfect sense! What do I do, though? I have the mods folder and a forge version in the same folder as the minecraft-server 1.12.2.jar.

Edited by 20201453
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.