Jump to content

Outdated version of JRE for forge 1.8.9 causes issues via accessing trusted sites.


Whiteout12

Recommended Posts

Hello, I am writing about an issue I have been experiencing whilst modding for forge 1.8.9.

A few days ago I started modding my small own mod using the 1.8.9 version of forge. everything worked smooth & fast, and no issues occurred.

after giving my friend the mod to test it out, it kept crashing & crashing, and upon inspection in the logs, I saw that I had an error while trying to access an endpoint on my site.

I happened to use a site provider to load data from my api site, which is not certified in java version "1.8.0_51" of the "Java HotSpot(TM) 64-Bit Server VM".

Upon further inspection, I found out that the reason the mod worked fluidly inside my IDE, (and also inside the modrinth app, ) was that they use java version "1.8.0_202" of the "Java HotSpot(TM) 64-Bit Server VM"

The difference over here is minor, they both use the JRE of the java HotSpot server, using java 8, but the difference between them is

"1.8.0_51" vs "1.8.0_202" -> modrinth & my IDE both use the new small version with the new patches, & forge normally installs on an older instance of this same version.

When taking a look inside .\jre1.8.0_202\lib\security\cacerts (modrinth & intellij idea normal) and .\jre-legacy\lib\security\cacerts (forge normal) I noticed that the caret file forge uses is indeed lighter in size, leading even more evidence to this assumption.

 

An explanation the error:

When establishing a connection with a site using HttpURLConnection, java checks through its certified list to make sure the website is secure, at this part all of the above information comes into play and the error fires:

Error executing task
java.util.concurrent.ExecutionException: java.lang.RuntimeException: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
    at java.util.concurrent.FutureTask.report(FutureTask.java:122)

Key part: "unable to find valid certification path in ..."

The mod fails to create a connection with the site *only in this particular version of java*.

 

The current site provider is pythonanywhere, which allowed me to set up a website using a python backend for free (hence, why used).

 

There is a chance I was wrong about "blaming it on forge", but only while using it and not vanilla minecraft, I got the log about the java version (The one that stated what version I am using).

Please let me know if there is anything I can do in the situation, even pointing me into another place to address my issue, really all help appriciated.

Kind regards, Whiteout12.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.