Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.6.4]How to make a spawn egg


starwarsmace
 Share

Recommended Posts

EntityList.addMapping(EntityClayGolem.class, "Clay Golem", 3, 13347172, 7033635);

 

Those last two ints are the decimal representation of the egg colors.  The first one, IIRC is the base color, the second is the spots.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

EntityList.addMapping(EntityClayGolem.class, "Clay Golem", 3, 13347172, 7033635);

 

Those last two ints are the decimal representation of the egg colors.  The first one, IIRC is the base color, the second is the spots.

 

Thanks but what is the first int?

 

Edit: Nvm I found out its the id for you entity.

I'm back from being gone for... I think its been about a year. I'm pretty sure nobody remembers me, but hello anybody who does!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • From some testing it seems to have been due to my spawn.json from incontrol. I find it odd though since it didn't do much, if anything. It seems to have caused, not only a crash, but stopped new worlds from being created(it froze at like 0%).
    • After a lot of digging, I've concluded the best way to go about this is not combining textures, as that is impossible during runtime, but to add a render layer. I've been trying to understand how the rendering works, but I don't know what buffers are, like this one in HorseMarkingLayer: public void render(PoseStack p_117058_, MultiBufferSource p_117059_, int p_117060_, Horse p_117061_, float p_117062_, float p_117063_, float p_117064_, float p_117065_, float p_117066_, float p_117067_) { ResourceLocation resourcelocation = LOCATION_BY_MARKINGS.get(p_117061_.getMarkings()); if (resourcelocation != null && !p_117061_.isInvisible()) { VertexConsumer vertexconsumer = p_117059_.getBuffer(RenderType.entityTranslucent(resourcelocation)); this.getParentModel().renderToBuffer(p_117058_, vertexconsumer, p_117060_, LivingEntityRenderer.getOverlayCoords(p_117061_, 0.0F), 1.0F, 1.0F, 1.0F, 1.0F); } } If this is a Java question, let me know, but any help is appreciated!
    • This is not a forge issue. You have a problem with your java installation. You should reinstall it, but java 7 is very old. Too old for the currently supported forge versions, 1.16.5 needs java 8 and later versions need java 16 or 17 Curseforge has an option in the minecraft java settings to automatically download and use a java version that is suitable for the version of minecraft used by the modpack. Enable that and see if it fixes your problem. 
    • I have CurseForge for Minecraft Mods, and in the start I download RlCraft and all was okay but, one day I tried to download another modpack and just said this: https://1.bp.blogspot.com/-D0XHOP1c7Ss/VhKcuLaPJgI/AAAAAAAAD5k/5DOku_KUG0E/w1200-h630-p-k-no-nu/JVM%2BError%2BEclipse%2BJava.png I tried to enter the file that said there, but I can't (maybe not exist and that is the problem) I don't know how to fix it Also, when I just "accept" it installs the mod pack and when I tried to play it appear the same and when I "accept" for a second time It starts minecraft but in minecraft said that occurred an error (Error: 1) and can be a problem of java files. So I just don't know what to do. HELP!!
    • If you can reproduce the problem somewhere else, post the log from when you try to place the block. It might show an error or other useful information.
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.